Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Low Beam Problem

My new Roadster has a problem with the TRS Xenon low beams.
I initially thought it was just a broken bulb but that did not solve the problem - no light.

Maybe the ballast or canbus adapter is broken?

As far as I can tell there are three parts in sequence:
1. A black box labeled Morimoto 3Five DSP
2. A black heat sink type thing (also labeled Morimoto
3. The bulb

I am tempted to go LED ....
What can I do to ensure the replacement works and which of these boxes/heatsinks have to go?
DSC_0123.JPG
 
I ended up replacing the bulbs with Xenon ones.
Would have loved to go LED but looks like the TRS projector won't allow that. Even the replacement bulb barely fit and it reqired sawing off some plastic parts.

Either my ballast or igniter stopped working after switching both out, the new bulb worked perfectly.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top