Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

M3 won't remember a name given to a Key card

Mark-R

Member
Jan 28, 2020
313
514
Shropshire, UK
Apologies if this has been covered elsewhere, but a quick forum search didn't come up with anything.

It is possible to give a Key card a name by clicking on the pen (e.g. 'Wallet' in the example below). However, the name reverts back to 'Key card' after a few minutes. Is this 'normal' or just my M3? Is there a way to make it keep a given name?

Key-card.jpg
 
  • Informative
Reactions: UnicornDriver

cypho

Member
Dec 20, 2018
801
991
USA
I haven't tried renaming a keycard recently but it worked when I did it a few months ago. Have you tried rebooting?
 

VanillaAir_UK

Well-Known Member
Jun 17, 2019
8,465
6,000
Surrey, UK
Has this been fully resolved yet?

I noticed yesterday that a set of key cards registered to the car had reverted back to 'key card'. Looks to be the original set which I am sure due to the above bug I had to rename back so they must have subsequently lost their name again at some point. A later set seem OK.
 

Mark-R

Member
Jan 28, 2020
313
514
Shropshire, UK
Has this been fully resolved yet?

I noticed yesterday that a set of key cards registered to the car had reverted back to 'key card'. Looks to be the original set which I am sure due to the above bug I had to rename back so they must have subsequently lost their name again at some point. A later set seem OK.

I have just tested my two cards and they both still have the names I gave them quite a while ago. I don't use them as my iPhone Xs has (so far) been 100% reliable, but I carry one key card in my iPhone case just in case.
 

VanillaAir_UK

Well-Known Member
Jun 17, 2019
8,465
6,000
Surrey, UK
I've just gone to test and getting mix results. We have 4 cards, 2 were "Key card" and 2 were named as expected.

I renamed both the "key card" ones - they had been named a couple of times in the past so shouldn't be "key card". I then exited back to nav screen then returned back to the lock menu. In front of my eyes, the renamed card that I could see on screen, reverted from the name back to "keycard". I scrolled down to the other one, and that keycard had also reverted. The other two key cards remained correctly named.

Weird. Watch name of 2nd key down. 2020.44.15

I suspect I'll end up deleting then re adding.


First youtube video, so fingers crossed it works
 
Last edited:

Traguar

Member
Jan 20, 2020
106
77
London
Mine's always done this since I bought it in March - cannot rename the keycards or the Telsa rings we have. Keep trying it over many updates but always the same.
 

Mark-R

Member
Jan 28, 2020
313
514
Shropshire, UK
I've just gone to test and getting mix results. We have 4 cards, 2 were "Key card" and 2 were named as expected.

I renamed both the "key card" ones - they had been named a couple of times in the past so shouldn't be "key card". I then exited back to nav screen then returned back to the lock menu. In front of my eyes, the renamed card that I could see on screen, reverted from the name back to "keycard". I scrolled down to the other one, and that keycard had also reverted. The other two key cards remained correctly named.

I recently bought a couple of spare key cards so have just tested addding these two and I'm getting the same behaviour as you i.e. the 'original' two cards still have the names I gave them a while ago, but if I rename the new ones they revert back to "Key card". :confused:
 
  • Helpful
Reactions: VanillaAir_UK

VanillaAir_UK

Well-Known Member
Jun 17, 2019
8,465
6,000
Surrey, UK
I recently bought a couple of spare key cards so have just tested addding these two and I'm getting the same behaviour as you i.e. the 'original' two cards still have the names I gave them a while ago, but if I rename the new ones they revert back to "Key card". :confused:

Thanks for testing. Oddly, its our original key cards that are reverting, the slightly newer ones are the ones sticking. We have had both sets for at least a year and all were originally working fine until about the time this thread started so assume it was same firmware release that broke things.

I wonder if there is a limit for number of keys that can be names, although doubtful that we have broken it as they use to work. Functionality has definitely regressed and unless I am doing something wrong, I cannot think of any reason why it now works differently.

Sounds like its not worth going through delete/repair if its still doing it on newly paired cards.
 

ElRey

Member
Aug 6, 2020
235
73
London
Mine's always done this since I bought it in March - cannot rename the keycards or the Telsa rings we have. Keep trying it over many updates but always the same.

I only ever tried renaming the ring I had and it never kept the name. I tried after the last update and it seemed to work. The only thing I did different was use just one word without a space. Not sure if that made a difference or if it had just been fixed.
Saying that, I haven't checked it in a week and will check later today to see if it's reverted to default.
 

MadScientist

Member
Apr 23, 2020
259
144
Salisbury, UK
Moderator comment - posts merged from "Key card renaming"

I’ve read in a previous thread that it’s difficult to rename the key cards and I’ve been unsuccessful after several attempts. The name keeps reverting back to Key Card after power down. I also tried deleting one card and reinstalling it with the same result.

I was a bit surprised when I bought two additional cards and found they behaved differently. Firstly, they were both recognised as ‘unknown keys’ and secondly, I was able to rename them both OK. They both seem to work perfectly so I assume it’s OK that they are not recognised as cards?

Does anyone see the same and what’s going on here? Are the two original card’s data treated differently in some way?
 
Last edited by a moderator:

X-Chris

Member
Nov 21, 2020
65
37
VA
Not in UK but same difficulties. Found that I had to rename keys a few times for it to stick.

Both cards still show as type “unknown key” and I haven’t been able to fix that.

Even tried removing them and adding them back in. No dice.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top