TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

Mark Forums Read

Discussion in 'Site Feedback' started by palmer_md, May 26, 2016.

  1. palmer_md

    palmer_md Member

    Joined:
    Sep 26, 2012
    Messages:
    718
    Location:
    Sacramento, CA
    I have a few sections of the forum that I watch. Once in a while I am away for a short while and there are a lot of posts, and I use the Mark Forums Read button to clear out all the markings for new posts since it would take too long to read them all.

    Unfortunately the Model 3 section of the forum seems to have this second menu missing and so I cant perform this function. It would be nice to have it since it is probably the most used section recently and it is a pain to open every single thread.

    Different topic, but I did not see a post for this either, but when viewing the forum on an iPhone, the little menu with my profile, conversations, alerts and search seems to move down into the reading area of the post. It obscures some of the text, but even more so it seems to block that entire section from being clickable. If there is a link in the post and it is to the left of these icons, you can not click it unless you pan it below this row of icons. I really see no need to have these icons stay visible when we "zoom" with the iPhone. They should just scroll up off of the screen like the other menu items do.
     
  2. palmer_md

    palmer_md Member

    Joined:
    Sep 26, 2012
    Messages:
    718
    Location:
    Sacramento, CA
    @doug Have any of the forum admins read this. Seem like a simple request to have the menu on the Model 3 work the same as the rest of them. In fact the Model 3: ordering, production and delivery subform has this sub-menu, just not the main Model 3 forum section.
     
  3. danny

    danny Administrator

    Joined:
    Aug 15, 2006
    Messages:
    738
    Can you perhaps provide a screenshot where you point out what is not "clickable". I'm having trouble understanding exactly what you mean.

    Thanks.
     
  4. danny

    danny Administrator

    Joined:
    Aug 15, 2006
    Messages:
    738
    Implemented a temporary fix for this.
     
  5. palmer_md

    palmer_md Member

    Joined:
    Sep 26, 2012
    Messages:
    718
    Location:
    Sacramento, CA
    Awesome. I see you found it and made the change. It works perfect. Thanks for looking into it.

    Michael
     
  6. palmer_md

    palmer_md Member

    Joined:
    Sep 26, 2012
    Messages:
    718
    Location:
    Sacramento, CA
    image.png

    Here is a screen capture. The menu that normally resides in the upper right for my profile conversations and alerts and search seems to pull down below the main header. It becomes obscured because it blends with the other content behind it.

    The link that says model s ordering production and delivery is not clickable at this point because that entire line is part of the menu (I assume). You can see my menu to the right of it covering up the most recent comment.

    It's just a bit annoying to have a large section of the menu disabled (especially if I zoom in more to make the links easier to click with the touch screen (needed to make sure I don't accidently select the wrong one. When zoomed this menu gets larger and obscures even more.

    I hope this is clearer. Thanks for taking a look.
     
    • Helpful x 1
  7. danny

    danny Administrator

    Joined:
    Aug 15, 2006
    Messages:
    738
    Thanks, that helps. So am I correct in assuming that this issue is happening in landscape (not portrait)?
    Also, please specify which iPhone model you are using.

    This is a bug and shouldn't be happening so it will need to be fixed.

    Thanks for sharing.
     
  8. palmer_md

    palmer_md Member

    Joined:
    Sep 26, 2012
    Messages:
    718
    Location:
    Sacramento, CA
    It happens in both landscape and in Portrait mode. I did not notice before, but in portrait mode when zooming in the menu moves down and it is off the right side of the zoomed page and still blocks the link buttons. This would be even more bothersome since you might not even notice why it is not working.

    I'm using an iPhone 6. NOT the S or + version.
     
  9. GoTslaGo

    GoTslaGo Learning Member

    Joined:
    Dec 25, 2015
    Messages:
    1,458
    Location:
    NV
    Thanks for posting this, I've noticed this too on my IPhone 6. I only use in Portrait mode.
     
  10. danny

    danny Administrator

    Joined:
    Aug 15, 2006
    Messages:
    738
    Thanks for the details. Will be looking into it.
     
  11. palmer_md

    palmer_md Member

    Joined:
    Sep 26, 2012
    Messages:
    718
    Location:
    Sacramento, CA
    Just noticed today that the Model 3 section is again missing the "mark forum read" button that you temporarily solved. Perhaps someone accidentally removed the temporary solution. Its back to the old way where the order/production/delivery section has the button but not the main Model 3 section of the forum.
     
    • Helpful x 1
  12. danny

    danny Administrator

    Joined:
    Aug 15, 2006
    Messages:
    738
    @palmer_md Thanks for mentioning it. We haven't developed a solution for this as we are prepping an improved navbar experience. What I think would be best would be to move the move the mark forums read button off the navbar. I'm going to add this to our roadmap.
     

Share This Page