Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

MCU1: Black center screen / mcu failure caused by a faulty navigation MicroSD card

Telectroboy2

Member
Sep 23, 2021
12
6
France
I'm not sure I can share it. This content come from LuckyLuke and he owns a shop so I imagine he prefers to keep that for him. But he shares if you ask.

So I've made a try yesterday after copying datas on a sd card with BalenaEtcher but it doesn't work.
I'm finishing the copy with dd command on Linux.
I hope it will work ;)

15812276736 octets (16 GB, 15 GiB) copiés, 39942 s, 396 kB/s
30883840+0 enregistrements lus
30883840+0 enregistrements écrits
15812526080 octets (16 GB, 15 GiB) copiés, 39943 s, 396 kB/s
 

zrachwal84

Member
Jan 27, 2020
10
3
Poland
Having crazy unusual symptoms suddenly and this thread looks close to what my problem is but not exactly...


After supercharging my 2015 model S a few hours ago, when I returned to the charger, the center screen was on and in reverse camera mode which was unusual. with a black bar on top and bottom. I cannot exit it.
And there are many sudden new issues all at once:

Center display unavailable, no controls. Cannot power off car via screen

no AC !!!

Power steering is heavier than ever before,
Autopilot and cruise control no longer work,

Car no longer can be seen via Tesla app,

Car thinks I'm still at the supercharger (I keep seeing a pop up in my center display of the speedometer saying the supercharger I’m near is over 80% capacity - Which is what it was telling me when I was on my way to the supercharger in the navigation).

drivability is poor (very slow acceleration).

Center screen cannot be accessed even upon reset (pressing both buttons and brakes for 30 seconds) - It just loops back to the center screen turning off and turning back on showing only the rearview camera and no controls to exit or do anything else.

I just scheduled an appointment with Tesla service but the closest appointment is over 15 days away. This is unacceptable. Anything I can do in the meantime? Thank you guys.
EMMC is dead, need repair by replace emmc chip or replace tegra board.
 

Telectroboy2

Member
Sep 23, 2021
12
6
France
"dd" can save your bacon, or burn it to a crisp if you get something wrong. Glad to hear it was the former.
Ahah Right! Never mix /dev/sdb with another one ^^

dd = destroy disk :p



Can anyone supply me with the Navigation Data EU-2021.8-1287 microSD image file please? I need to install manually as my certs are out of date and can't access Tesla's servers.

Here is the corrupted data, I've downloaded them with ddrescue from the original sdcard.

I'm still copying it on a new sdcard so I cannot tell if it's working or not...

Good Luck
 
  • Like
Reactions: red_five

amiral_sub

Member
Sep 20, 2019
145
91
Bordeaux, France
Hi all,
Since a few weeks, sometimes my mcu shows that the navigation data are not available.
everything else works: I see where I am, I see traffic data, spotify works.
I have to reboot if I want to use the navigation system.
After a reboot the navigation system works fine for a few days
Can it be a faulty sd card?
 
Last edited:

Babianus

New Member
Oct 6, 2021
4
2
Sweden
Trying my way around in Linux to get this script to run on a Windows based linux called Kali. Never once done something in terminal in Linux and very confusing but i came thus far that i can now go around in my C drive etc and found the .sh file that i downloaded from pastebin but to send the run command i have to determine the path to my sdcard but cant find my sdcard in terminal. I see the sdcard in Windows and its formatted in FAT32 and ready to go but cant find it anywhere in linux terminal.

Been at this for several hours and starting to get depressed....

You guys that done this, how did you find your path to sdcard ?

googleing for hours now and trying these kind of mount commands but it dont work...
 

Telectroboy2

Member
Sep 23, 2021
12
6
France
Hi all,
Since a few weeks, sometimes my mcu shows that the navigation data are not available.
everything else works: I see where I am, I see traffic data, spotify works.
I have to reboot if I want to use the navigation system.
After a reboot the navigation system works fine for a few days
Can it be a faulty sd card?
Yes, it could definitely be your SD Card! It did the same on my car at the beginning and after a month the navigation stopped working. Except display, position, trafic, radio, spotify... Just the navigation.




Trying my way around in Linux to get this script to run on a Windows based linux called Kali. Never once done something in terminal in Linux and very confusing but i came thus far that i can now go around in my C drive etc and found the .sh file that i downloaded from pastebin but to send the run command i have to determine the path to my sdcard but cant find my sdcard in terminal. I see the sdcard in Windows and its formatted in FAT32 and ready to go but cant find it anywhere in linux terminal.

Been at this for several hours and starting to get depressed....

You guys that done this, how did you find your path to sdcard ?

googleing for hours now and trying these kind of mount commands but it dont work...
If you use a virtual machine don't forget to connect your sdcard to the guest system (the linux OS) if not so you can see it with a sudo fdisk -l command.
Normally, the path is something like /dev/sdb2


You can check in my message down there, how it has to be displayed. It's a Debian virtual machine but you expect the same result anyway.

Hello everybody,
I've got the same issue since 2 months. At the beginning it just disappeared with a reset but not anymore.
I've asked Tesla they charge me 155€ to do it. Not so much but I need to drive 200kms away from home.

As I have a 16Gb Sandisk Ultra SDCard, I'm trying to save the data of the original one. Which was a bit oily.

The content are broken.
View attachment 713063

while trying to do a fdisk (very long to have a display...)
View attachment 713064

some details of both partitions in testdisk
View attachment 713065

dd is incredibly long
PC-JPVMDEBIAN:~$ sudo dd if=/dev/sdb of=cartesdtesla.img status=progress
70513152 octets (71 MB, 67 MiB) copiés, 1234 s, 57,1 kB/s


Does anyone has the .sh script suggested by LuckyLuke and/or the image of the sdcard for europe?

Thanks a lot :)


And sorry for my bad English...
 
  • Informative
Reactions: Krash

Telectroboy2

Member
Sep 23, 2021
12
6
France
So I can only replace the card by a new one or do I have to partition it?
In my special case, I have replaced it with a Sandisk Ultra 16Go SdCard that I have copied with some known good datas.
I've copied datas on it through DD command on a Linux OS.

It worked straight from a reboot.

Datas comes from LuckyLuke I don't share it here because I'm not sure that I can. He owns a shop to repair sell part for electric cars so may be it's a part of his job. And he gives it to me for free. I imagine you can ask him too...


I've read some people inserting the fresh new SDCard right into the MCU and after a reboot the MCU has downloaded nav datas.
I haven't tried that.


And I have shared here (Post #86) my saved but normally corrupted datas. I you try them and it works please tell me :)
 

unihappytime

Member
Dec 23, 2015
47
7
United Kingdom
Hi Guys, I have PMed Luke about my situation.

But he haven’t replied.

I had a message saying incorrect maps was loaded, not it’s just say no navigation data loaded .

Since my car is an import from Hong Kong, Tesla UK won’t reformat or replace it or even send over map data OVA.

Please anyone can help me out here?
 

Babianus

New Member
Oct 6, 2021
4
2
Sweden
Hi Guys, I have PMed Luke about my situation.

But he haven’t replied.

I had a message saying incorrect maps was loaded, not it’s just say no navigation data loaded .

Since my car is an import from Hong Kong, Tesla UK won’t reformat or replace it or even send over map data OVA.

Please anyone can help me out here?

Tesla won´t take it in and change sdcard even if you pay for it ?

If not then i would try to buy a new sdcard and do the script that Luckyluke linked to create the correct partitions on it so you then can transfer the the european maps on to it and put it back in to the MCU. No idea if the car somehow just accepts maps of Asia since your comment about "incorrect maps was loaded" but its worth shot. Im no expert but thats what i would have done.
 

Babianus

New Member
Oct 6, 2021
4
2
Sweden
I also would like to give a big thanks to Luckyluke for providing the info, script and videos to make a new sdcard.
Installed it today and it took like 15 minutes after i powered up the MCU for it to start downloading maps. Everything works great now !

Its people like Luckyluke that will help the owners of Teslas to drive their cars to a million miles !


Thanks again
 

busaman

Member
Dec 12, 2016
240
116
suffolk UK
well i tried a more simple approach mine had not failed completely so i removed the sd card and bought a sandisc ultra microSDXC UHS-1 32gb card as i know absolutley nothing about linux
i downloaded a simple windows utility WIN32 Disk Imager 1.0 made a copy saved it to my pc desktop and simply wrote the imag back to the new sd card with out formatting and it seems to work fine and is 5x faster i hope it helps someone in the future.
 
Last edited:

electropedal

New Member
Oct 24, 2021
1
0
London
Facelift / 2016+ cars have the newer MCU1 (sometimes referred to as MCU1.5). This model MCU has a secondary 16GB emmc chip on the MCU mainboard where the navigation maps are stored. I have not seen any of these go faulty yet. Also on-board emmc is somewhat more reliable than a separate consumer grade microsd card. So I would not worry too much for these models.

Hi LuckyLuke,
As a new member I can't sent PM's but I hope you can help me
I need the microSD card image for EUROPE as partitioning the new card didn't trigger the nav maps download.
My original microSD card was unreadable.

I need this urgently as I have a long trip planned ahead and Tesla cannot book me in time.
Please note that I can pay for this service
Regards,
 

busaman

Member
Dec 12, 2016
240
116
suffolk UK
Hi LuckyLuke,
As a new member I can't sent PM's but I hope you can help me
I need the microSD card image for EUROPE as partitioning the new card didn't trigger the nav maps download.
My original microSD card was unreadable.

I need this urgently as I have a long trip planned ahead and Tesla cannot book me in time.
Please note that I can pay for this service
Regards,
i have the image file of the one that worked for me i could send it via mega or send me an sd card and i will copy it for you.
 
  • Helpful
Reactions: Krash

mihaiile

Member
Oct 26, 2021
8
4
Switzerland
Hi all,
Can any of you provide me with the EUROPE image?

As with most of you here I was also hit by this microSD card problem (the latest map update came for me around 1 month after eMMC update by Tesla, of course they did not change the microSD card...)

Long story short, I already replaced the sd card myself with a newly formatted one using the script, but I only got a message stating "congratulations, you have the latest map version" or something like that despite having just inserted a fresh formatted card. Update option never came after one week now, wifi or not.
Since I am unable to read the original card (was not working for quite some time despite reset/reboot) I would really appreciate the help here. This involves taking it all apart again, hopefully I do not break anything, the first time went quite smooth actually.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top