Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

MCU1 Smooth like butter?!?

I received a 2017 S75d loaner while my car is in the shop. It has not received the MCU2 upgrade, yet... it performs as good or better than my own personal 2017 S75 with MCU2 upgrade. I have never seen anything like this. I had to double check it was MCU1 because I really couldn't believe it.

For anyone with MCU1 that thinks you have no choice but to upgrade to MCU2 to get a usable system....clearly it is POSSIBLE to have things work on MCU1. Make push your service center a little harder when you go in for your emmc upgrade to make sure they get it running right?

Car has the 2021 MCU1 update that recently went out.
 
I think MCU performance can be impacted by lots of personal data (saved navigation destinations for example), so maybe the loaner doesn't have much of that, or a lot less than your car in any case.
What's funny is this loaner I must have had before because my phone was already set up, lol.

What's not funny is it smells like cigarettes' :(

I turned off sentry mode when I got out of the car earlier, when I get back in in 3 hours I'll video it to see how fast everything comes up.

While driving back from lunch some of the maps buffered for a bit on the navigation but nowhere near as bad as other MCU1 loaners i have had. So not as perfect as I thought but still amazing.
 

aesculus

Still Trying to Figure This All Out
May 31, 2015
4,951
2,880
Northern California
My MCU1 is really fine. Not much different than new. The biggest complaint is the occasional (about every 300 miles?) MCU reboot.

I get good navigation times, maps load OK, voice recognition works almost all the time, music plays without stutter, phone is good. controls instant etc.

60k miles and now 7 years old. And if I check the app it says I have no MCU issues.
 
I'd like to know the secret of that performance!
The GUI on my MCU1 2016 MX functions fine for maps, traffic, and settings, but that's about it. Internet has been unusable since an update around 2018 or 2019. Early on, I could use Tesla Waze while driving, but it hasn't worked since that update.
However, except for Waze, this doesn't bother me. I don't play video games or watch movies while charging, so I don't miss this lost functionality.
 

aesculus

Still Trying to Figure This All Out
May 31, 2015
4,951
2,880
Northern California
This is unheard of with MCU1.
My car is a voice text daemon. And makes voice reco calls too. And likes to navigate via voice. I have not really tried other techniques.

Because of this and not having a bubbling screen, I am really favoring sticking with MCU1 and the emmc upgrade when it finally gets full.
 
  • Like
Reactions: aerodyne

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top