Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Missing functions after MCU2 upgrade

GOATMaster

Goat 🐐 Overlord
Supporting Member
Apr 23, 2022
39
17
Dallas
When I picked up my 2015 P90DL after the MCU 2 upgrade I had a few issues.

What worked:
Auto-parking, all settings were restored homeIink, seats, previous navigation locations, Summon (via FOB), radio accounts, new games (sonic and so on), browser.

Note:
Although there were some shortcuts at the bottom there was only one temp control and the right corner was empty.

What didn't work:
Theater was completely blank, no XM or title, only one climate control option.

I called tesla support, they tried the Monty Python Easter eggs Patsy and the rabbit one, a soft reset and changing the language to another one and back. Nothing worked.

I decided to do a complete factory reset and then I saw items in the theater XM and Title appeared, I also had dual climate controls and more short cuta at the bottom.

Since I reset to factory I had to setup everything again. Afterwards I seems to have resolved almost everything except two Items.

Auto Park on exit and Summon via FOB is no longer working after thr reset to factory.
There is no longer an option to "REQUIRE CONTINUOUS PRESS" in my summon setting screen.

Has anyone else had or have this issue?
 

Attachments

  • 20220714_220423.jpg
    20220714_220423.jpg
    163.7 KB · Views: 115

GOATMaster

Goat 🐐 Overlord
Supporting Member
Apr 23, 2022
39
17
Dallas
It looks like it was regional locked. After the factory reset the option was missing. After doing some more research I read the feature is blocked in some countries and the car doesn't know where in the world it is until it drives, something about GPS not registering unless it's driving.

The settings are now back and I can autopark and summon with the FOB.

Very happy now.
 
  • Helpful
Reactions: brainhouston

geordi

Mr Fusion V.1
Jun 14, 2022
239
136
Earth
With the MCU upgrade - it seems that the trip indicators and the energy used aren't calculating - the only part of the energy screen that calculates is when it is in regenerative braking. Also the XM radio shows in the sources and I can choose channels, no sound though. FM doesn't show at all (as expected)

But that's not the worst of it.

They called me up yesterday after I had gotten it back and informed me that they were "fixing Tesla's mistake" from a warranty battery install that happened back in March - and took away 30% of the range right then. I have had full access to 295 miles at full charge of the 90kw battery that THEY installed in my 60 before I ever bought it - and yesterday it went from 245 miles @80% to 100% at 209 miles in my driveway. WTAF.

Oh, but I can have it back if I pay them a ransom of $4500. This is utter bullshit. I was already screwed for more than $1000 by the TPMS repair (Which I contend should have been done under the safety warranty) b/c the module wasn't functioning properly at all. I had replaced the sensors with NEW OEM sensors, but they insisted that the sensors and the receiver were "a kit that is matched" and I HAD to get all new sensors (for $380 plus $900 in labor of the job) and then - on their own notes in the paperwork - that new module was ALSO discovered to be defective, so ONLY the module was swapped out again, which proves their lie of the "matched kit" was nonsense.

It's all a money grab with the service centers. Everything is "give us more thousands"
 
  • Like
Reactions: lccreech
My 2016 has been stuck at 99% calibrating cameras for the past 2 weeks after the upgrade. And I have had other issues, I posted here
 

berkeley_ecar

S 90D (fully loaded) delivered 18 Mar 2017
Jul 21, 2014
262
217
Berkeley, CA
I got the infotainment upgrade with my MCU2 installation in June 2020, followed by an AM/FM installation in Mar 2021. The list of stations that I can scroll through using the buttons on the left side of the steering wheel seems to have gotten randomized, making it frustrating to find stations while driving. The station logos that used to appear on my console display are also less reliably present.
 
I got the infotainment upgrade with my MCU2 installation in June 2020, followed by an AM/FM installation in Mar 2021. The list of stations that I can scroll through using the buttons on the left side of the steering wheel seems to have gotten randomized, making it frustrating to find stations while driving. The station logos that used to appear on my console display are also less reliably present.
It's even worse with the history icons for USB music. Buggy and total crap to release such code.
 
I just had my Infotainment upgrade on 2017 Model S, prior MCU1, AP2.5. Here's what I posted in another thread with the issues I'm having:
No Caraoke, Disney+ won't play (black screen), No Voice Commands (Connection error, Try again), Tune-in not working (spinning circle), Phone calls won't "hang up" and Spotify only plays 1 song and stops. If I press the Play or FWD button, it starts a panic "start/stop/start/stop" loop on the songs.

I have a service appointment set for tomorrow. According to another thread, this is an easy firmware download fix. Crossing fingers.
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top