Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register
  • Want to remove ads? Register an account and login to see fewer ads, and become a Supporting Member to remove almost all ads.
  • The final cut of TMC Podcast #29 is available now with topics time-stamped. We discussed the Tesla Cybertruck's expected 1 MW Ultra-Fast Charging capability, the Tesla Semi Delivery Event, the coming Model 3 refresh (project "Highland"), and more. You can watch it now on YouTube.

Model 3 2021.4.12 update bug

Car just updated to 2021.4.12 and all my settings are gone. Driver profiles have been deleted and settings have been reset.
The GPS also thinks I'm in California, not London. Some autopilot settings have been disabled too. And the car seems to have mysteriously developed the ability to use dual climate control.
Anybody else had similar experiences with this update? Or any other update?
 
Is it now failing to save settings? Or was it just a one time reset?

I wouldn't like my settings reset either, but it hardly seems service worthy. Probably the update performs some conversion of settings incorrectly which corrupted them. Unless it's stopping you from saving new settings, all the service center can do is set them back manually for you.
 
  • Like
Reactions: drtimhill
Car just updated to 2021.4.12 and all my settings are gone. Driver profiles have been deleted and settings have been reset.
The GPS also thinks I'm in California, not London. Some autopilot settings have been disabled too. And the car seems to have mysteriously developed the ability to use dual climate control.
Anybody else had similar experiences with this update? Or any other update?
My M3 updated today, without any problems.
 
I had the same issue while I was on 2021.4.11. Since I had an appointment for an unrelated problem, I added what happened to the problem description in the app. My car thought I was in Palo Alto (I wasn't), LTE was no longer functional, all settings were gone, AP wasn't even working.
This happened after I closed the Netflix app. Since 2020.48.x it barely ever closed properly like it did before, instead it took several seconds to close and sometimes even caused a screen reboot. The tech pulled the logs and told me that following the crash of the Netflix app, the car detected a corrupted file and basically reset all settings to factory default. Interestingly, the phone keys were still paired.
After numerous resets via the scrollwheels and power-offs via the menu the car is now back to normal. Some things however couldn't be recovered, such as navigation favourites, browser bookmarks, trip odometer etc.
If you're on a software before 2020.48.x I recommend not to install any updates for now. My car just updated from 2021.4.11 to 2021.4.12 without issues though. So while the updates don't necessarily cause issues, they are buggy and can cause the whole system to go back to factory settings. Updating from 2021.4.11 to 2021.4.12 doesn't seem to make things worse though.
 
Like I said, the car went back to factory settings by itself, so there was nothing I needed to do. Obviously that also fixed any potentially corrupted files.

I forgot to mention that the tech also said that it's a known bug that Netflix can crash upon closing. This might be fixed in 2021.4.12. At least I haven't seen it happen since the latest update.
 
  • Informative
Reactions: Gasaraki
I had the same issue while I was on 2021.4.11. Since I had an appointment for an unrelated problem, I added what happened to the problem description in the app. My car thought I was in Palo Alto (I wasn't), LTE was no longer functional, all settings were gone, AP wasn't even working.
This happened after I closed the Netflix app. Since 2020.48.x it barely ever closed properly like it did before, instead it took several seconds to close and sometimes even caused a screen reboot. The tech pulled the logs and told me that following the crash of the Netflix app, the car detected a corrupted file and basically reset all settings to factory default. Interestingly, the phone keys were still paired.
After numerous resets via the scrollwheels and power-offs via the menu the car is now back to normal. Some things however couldn't be recovered, such as navigation favourites, browser bookmarks, trip odometer etc.
If you're on a software before 2020.48.x I recommend not to install any updates for now. My car just updated from 2021.4.11 to 2021.4.12 without issues though. So while the updates don't necessarily cause issues, they are buggy and can cause the whole system to go back to factory settings. Updating from 2021.4.11 to 2021.4.12 doesn't seem to make things worse though.
Did the tech fix the GPS/Nav issue or did you manage to fix it yourself when you reset via the steering wheel? I tried resetting a couple of times and the Nav is still not working.
 
Try a reboot, press and hold both steering wheel buttons until the screen goes black then release. Hopefully that does the trick and if not make an appointment via the app

This literally just restarts the touch screen. To do an actual reboot you need to go into the service menu and reboot the car. After 5 minutes, press the brake. Stay in the car and just wait while it goes through the reboot.
 
This literally just restarts the touch screen. To do an actual reboot you need to go into the service menu and reboot the car. After 5 minutes, press the brake. Stay in the car and just wait while it goes through the reboot.
I don't remember in which order I tried the resets, but you're right. You need to go into the service menu and power off the car.
At some point when the navigation was back I had European style speed limit signs (see attached image). Another reset fixed that issue, too. The tech basically didn't need to do anything.
 

Attachments

  • 20210313_085952.jpg
    20210313_085952.jpg
    406.4 KB · Views: 70
  • Like
Reactions: Mattopotamus
Just installed 2021.4.12 in my 2018 LR with no issue whatsoever.
See that 2021.4.12 is available. Hesitating because of this post. Anyone else have trouble?
Had the all the problems described in this thread going from 2021.4.11 to .12 with a model y. First symptom was a disabled autopilot. After a reboot, the car went to factory settings.
 
This literally just restarts the touch screen. To do an actual reboot you need to go into the service menu and reboot the car. After 5 minutes, press the brake. Stay in the car and just wait while it goes through the reboot.
I didn't find a reboot option but there was a power off button. Pressed that and waited a a couple of minutes. But still the same issues when I hit the break. Ill just wait for the service to deal with it as its still within warranty.
 
  • Like
Reactions: Mattopotamus

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top