TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

Model S 70

Discussion in 'Australia & New Zealand' started by EcoCloudIT, Jan 7, 2016.

  1. EcoCloudIT

    EcoCloudIT Member

    Joined:
    Aug 24, 2015
    Messages:
    336
    Location:
    Melbourne, VIC
    I think someone asked this the other day, I'm about to do a range trip so change to range trip and plugged it in....however my car will only go to 363km's...even though it's meant to go to 420km's..... Would this be because k my car set to typical km's rather than rated?

    -ECIT
     
  2. PJF000

    PJF000 TOCA Member

    Joined:
    Dec 26, 2015
    Messages:
    242
    Location:
    37.8136° S, 144.9631° E
    Probably. Change to rated and see what you get. Keep in mind that you probably won't achieve the typical unless you drive VERY conservatively.
     
  3. EcoCloudIT

    EcoCloudIT Member

    Joined:
    Aug 24, 2015
    Messages:
    336
    Location:
    Melbourne, VIC
    I think I must drive like a granny cause I often get a 178kw/h for the last 50km on the dash...

    -ECIT
     
  4. lennier

    lennier Member

    Joined:
    Feb 27, 2015
    Messages:
    385
    Location:
    Melbourne, Victoria, Australia
    I think that must be typical ECIT, as I get 390km indicated (rated) on my S60 for a full charge. Although typical tends to be 75-80% of rated so that seems high. Might be a calibration issue if it's the first range charge you've done.
     

Share This Page