Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Wiki Model X Refresh Issues Thread

I have my appointment for FWD adjustment. This and trunk spacing are literally the only issues with my car. Here are a couple of pics but the driver side FWD has a nice sized cap up top and the passenger side has a small pinch in the weatherstripping. Has anyone had issues like these successfully resolved?
 

Attachments

  • 9AE775E5-A74F-40A9-A988-80A43E33E41A.jpeg
    9AE775E5-A74F-40A9-A988-80A43E33E41A.jpeg
    172.8 KB · Views: 79
  • 3C9EED45-6D08-4E4F-A4CC-A125F0266269.jpeg
    3C9EED45-6D08-4E4F-A4CC-A125F0266269.jpeg
    79.6 KB · Views: 61
  • FDE82F9D-063F-4CD3-85DB-B546783BA2B3.jpeg
    FDE82F9D-063F-4CD3-85DB-B546783BA2B3.jpeg
    86.1 KB · Views: 61
  • Like
Reactions: jc368
just curious how "strong" should the a/c be on the vents to the side in the 3rd row? they seem pretty weaksauce even on level 5
With the middle row fan control set to high (all the way to the right), I can feel the air coming out to the 3rd row vents, but if I were to guess, it's less than one-half of the force that is coming out of the center console (middle row) vents.
 
Did you see the mini -/+ energy line at the bottom of the small screen? I don’t remember seeing that until now with 2022.12.1
It was there on version 2021.43.101 - when I first noticed it (after several hundred miles of driving), I wasn't sure what it was until I noticed that it turned green when braking (regenerative). Like almost everything else on the MX displays, it would be nicer if it were a bit larger in size to be more noticeable/readable.
 
Hey guys, would love some advice on what to do regarding an issue with the windshield on my MXP. Delivered 3/16/22, and within a day I dropped it off at the shop to get ceramic coating, Xpel Prime window tint on front driver and passenger windows, and also the windshield (no tint on windshield but did it for heat rejection).

After getting the car back and driving it for a week I noticed some waviness/ripples in the windshield. It’s minor and very hard to photograph but there’s some visible ripples directly in my line of sight from the drivers seat. At first I maybe thought it was moisture from the xpel tint film, and waited a week or two but it’s still there. I didn’t think it would be a huge deal but it’s driving me nuts every day as I see it when I move my head side to side. It’s also on the sides of the windshield, I’ve attached some photos. Interestingly the driver and passenger front windows are totally clear.

Thought maybe it was a bad tint job. The shop I goto here in houston is outstanding and they have a fantastic rep and they’ve done 3 of my cars. I asked them to redo it and they did, last week.

Unfortunately the ripples are still there, and the shop owner told me they did the tint very carefully and he said he believes it’s the actual windshield and not the Xpel.

I made an appointment with Tesla service in a few weeks. I can live with it but obviously if it’s truly the windshield I’m wondering if I can bring it to Tesla’s attention and maybe they can replace it? Has anyone else had this problem ?
C5ACC711-AE91-4A38-9566-924179C17520.jpeg
 
Hey guys, would love some advice on what to do regarding an issue with the windshield on my MXP. Delivered 3/16/22, and within a day I dropped it off at the shop to get ceramic coating, Xpel Prime window tint on front driver and passenger windows, and also the windshield (no tint on windshield but did it for heat rejection).

After getting the car back and driving it for a week I noticed some waviness/ripples in the windshield. It’s minor and very hard to photograph but there’s some visible ripples directly in my line of sight from the drivers seat. At first I maybe thought it was moisture from the xpel tint film, and waited a week or two but it’s still there. I didn’t think it would be a huge deal but it’s driving me nuts every day as I see it when I move my head side to side. It’s also on the sides of the windshield, I’ve attached some photos. Interestingly the driver and passenger front windows are totally clear.

Thought maybe it was a bad tint job. The shop I goto here in houston is outstanding and they have a fantastic rep and they’ve done 3 of my cars. I asked them to redo it and they did, last week.

Unfortunately the ripples are still there, and the shop owner told me they did the tint very carefully and he said he believes it’s the actual windshield and not the Xpel.

I made an appointment with Tesla service in a few weeks. I can live with it but obviously if it’s truly the windshield I’m wondering if I can bring it to Tesla’s attention and maybe they can replace it? Has anyone else had this problem ? View attachment 793703

I don't do window tinting, so maybe I'm off here..... But I would remove the tint before going to Tesla to complain about the windshield. If you have the tint on there when you go to Tesla, they'll just blame the tint. You'll need to prove it is the windshield itself and not the tint.
 

strider

Active Member
Oct 20, 2010
4,135
2,027
NE Oklahoma
There were complaints about the new glass early on with the Model S (Tesla started making their own glass for the Refresh S/X). There were some serious distortions in the early models. But the complaints seem to have died down until yours here. I had assumed they fixed their process.
 
Last edited:
Hey guys, would love some advice on what to do regarding an issue with the windshield on my MXP. Delivered 3/16/22, and within a day I dropped it off at the shop to get ceramic coating, Xpel Prime window tint on front driver and passenger windows, and also the windshield (no tint on windshield but did it for heat rejection).

After getting the car back and driving it for a week I noticed some waviness/ripples in the windshield. It’s minor and very hard to photograph but there’s some visible ripples directly in my line of sight from the drivers seat. At first I maybe thought it was moisture from the xpel tint film, and waited a week or two but it’s still there. I didn’t think it would be a huge deal but it’s driving me nuts every day as I see it when I move my head side to side. It’s also on the sides of the windshield, I’ve attached some photos. Interestingly the driver and passenger front windows are totally clear.

Thought maybe it was a bad tint job. The shop I goto here in houston is outstanding and they have a fantastic rep and they’ve done 3 of my cars. I asked them to redo it and they did, last week.

Unfortunately the ripples are still there, and the shop owner told me they did the tint very carefully and he said he believes it’s the actual windshield and not the Xpel.

I made an appointment with Tesla service in a few weeks. I can live with it but obviously if it’s truly the windshield I’m wondering if I can bring it to Tesla’s attention and maybe they can replace it? Has anyone else had this problem ? View attachment 793703



My X Plaid has this issue. Mine is in the center of the windshield in both driver and passenger line of sight. Also only noticed AFTER the front window treatment. My shop removed it, we saw it still was present without the treatment. Currently waiting for parts. Looks like brush strokes to me.
 

aerodyne

Nose cone car > MS LR?
Nov 19, 2018
4,755
7,919
Los Angeles
Well, got my car back finally… and it’s going back in tomorrow. Someone forgot to reinstall the frunk! He’s a great pic if you’re wondering what’s under there: View attachment 793770

Well, that takes the cake....

They also forgot the three trim panels and fasteners.

Someone needs to be fired over this.
Let us know the SvC so folks can avoid it...
 
Last edited:

sorka

Well-Known Member
Feb 28, 2015
9,760
7,964
Merced, CA
Hey everyone. New problem for me. Just tried dragstrip mode for the first time last night and cannot get launch mode / cheetah stance to work.

Dragstrip in "peak performance ready". I pressed the brake pedal all the way down to the floor as far as it will go and while holding it I start to press the accelerator and it throws a warning that says "both pedals pressed, motor power reduced". The front doesn't lower at all.

I first tried it when entering dragstrip mode before it said it was ready. All of the reading I've done says you don't need to wait for peak performance ready status. My only goal is to lower the front of the car as far as possible on a hard launch to protect the cv joints rather than waiting for the battery to heat up to maximum performance. I'll probably never use dragstrip mode to fully heat the battery.

So when that didn't work, I thought, maybe it requires waiting for it to fully be ready but it still didn't work after that. The only thing I can think of is it's either a bug with the current software and nobody has reported it or I have some other failure that's preventing it from working that isn't being shown as an alert. Perhaps the brake stroke sensor is not working right or one of the ride height sensors has a pushed pin or something.

Current software is the factory delivered software of 2022.3.102.1 which was first seen in the wild about 3 weeks ago.

Can anyone else get cheetah stance to work?
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top