TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

Music skipping with UHFS with USB, flac

Discussion in 'Model S: User Interface' started by hiroshiy, Aug 8, 2015.

  1. hiroshiy

    hiroshiy Active Member

    Joined:
    Apr 6, 2013
    Messages:
    1,544
    Location:
    Tokyo, Japan
    I've heard a few people complaining about this, but it never became a separate topic so I started this thread.
    I have UHFS Ultra High Fidelity Sound system and use USB with flac files. The sound quality is very good. I'm a sound maniac (!?) with $10K medium class audio system at home.

    Now, the problem is skipping. The music skips, almost every tune skips once. If you listen carefully you'll easily be able to tell. I think I have a decent quality Sony USB stick but it might be the cause. Have you had any similar experiences?
     
  2. Tdriver

    Tdriver Member

    Joined:
    Jan 20, 2015
    Messages:
    190
    Location:
    Palm Desert, CA
    I would try a different brand stick, making sure to format it in Fat32. I burn a lot of DVD's. I found one brand caused skips and another did not.
     
  3. hiroshiy

    hiroshiy Active Member

    Joined:
    Apr 6, 2013
    Messages:
    1,544
    Location:
    Tokyo, Japan
    Thanks I'll try another one.
     
  4. saladman

    saladman Member

    Joined:
    Feb 11, 2015
    Messages:
    95
    Location:
    Seattle, WA
    Ever since I took the latest update (.21) this week, I've started having audio skips on all media, even cell phone calls.
     
  5. Todd Burch

    Todd Burch Electron Pilot

    Joined:
    Nov 3, 2009
    Messages:
    4,737
    Location:
    Smithfield, VA
    Yep, I've been having fairly common skipping since the .239 update of 6.2. But I'd say it happens once or twice every few hours of listening. Seems to come in batches. I've heard it listening to Slacker and also via a USB drive.
     
  6. jerry33

    jerry33 S85 - VIN:P05130 - 3/2/13

    Joined:
    Mar 8, 2012
    Messages:
    12,763
    Location:
    Texas
    Mine skips when parked/charging overnight. From C to T in favourites the last time I noticed--at least 100 tracks. I'm not sure about which 6.2 version it started with. I've never noticed it skipping while driving, but then maybe I haven't been paying close enough attention. Note that yesterday's update caused a number of problems with my car. Reboot causes a blank 17" display, miles show as dashes, songs play once and then they stop (when the screen is not blank).
     
  7. rapoport3a

    rapoport3a Member

    Joined:
    Apr 30, 2014
    Messages:
    320
    Location:
    Ontario
    I have a Kingston Hyper Drive that doesn't skip (yet?). Some tracks are 70 minutes long. Mind you, its capacity is 256 GB. Maybe that has nothing to do with it.
     
  8. JohnSnowNW

    JohnSnowNW Active Member

    Joined:
    Feb 13, 2015
    Messages:
    1,409
    Location:
    Minnesota
    What are you rocking?

    I have two audio systems, and the one that doesn't include DIY speakers was about $6k. I have had Klipsch and Focal over the years, but then I started building my own. I have had to put some upgrades off because I can't keep my kids out.
     
  9. hiroshiy

    hiroshiy Active Member

    Joined:
    Apr 6, 2013
    Messages:
    1,544
    Location:
    Tokyo, Japan
    Haven't had time to try another brand USB yet...

    2TB NAS for music storage, LINN Magic DS-I, and B&W 805S. Oops they didn't cost that much! 
    Wants to upgrade the power amplifier.

    I actually think that Tesla UHFS is very good quality as a in-car audio. Hope a little bit tighter bass, but acceptable.
     
  10. JohnSnowNW

    JohnSnowNW Active Member

    Joined:
    Feb 13, 2015
    Messages:
    1,409
    Location:
    Minnesota
    The 805S are nice. I don't know if shipping to Japan would negate the savings, but Audiogon is a great source for high-end audio equipment, especially of the gently used variety.

    Audiogon
     
  11. Todd Burch

    Todd Burch Electron Pilot

    Joined:
    Nov 3, 2009
    Messages:
    4,737
    Location:
    Smithfield, VA
    This isn't an issue with storage. It explicitly started after the .239 update for me (can't remember what version I had before that). Prior to that I had zero issues with skipping.

    And to clarify, this is skipping WHILE listening to a song...like what you would hear on a CD that has a scratch. It's a software issue in recent firmware.
     
  12. jerry33

    jerry33 S85 - VIN:P05130 - 3/2/13

    Joined:
    Mar 8, 2012
    Messages:
    12,763
    Location:
    Texas
    Once in a great while I have that kind of skipping, but it goes back a long way before 6.x. Advancing one track solves the issue and it hasn't been a big deal as it's very infrequent. Skipping many entire tracks while the car is of started recently, and happens every day.
     
  13. hiroshiy

    hiroshiy Active Member

    Joined:
    Apr 6, 2013
    Messages:
    1,544
    Location:
    Tokyo, Japan
    I used to play drums (loong time ago) so I'm sensitive to skipping. It makes music "out of rhythm". I didn't remember when it started, but I think 6.2 already had one.
    I wonder it's storage or not, will try a new media soon. Maybe the size?? I use 128GB.
     
  14. LetsGoFast

    LetsGoFast Active Member

    Joined:
    Oct 13, 2014
    Messages:
    1,342
    Location:
    Virginia
    I have this happen but only once in a great while. Maybe once every hour? I think getting a new USB stick might be worth a shot.
     
  15. universeFrom0

    universeFrom0 Member

    Joined:
    Dec 17, 2014
    Messages:
    31
    Location:
    UK
    I have this problem and I'm convinced it's not the USB drive. Strangely, some days it will be worse than others and I feel it affects WAV and FLAC more than mp3 and m4a. Sometimes it's so bad I can't continue to listen (yesterday), other times its fine apart from the very occasional skipped beat (this evening). I tested the USB drive on my laptop and it plays the tracks perfectly. The problem is definitely in Tesla's media app.
     
  16. bob_p

    bob_p Member

    Joined:
    Apr 5, 2012
    Messages:
    939
    Since getting the 6.2 software, the media player has had multiple problems. USB music plays by itself overnight - often moving to a different song when I get in the car in the morning. There are occasional skips in USB playback - sometimes going back to the beginning of the current song. And, I've had several instances where the media select doesn't work - and will not allow playback to be shifted to another source (such as going to FM, XM, USB or BT). I'm having to reboot the software frequently now in order to get the media playback to work.

    When they were developing sleep mode in a one of the earlier releases - they had problems with USB playback losing position when the car resumed from sleep mode - and there was a simple workaround by disabling sleep mode for the car. But with 6.2, I haven't found any way to workaround these issues - and seem to be rebooting my car often - while the car is in motion - in order to get USB working correctly again (at least for a while).

    Since these type of problems still get through Tesla's testing process - they really need to do something to improve their testing - such as really having an "open beta" (which Musk had claimed they were going to do) - so that more owners can bang on the software, while it is still in development and they are able to more quickly fix obvious problems like this...
     
  17. Korben

    Korben Member

    Joined:
    May 13, 2015
    Messages:
    111
    #17 Korben, Oct 6, 2015
    Last edited: Oct 6, 2015
    Noticed pronounced skipping on an album a few days ago. Rebooted the main screen and this resolved it. There do appear to be some challenges with playback and skipping. Occasionally songs won't play at all.

    In general, the media player needs a lot of work.

    Album art (not using my cover art but instead a relatively poor album art service)
    Playlists (unable to manage and organize tracks from USB, favorites is definitely not cutting it)
    Skipping (usually minor but sometimes major)
    Failure to playback (sometimes a song just won't play but will play after reset)
    Auto audio leveling (leveling data I provide in each file is not used)
    Screen real estate (there is so much wasted space in the media player screen, it is crying out for more accessible detail)

    The sound itself? It's awesome. I had to get used to the front stage feel but now I like it. I still wonder whether my passengers have as enjoyable playback experience as I do.

    -Edit for clarity

    I am using FLAC files. Also, just read in the v7 beta thread that you may be able to queue next song! That in itself makes life a whole lot better for the DJ in driver or passenger seat.
     
  18. bob_p

    bob_p Member

    Joined:
    Apr 5, 2012
    Messages:
    939
    We're still running the equivalent of "Version 1.0" on the audio system software - basic functionality implemented - and it usually works (though with the 6.2 release, there have been more bugs in the audio system).

    There has been very little improvement to the audio software since the Model S was introduced - and, at least so far, Tesla has seemed more interested in adding new functionality in other areas (like the "Version 1.0" calendar software) rather than investing in improvements to the existing apps.

    The audio and navigation software continue to miss many features present in other vehicles (my nearly 10 year old Lexus had a number of useful features missing from the Model S).

    While the 17" touchscreen is fantastic to use - and the software that is present looks great on the display - at some point, Tesla risks getting a reputation of delivering software that looks pretty, but lacks many expected features (and new releases often have multiple bugs - that owners have to deal with for months until Tesla gets around to fixing them).
     
  19. ReddyKilowatt

    ReddyKilowatt Member

    Joined:
    Apr 20, 2015
    Messages:
    23
    Location:
    New Canaan, CT
    I've had this problem as well. Rebooting the screen seems to fix it.
     
  20. CSFTN

    CSFTN Member

    Joined:
    Aug 24, 2014
    Messages:
    470
    Location:
    Memphis, TN
    I believe the issue here is the same with the touchscreen lagging. I think it is all about Slacker. If I reboot the control screen, then I have no slow responses of any kind when using the touchscreen. Run Slacker, then get out of it and go to FM - everything is slower until my next reboot. I think Slacker runs in the background even when not being listened to, and consumes the processors resources.

    Reboot, never run Slacker, and I bet you will be fine.
     

Share This Page