Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

My car has gone slightly haywire

This is mostly to do with the bluetooth key system, and I've already turned bluetooth off/on, rebooted the display, and powered off the car... so bare with me.

The 2 key cards no longer work on the B pillar, but they still work to start the car by the cup holders.

My Android phone still functions correctly as a keycard. The wifey's Android phone is no longer a keycard; the app wants to "Set up your phone as a key.", but bluetooth audio and phone dialing still works fine.

I still see all 4 devices listed in the key menu. I tried to remove her phone to re-pair it, but the key cards are needed to remove a key, but that's not working.

And the interior lights are blinking when the car is put in Park?

Oh, and the car is running 2018.4.9. The car is a mid-December build.

I've left a note with my local service center. Anyone have any ideas on what else I can try?
 

MikeBur

ManualPilot
Dec 8, 2014
1,378
745
Seattle, WA
Sorry to hear. The keycards not working and the interior lights makes this sound like you need to bring this to the SC.

The only thing I can think of, beyond what you already mention, is a deeper reboot. This is slightly different to regular reboot.
As I understand it:
  1. Park car
  2. Keep foot on brake and press both thumbwheel buttons down simultaneously and keep brake and thumbwheels held down until Tesla ‘T’ appears
  3. Let go of thumbwheels
Supposedly this is the deepest reboot we can do.

There are many other settings, including factory mode and factory reset a Service Center tech or Ranger can do with their laptop after the rolling code entry.

We can speculate more, though I would push for a quick appointment for diagnosis and likely factory reset at SC.
 

spudnik187

Member
Dec 28, 2017
242
199
Austin, TX
I had a similar issue after picking mine up from the SC on Wednesday. They couldn't figure it out, so it's back at the SC. It was working fine when I dropped it off. While they had it, they updated it to 4.9. I wonder if it's an issue with that version of the firmware. I told the folks at the SC yesterday that 10.1 was available (they seemed to be completely unaware), but I'm not sure if they've tried updating it yet. I'm waiting for a call back to see what the scoop is.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top