Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register
  • Want to remove ads? Register an account and login to see fewer ads, and become a Supporting Member to remove almost all ads.
  • The final cut of TMC Podcast #27 is available now with topics time-stamped. We discussed: Consolidation in LiDAR manufacturers; Volvo EX90 shipping with LiDAR; FSD Beta Full Release in N.A.; FSD detecting autopilot cheats, Gwen Shotwell directly overseeing SpaceX Starship; and more. You can watch it now on YouTube. We should have it published to podcast networks shortly.

MYP won't auto connect to Wi-Fi. "Unable to obtain IP address" error when manually connecting to wifi. Only a hard Reboot auto-connects successfully.

Stewart

2021 MY, blue/black FSD & Tow
Dec 22, 2020
68
36
Mill Creek, WA
I’m of the opinion that this is a firmware issue with Tesla, early on never had any issues with connecting to my WI-FI network. Now if I get a notification to connect to the Wi-Fi todo a update, it’s a two thumb reboot. What I find that confirms my suspicion that it’s a Tesla issue is I don’t see any Wi-Fi networks before I reboot. After I reboot I see my neighborhoods Wi-Fi broadcast’s as well as my Wi-Fi network.
Maybe this is something that Tesla is doing on purpose? For what reason who knows and would have been nice to know if this was the intent.
Thoughts?
 
I’m of the opinion that this is a firmware issue with Tesla, early on never had any issues with connecting to my WI-FI network. Now if I get a notification to connect to the Wi-Fi todo a update, it’s a two thumb reboot. What I find that confirms my suspicion that it’s a Tesla issue is I don’t see any Wi-Fi networks before I reboot. After I reboot I see my neighborhoods Wi-Fi broadcast’s as well as my Wi-Fi network.
Maybe this is something that Tesla is doing on purpose? For what reason who knows and would have been nice to know if this was the intent.
Thoughts?
This is definitely weird...
 

totoro

New Member
Sep 1, 2022
4
1
US
Which ATT combo are you talking about? ATT router? And you have connected a second WiFi hotspot to it to resolve the issue?
ATT gave me a modem/router combo device. Its default set to allow fixed DHCPS-fixed IP passthrough which needs to be changed to allow DHCPS-dynamic. Tesla is not compatible with fixed IP so it keeps searching for Dynamic IP. While you can change this setting within ATT combo but lots of folks have suggested me to use my own router.
 
My ATT router settings had dynamic DHCP by default, but for Tesla I have made a "Fixed IP Allocation". But to be honest, I didn't notice any difference... Tesla can connect to wifi... but if sometimes it loses the connection and when sitting in the car I forcefully try to connect to wifi, it often can't do it showing that weird DHCP error.
Anyway.. I just ignore this.. my car was able to download and install update yesterday, and that's all I need wifi for. The golden rule in IT: "If it works - don't touch it" ))
 
ATT gave me a modem/router combo device. Its default set to allow fixed DHCPS-fixed IP passthrough which needs to be changed to allow DHCPS-dynamic. Tesla is not compatible with fixed IP so it keeps searching for Dynamic IP. While you can change this setting within ATT combo but lots of folks have suggested me to use my own router.
Can you clarify what you changed here? And are you saying you did this with using a standalone router? Or just changed these settings to allow dynamic?

I guess im not really sure of the whole "Passthrough" terminology. I'd love a solution that doesnt require me to hook up my Router so I can keep using this all-in-1 since I dont think my old router can handle gigabit speed. I thought passthrough made it so the ATT device functions as a router ONLY, but it wont let me change the "DHCPS-fixed" without changing the allocation mode to "Passthrough"

Maybe there's another location for this setting?

Thanks in advance

Screenshot 2022-09-02 at 5.24.18 PM.png
 
From my understanding, "passthrough" configuration is used when you try to connect to your network from outside of the internet to the device located in your home network. Because your home network devices don't have external IP address. Using a "passthrouh" you can configure, where to "passthrough" the incoming request to your router, to which internal IP address in your network.
This configuration I made when was configuring external access to my Network Attached Storage device in the home network.

In case with Tesla, we try to connect to WiFi using username and password. It has nothing to do with external access and "passthrough" of the access to internal network.
 

totoro

New Member
Sep 1, 2022
4
1
US
Can you clarify what you changed here? And are you saying you did this with using a standalone router? Or just changed these settings to allow dynamic?

I guess im not really sure of the whole "Passthrough" terminology. I'd love a solution that doesnt require me to hook up my Router so I can keep using this all-in-1 since I dont think my old router can handle gigabit speed. I thought passthrough made it so the ATT device functions as a router ONLY, but it wont let me change the "DHCPS-fixed" without changing the allocation mode to "Passthrough"

Maybe there's another location for this setting?

Thanks in advance

View attachment 848415
I changed this to DHCPS-dynamic but it looks not working. So I go ahead connect another standalone router with this combo and turn the Wi-Fi from ATT combo off. So the car joined the Wi-Fi from the standalone Router with no more error.
 
  • Like
Reactions: Art84
Same issue here. I’m on 2022.12.3.20 on my 2020 Model 3. The Tesla app says there’s a software update ready to be installed but that I need to connect to wifi to download it.
I tried connecting to 2.4G & to 5G wifi in my home. No luck. I get the following error message “Could not connect to Netwerk. Unable to obtain IP address. Please check DHCP server settings.”
What should I do?
 
Same issue here. I’m on 2022.12.3.20 on my 2020 Model 3. The Tesla app says there’s a software update ready to be installed but that I need to connect to wifi to download it.
I tried connecting to 2.4G & to 5G wifi in my home. No luck. I get the following error message “Could not connect to Netwerk. Unable to obtain IP address. Please check DHCP server settings.”
What should I do?
You can try two things.
1. Reset your router and set up again. Yes, reset, not just reboot. It helped me
2. Reboot the car, it's mentioned that this helped someone else

By the way, your software is pretty old. I initially was on 2202.15 version when got my car and had issues with manual connection to wifi. After the update to 2202.24, I think it's not a problem anymore. When car in garage, and I sit into it, I see that wifi is connected and not losing this connection anymore
 
You can try two things.
1. Reset your router and set up again. Yes, reset, not just reboot. It helped me
2. Reboot the car, it's mentioned that this helped someone else

By the way, your software is pretty old. I initially was on 2202.15 version when got my car and had issues with manual connection to wifi. After the update to 2202.24, I think it's not a problem anymore. When car in garage, and I sit into it, I see that wifi is connected and not losing this connection anymore
On 2022.24.8 still got the issue 🤦
 
So I just got my Tessa model S. I live in a large apartment complex and there is no wifi in the garage. So I tried to park near Starbucks and connect to wifi. Got the error unable to obtain IP address check dhcp settings. Obv i can’t check settings on Starbucks routers. Then got the same error connecting to my iPhone hotspot. So I never even connected the car to Wi-Fi and I think there is an update I need to download. Any suggestions other then rebooting the car?
 
So I just got my Tessa model S. I live in a large apartment complex and there is no wifi in the garage. So I tried to park near Starbucks and connect to wifi. Got the error unable to obtain IP address check dhcp settings. Obv i can’t check settings on Starbucks routers. Then got the same error connecting to my iPhone hotspot. So I never even connected the car to Wi-Fi and I think there is an update I need to download. Any suggestions other then rebooting the car?
I get that error sometimes when I'm trying to connect to Wi-Fi at home but I'm too far from the router and signal is too weak. I can expect that being the case when you park outside of Starbucks, but I don't know why it would happen when using your iPhone hotspot...
 

Stewart

2021 MY, blue/black FSD & Tow
Dec 22, 2020
68
36
Mill Creek, WA
So I just got my Tessa model S. I live in a large apartment complex and there is no wifi in the garage. So I tried to park near Starbucks and connect to wifi. Got the error unable to obtain IP address check dhcp settings. Obv i can’t check settings on Starbucks routers. Then got the same error connecting to my iPhone hotspot. So I never even connected the car to Wi-Fi and I think there is an update I need to download. Any suggestions other then rebooting the car?
Do you see any Wi-Fi broadcasts? If not try and do a reboot. This was an issue with previous versions of code, as of late I haven’t seen the issue. Your mileage may vary 🤔
 
FWIW, my Model 3 had the same behavior the OP described with my AT&T fiber router as well as the DHCP error on occasion, forcing a reboot. Since updating to 2022.36.x, the car has consistently connected to the 5 GHz network without needing to be rebooted. I’ll update here if the behavior changes.
 
  • Like
Reactions: M3PDC

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top