Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.

No TPMS Values (Not even blank values) Displayed


Active Member
Dec 26, 2018
Peculiar Issue.

Over the weekend, I swapped my brake pads and rotors. I also removed a broken dash cam and installed a new dash cam (front and rear camera).

When I got back into my car, my TPMS light was blinking, and I didn't get ANY TPMS values. I don't mean they showed the "- -" like it was waiting for values, the whole area was completely blank:


I have no idea what could have caused this to be totally blank, not displaying even the "no value" lines, on all four wheels.

I don't recall unplugging anything on the interior when I installed the dash cam, just ran some wires from front to back over the passenger side roof line, and ran a power down the passenger A pillar, under the center console, and into the USB outlet.

I called Tesla 1-800 support and they had me reboot and change the wheel configuration, no change.

Did I blow a fuse somehow? Did I somehow impact this by replacing pads/rotors? Any other ideas??
Have you tried unplugging the dashcam? I've heard of some of them interfering with wireless signals. (Especially if a cable was cut and spliced to make installation easier.)

It's not currently plugged in. I was going to run it off one of the two independent USB ports, but it seemed like it wasn't getting enough power from there....it would flicker and cut off. When I powered it through the cigarette lighter, it worked fine.
Hi folks,

Got my car back from the Service Center and the TPMS values are coming in again, light is no longer flashing.

They stated that Fuse F219 (5A Micro2) controls power to the TPMS ECU (and the glove box light), and that it was blown.

IIRC, my glove box light was working, but perhaps something happened during my V11 update that just needed a hard reset to the TPMS system via Toolbox.

At any rate, if you're not getting any values at all (not even the '--'), it may be because your TPMS ECU is not getting 12V power.
From MS wiring diagram, there are four wires at harness #X140 for TPMS ECU
1. Ground
2. 12V Power from “Body Control Module”
3. CAN BUS –
4. CAN BUS +

In the wiring diagram for 2103 MS, there is no fuse between the "Body Control Module" and the TPMS ECU.

I have the exact symptoms of post #1 above.

Does anyone have experience in testing the TPMS ECU?
I'm guessing
- Undo negative 12V battery terminal
- Undo #X140 wire harness
- Redo negative 12V battery terminal
- Use multimeter to check for power

I have already changed the wheel configuration. The car completely rebooted, but no change.

All I did was remove a tire, then remount it. Since then, I've had these symptoms.

How do I "do a hard reset via Toolbox"?

I am continuing to have the exact symptoms of post #1 above.
Steps I've tried, with "no change"
- two button reboot
- change wheel configuration
- disconnect 12V battery, and reconnect

Does anyone know if you can reset the TPMS ECU by putting the car into "Service" mode, and resetting it there?

If I end up having to replace the TPMS ECU, do I have to do a firmware update for the car, like I did when replacing the charge port?

Has anyone previously replaced their TPMS ECU (Continental), behind the rear passenger side seat? Any tips?

San Diego, CA
For future readers, the solution was a software reset.
I had the sensors checked in all four wheels. No issue there.
I now know what a “hard reset via toolbox” is, but the current price for Toolbox is $500 per month
I paid a local garage $200 for the software reset.
In the future, I would probably try a firmware redeployment, downloaded from the Wifi of the Tesla Service center.
  • Informative
Reactions: Gtech
I just wanted to add to this thread for future reference. My issue was the same with flashing tire. F47 was in fact the blown fuse that resulted in TPMS not working, as well as OBD2 port, and glove box light. I found a few fuse box diagrams but none of them mentioned the TPMS in the fuse description. I must have blown it while metering out a connector on the right side of the center console during a dashcam install. It was a micro 5amp fuse.
I have the same problem.

F219? I think you are referring to a refreshed MS (>2016).

Glove box light is F47. Is that it, for TPMS computer, for a 2013 MS?



  • 058645F7-7157-4202-BDEB-D89289BEEEA9.jpeg
    448.5 KB · Views: 18