Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

P100D backup camera image scrambles sometimes after MCU2 replaced with refurbished unit

I had my late 2016 P100D FSD serviced for a humming noise from my right speaker in the trunk about a month ago. It had previously been upgraded to an MCU2 with a new screen. During the service visit they replaced the MCU2 screen with a refurbished unit. Since then I have noticed green lines going horizontally across the screen intermitently. Over the weekend the problem became worse during two drives and the image was much more scrambled near the bottom. I asked a technician who about what the issue could be. He asked if I have the rear view camera image on the screen at all times. I told him I do most of the time. He says it’s not meant to be displayed so much and to only have it in the screen when backing up or to briefly check on things. Why would they have the option of having it display all the time if it’s not built to do that? My fathers model x has exhibited no ill-symptoms from having it on 100% of the time. Is this really true or did they put in a faulty refurbished mcu2 or possibly a bad connection during the install? I am covered under CPO warranty as well as mcu warranty and x-care warranty as well.
 

Attachments

  • 4396DE40-0E5A-4EC3-99D5-66502217CB60.jpeg
    4396DE40-0E5A-4EC3-99D5-66502217CB60.jpeg
    205.2 KB · Views: 35

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top