Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Phone app is now unable to load my iPhone's Recent Calls and Contacts [Update: fixed it]

This site may earn commission on affiliate links.
EDIT: To be clear I'm talking about the Tesla app in the car that allows you to make calls on your phone. Not the app on the phone that lets you open the car and control some of the car's features.

When I open the phone app and go to these tabs it sits there spinning saying it is preparing to load them.

I have most recent iOS 13 on an iPhone SE.

I've tried disconnecting the Bluetooth and reconnecting. I haven't tried removing my iPhone completely and then adding it back as a device again. I had misplaced my key card so couldn't add it back if I removed it. I have since found the Tesla key card but don't want to risk trying to do it during the week. Thought I'd come here first to see if anyone has seen this and has a quick fix.
 
Did repairing work? I’ve experienced the same issue recently and I don’t know if it’s because of the Tesla update or the iOS update. I haven’t re-paired my phone yet.
I didn't have time last weekend, so haven't tried yet. I ended up with a 12-hour shift Saturday, and Sunday also busy with stuff. I might just bite the bullet tonight.