Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register
  • The final cut of the 9th episode of the Tesla Motors Club Podcast, featuring Balazs Biro, of the prominent Hungarian EV channel Villanyautósok, is now available. You can watch it now on YouTube or listen to it on all major podcast networks.

Phone key issues

Picked up my 2021 MY about a month ago - mostly loving it. The biggest aggravation so far has been the phone key. It works about 60% of the time. The weird thing is that sometimes it doesn't work even when the phone is clearly connected to the car via Bluetooth. The other day I was working in the garage and my phone rang. When I answered it, it was connected to the car. But then I reached over and tried to open the door, and it wouldn't let me - said to tap the key card to the door pillar.

It's a pretty ancient Android phone (Moto G5). Do I just not have a cool enough phone to be driving this car?

(Searched the forums - found lots of older posts complaining about the phone key, but I didn't find anything current that matches my experience)
 
Bluetooth audio and Bluetooth key are two completely different things.

when the key doesn’t work, you need to turn bt off and on on your phone. I have to do that a few times a month. Works every time.
I get that, and it does reliably fix things when I turn bluetooth (or airplane mode, amounts to the same thing) off and on. Problem is that for me it's a few times a day, not a few times a month.

I'm rather inclined to blame this on my stone age phone. Not willing to buy into the Apple cult just yet, but I'm in the market for a new Android. If there's any recommendations on Android phones that work particularly well with Teslas, I'm all ears.
 
I get that, and it does reliably fix things when I turn bluetooth (or airplane mode, amounts to the same thing) off and on. Problem is that for me it's a few times a day, not a few times a month.

I'm rather inclined to blame this on my stone age phone. Not willing to buy into the Apple cult just yet, but I'm in the market for a new Android. If there's any recommendations on Android phones that work particularly well with Teslas, I'm all ears.
I have an Android Pixel 4 phone (now superseded by Pixel 5 models) that has worked flawlessly with my Tesla MY. I've never had to turn Bluetooth off/on to get it to work. Also, FWIW, the wireless charging works very nicely.
 
I have had this happen a couple of times. I have had the car since October and hadn't had a problem until about a month ago. A couple of months ago I upgraded my phone from iPhone X to iPhone 12. I got it set up so the new phone worked but there have been two instances where the car would not recognize the phone key. Both times I completely rebooted the phone and it did not fix the issue. I used the card key to start the car and drove home and the next day there wasn't a problem, the phone worked. So I'm thinking the car going through a full power down cycle worked.
 
I get that, and it does reliably fix things when I turn bluetooth (or airplane mode, amounts to the same thing) off and on. Problem is that for me it's a few times a day, not a few times a month.

I'm rather inclined to blame this on my stone age phone. Not willing to buy into the Apple cult just yet, but I'm in the market for a new Android. If there's any recommendations on Android phones that work particularly well with Teslas, I'm all ears.
I've had it work flawlessly with Pixel 3, 3a, and 4a.
 
I get that, and it does reliably fix things when I turn bluetooth (or airplane mode, amounts to the same thing) off and on. Problem is that for me it's a few times a day, not a few times a month.

I'm rather inclined to blame this on my stone age phone. Not willing to buy into the Apple cult just yet, but I'm in the market for a new Android. If there's any recommendations on Android phones that work particularly well with Teslas, I'm all ears.
My Pixel 5 works fine so far.
 
If you were working in the garage then that means your phone was within range the whole time. So your car disabled the key. If you walk away to where it disconnects the bluetooth then the car will recognize the key again. Power cycling the bluetooth on the phone simulates this. This is a security feature if you really think about it. Sometimes people park their cars outside but are within range of their phone while inside... this prevents random guys coming up and opening your door.
 
I've had my M3 for 3 years now and experienced this problem off and on again during that time. It was VERY frustrating!

The fix I found was going into my app settings on the phone. The phone had permission to put the Tesla app to sleep when not in use. Since revoking that permission a couple of months ago, I have not had any trouble.

Hope this helps!
 
  • Like
Reactions: iamnid
Your phone may also have a setting that puts background apps "asleep" and/or closes them. If that is the case, it may be terminating the Tesla app when not in use to save memory and/or battery. This may result in the key not working until you open the app. If this is the case, there will be a way to exclude the Tesla app from this behavior -- I suspect this is what is going on.

EDIT: I see the response just prior to this one essentially says the same thing. I think this will be the "key" to your problem. (pun intended)
 
  • Funny
Reactions: srlawren
Third post saying the same thing here: it's almost always a problem with the phone operating systems trying their hardest to save battery. In many cases the Tesla application gets suspended. It must be allowed to continue running, never be put to sleep. You also need to give it bluetooth and gps rights all the time, etc.
Mine always worked fine until this morning... and then I realized I had just updated the Tesla app on my phone. Sure enough, the app wasn't running because of the update. As soon as I started it, everything worked again.
 
After months, my iPhone 8 suddenly started my Y giving me "I don't know you" issues 10 days ago. Checked settings. All possible App access enabled.
Instead of using card key I'd open my phone, open the Tesla App and select Phone Key which lies and says connected. Touching this takes me to a help screen suggesting Bluetooth toggle off on, but just going to that screen lets me start the car.
The only way I get iKey to work without this run around is leave the Tesla App open 24/7 on my phone. . Is this behavior normal? Is it draining my phone battery?
 
The Tesla app must indeed be running on your phone. It doesn't have to be in the foreground obviously, but it needs to be running. It is the app that handles the "handshake" between the phone and the car, that authenticates you as the owner. The Tesla app should not be doing any background communication or other processing so I sincerely think it will not drain any significant power from your phone battery. Anyway, that's how it works. If you want to use your phone as key, the Tesla app must be running, it's a prerequisite.
 

mark95476

Active Member
Jun 21, 2020
2,067
1,595
Bay Area CA
I don't have the app running on my iPhone 6. I can open the rear hatch or get into my car and start driving 99.9% of the time. Very rarely it'll beep and won't let me shift into drive/reverse. The screen will show something with green writing, but I've been too slow to get a picture.

When this happens, I found that I can open my door, close it, and then my car will allow me to shift into drive/reverse. I don't need to launch the app on my phone.

After months, my iPhone 8 suddenly started my Y giving me "I don't know you" issues 10 days ago. Checked settings. All possible App access enabled.
Instead of using card key I'd open my phone, open the Tesla App and select Phone Key which lies and says connected. Touching this takes me to a help screen suggesting Bluetooth toggle off on, but just going to that screen lets me start the car.
The only way I get iKey to work without this run around is leave the Tesla App open 24/7 on my phone. . Is this behavior normal? Is it draining my phone battery?
The Tesla app must indeed be running on your phone. It doesn't have to be in the foreground obviously, but it needs to be running. It is the app that handles the "handshake" between the phone and the car, that authenticates you as the owner. The Tesla app should not be doing any background communication or other processing so I sincerely think it will not drain any significant power from your phone battery. Anyway, that's how it works. If you want to use your phone as key, the Tesla app must be running, it's a prerequisite.
 
Can you see the Tesla "notification" icon at the top of your phone? If you do, the app is running. I can "kill" all (foreground) running apps on my phone and I still have the notification icon, which means the tesla app is still running in the background. You think the app is not running because you haven't started it manually (foreground) and you don't see it when you go to "kill" apps.
The app must run, it must not be suspended, and it needs the proper rights.

Oh, and by the way, you can disable notifications for that app but it doesn't mean it will not still be running.
 
I had this issue once with my old iPhone XR, but have had it happen a few times with my new iPhone 12, in fact twice today. I started the app as I do each day, went to the garage, and the phone was not connected. I tried to turn BT off and on, and that didn't work. Being in a bit of a hurry, I grabbed a key card, unlocked the car and disconnected the charging cord, and as I was about to get in, the phone connected. I then drove to the gym, and as I was coming out, I started the app, as I do every other day, and again it would not connect. I closed and restarted the app, turned BT off and on, and even totally powered down the phone and powered it back up. No joy at all. I don't take the keycard to the gym, and had to have a friend give me a ride home to pick up a card. Upon getting back, the phone still would not connect, I used the key card to get in, and only after that did the phone connect.

Went out later, and the phone connected normally. This is not a matter of the app not running -- it was, at all times, running in the foreground. Usually until the phone connects, the image of the car is black and white on the app, and then in color when it connects. In each of these instances, the image turned to a color image, and the phone stayed disconnected. No settings on the app were changed before or after. It had not been running for enough time for the app have automatically gone to sleep.
 

mark95476

Active Member
Jun 21, 2020
2,067
1,595
Bay Area CA
It's not running at all. I have no apps running on my phone 99% of the time.

I used to launch the Tesla app back when I first got my car, but then I realized that I didn't need to. My iPhone gets paired automatically via Bluetooth when I get close.

Can you see the Tesla "notification" icon at the top of your phone? If you do, the app is running. I can "kill" all (foreground) running apps on my phone and I still have the notification icon, which means the tesla app is still running in the background. You think the app is not running because you haven't started it manually (foreground) and you don't see it when you go to "kill" apps.
The app must run, it must not be suspended, and it needs the proper rights.

Oh, and by the way, you can disable notifications for that app but it doesn't mean it will not still be running.
 
All right, I guess I should change the terms I use. Bluetooth is between the phone (the device) and the car, yes. iOS or Android provide bluetooth communication services. That part doesn't need any app, no. However, when you pull the car's handle, the car wants to know who's there before unlocking the door. Although that communication occurs through the bluetooth (LE?) connection, I am at least 99.9% sure that it is the Tesla application code that handles the actual request. Technically, that code launches when you start your phone, automatically. Whether you manually start the application's user interface or not doesn't matter.
The configuration of your phone's operating system makes it so sometimes, that part of the Tesla app is put to "sleep" to save battery, or has some of its rights removed. At that point, it cannot handle the request anymore so your door stays locked. Normally at that point, if you start the user interface (e.g. show the app in the foreground, on your phone screen), the process is made live again (not suspended anymore) and the unlock works.
I've had one case where I just updated the Tesla app on my phone and the door wouldn't unlock. Launching the app fixed this. I think that restarting the phone would also have fixed it. My understanding there is that the "background portion" of the Tesla app that handles the requests had been stopped so the app could be updated, and it did not start automatically after the update like it does when you boot the phone. IT never misbehaved after that.

Each Android and iOS update brings along new mechanisms to detect running apps and suspend them in some way to extend battery life. Some of these do not play well with the Tesla app and cause the sorts of problems that are reported here and on many other forums continuously.
 
  • Like
Reactions: philw1776

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top