TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Phone Key Pairing Issues (OnePlus)

Discussion in 'Model 3' started by slippy47, May 9, 2018.

  1. slippy47

    slippy47 New Member

    Joined:
    Apr 12, 2018
    Messages:
    4
    Location:
    Orlando
    Upon delivery of my Model 3, I attempted to pair my OnePlus 2 phone (Android-based OxygenOS 3.6.1 using Android 6.0.1) with the car, but after searching for several minutes, it would never connect. The technicians and I tried every scenario under the Sun regarding resetting Bluetooth and location services, restarting/reinstalling the Tesla App, rebooting the phone, verifying all permissions were enabled, etc. My girlfriend owns a OnePlus 1 phone (Android-based CyanogenOS 13.1 using Android 6.0.1) but ran into the same problem when trying to connect hers. We also tried connecting with one of the technician's phones with Android 7 and it worked fine, so i know it's possible.

    After taking the car home, I rooted my phone with Lineage OS to see if getting past Android 6 would help, but now my phone won't even try to connect as a key, it just displays an error message "Your phone key was not set up correctly. Please delete and re-install the app". As you can guess, i tried reinstalling along with a slew of other troubleshooting, but always the same error message.

    The classic Bluetooth functionality works perfectly fine with my phone (syncing contacts, making calls, music, etc.); but setting up the phone as a key has not worked on either of my OnePlus phones. I believe the phone key connectivity relies on Bluetooth Low-Energy working in tandem with location services, which is why it may be so difficult to set up with at custom ROM

    My pipe dream is to find a solution to allow my rooted phone to connect as a key to the car, but I don't see that very likely (perhaps a question for the rooting community). I have been contemplating getting a new phone for a while now, rather than replacing my old dying battery, but if I'm worried that I might run into the same problems if I get another OnePlus phone. As you can tell, I love their phones, but I have to go with one that I know will work as a phone key.

    Does anyone here have a OnePlus phone newer than the OnePlus 2 that connects as a phone key to their Model 3?
     
  2. SDKoala

    SDKoala Model 3 LR RWD

    Joined:
    Apr 11, 2018
    Messages:
    621
    Location:
    San Diego
    If it helps to have another data point, I have an old unrooted OnePlusX that's still on Lollipop that I'll see if I can configure as a key.
     
  3. insaneoctane

    insaneoctane Active Member

    Joined:
    Apr 6, 2016
    Messages:
    2,659
    Location:
    Southern California
    Oneplus 3T working perfectly here....
     
  4. Twiglett

    Twiglett Single pedal driver

    Joined:
    Oct 3, 2014
    Messages:
    2,055
    Location:
    Austin
    I exercised my google foo and found a whole bunch of issues with the OnePLus 1 & 2 not connecting or partially connecting to BLE devices.
     
  5. CitizenM

    CitizenM New Member

    Joined:
    Jun 20, 2018
    Messages:
    2
    Location:
    Massachusetts
    I'm in the same boat. I got a OnePlus 2 that had the original version of Oxygen on it from when they first came out. Trying to setup the key, it would just sit there spinning. Because of that I also decided to upgrade my OS to Lineage. I'm running 15.1-20180423 nightly. My phone is rooted. And now I'm also getting the same message "Your phone key was not set up correctly. Please delete and re-install the app", which is how I found this forum entry.

    I talked to Tesla support last week and they suggested a few things none of which helped:

    Cycle airplane mode on->off.
    Delete and re-pair on the car and phone side.
    Restart Tesla (scroll wheels press+hold) and phone.
    Disable energy saving mode.
    Enable location permission.
    Allow "Modify System Settings".

    The support person said if they tried to escalate this problem to customer support engineering, one of the first things they would make sure is that the phone has a stock ROM and is not rooted. It seems more likely that there is a BLE problem with the OnePlus 2 Bluetooth drivers or so rather than a failure because of a Tesla app security check (via the SafetyNet API) to see if the phone has been tampered with.

    I noticed one error in the system log during installation of the Tesla app: the process UserRestrictionsUtils logged "Unknown Restriction: com.teslamotors.tesla". But I don't know if that would cause any problems after installation or if the same thing gets logged on a phone that works as key.

    Sometime in the next few weeks I'll try a more current Lineage OS Oreo version to see if that fixes the problem. I'm also still hoping that a Tesla app update may fix it. I doubt there will ever be a fix for this phone if it is a problem in the OnePlus firmware.
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC