Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.

Podcasts on TuneIn - giant step backwards


Active Member
Mar 21, 2016
Durham, NC

Recently support for podcasts on TuneIn in the car had gotten better. The ability to have different playback speeds (even though I don't actually use that myself), and much better support for picking up where you left off, even if you switch to a different audio source, have been welcome improvements (I won't say enhancements, because those should have been features available on day one). Yes, there would be the occasional glitch, but all in all I felt like TuneIn support in the car was actually usable and I could finally start using TuneIn in the car rather than streaming my podcasts from my phone. And then along came 2021.4.12 (I think) and even 4.15, which I thought might fix things but only made them worse! It is now worse than it's ever been! How on earth can Tesla not get even basic functionality right?

I'll start with the fact that when starting a new episode I almost always get a Loading Error. Fine, I click the icon to try again and it works about one out of three times. The other two times it skips to the next episode (which I just got done listening to). I mean it's like it's not even trying. I click the episode and immediately get the Loading Error.

But the really frustrating thing? I have been listening to an episode of Judge John Hodgman (Ep 498 - A Rollicking Docket) (yes, I know, I am behind--that's what not driving as much has done). The TuneIn player got absolutely stuck on one particular section of the podcast (maybe 10 minutes in?). I would listen for awhile, get out of the car and when I returned it would be right back at that original spot. I would try to use the skip ahead button to fast forward to where I was, and then wham, it would go right back to that "stuck" point. So I would try again and listen without fast forwarding (repeating that part of the podcast) and got maybe 10 more minutes in and then wham, right back to the stuck point. So then I tried using the slider (which rarely works well in this situation, but I wasn't about to hit the skip ahead button 50 times to try to get up to where I was, and seriously, even though the slider indicated I was at any other point in the podcast, it just kept playing the section it was stuck on.

Finally I just gave up and went back to streaming from my phone for that episode. When it was time to move to the next episode, I figured I would try again in the car, hoping that maybe it was just that episode that was the problem. So I am listening to Ep 499 when about 3 minutes in, guess what: it went immediately back to that same point in Ep 498 that it was stuck on. It's like my TuneIn player is possessed! Honestly, what is so friggin' hard about this!

Sorry for the rant, but I needed to vent!
Podcast support is pretty much broken in TuneIn even on other device types. I have both iPad and Android phone which also don’t work reliably with TuneIn podcasts. Trouble is that on those devices it works occasionally and then TuneIn support claims the problem is fixed.

It’s worst on the Tesla however where play position within an episode returns to the start everytime I restart playing an episode.

it is weird since all my subscriptions to the podcasts sync correctly between my devices. It is just play position that is broken.
This behaviour of skipping back to a predetermined point in the podcast reminds me of an issue I had with Google Play Music (back when that was still a thing). Some songs would get downloaded incorrectly (e.g. streaming and then interrupted while in an elevator) and you wouldn't know because the player cached a couple seconds/minutes ahead of the song, but then once you got to that point it would read as an "end of file" and skip to the next song / give-up on life. I wouldn't be able to manually progress it past that point.

It sucked even worse because the corrupted cache file was no saved on the phone and it would be a struggle to clear said cache in order to properly re-download the song.

It sounds like the "loading error" is happening partway through your songs as well. Can't help but wonder if it's TuneIn, the app itself, the Tesla's LTE connection, or something else entirely...
The podcast feature of the Tesla infotainment system is a joke!

When I first got my car about a month ago I was apprehensive about giving up CarPlay but thought I'd learn to appreciate the clean integration of the Tesla system.

There are some things to like about it, but come on, the most basic feature of playing podcasts is broken - the ability to remember where you left off.

If Elon is going to be so damned stubborn and refuse to provide CarPlay then you'd better make something good. So far I'm unimpressed.


Active Member
Mar 21, 2016
Durham, NC
I realize I started this thread as a rant on Tesla podcast support, but since the subject of CarPlay came up, let me shift gears a bit...

Now I'm not an Apple user, so maybe CarPlay is simply head and shoulders above Android Auto, but holy crap, I absolutely fail to understand how people could ever complain about Tesla in favor of Android Auto.

My wife just got a VW ID.4 that supports Android Auto. Out of the box, with our phones (which aren't THAT old), we had to use the wired mode. Apparently to run wireless AA you need a very recent or specific brand of phone, although I did find a back door where you could click something 10 times to get into developer mode and switch on wireless AA. Why?

With wired mode, it's a piece of garbage. The car offers a WiFi hotspot, which is helpful because our provider's signal is not that great in the area we just traveled to. But as soon as you plug in the phone, it shuts off the WiFi hotspot. Granted, this may be a software implementation issue on VW's side, but it basically killed our ability to stream music and use navigation for large sections of the trip (I didn't figure out the wireless hack until yesterday).

Also with wired mode, when you plug in your phone, nothing appears to happen. You can launch "App Connect" (VW's name for AA or CarPlay), but in wired mode all it does is pop up a screen that lets you turn the WiFi hotspot off, and once you do, THEN you see the AA screen. And there is nothing obvious on that screen that indicates that you should need to do it. We only discovered that by trial and error. Again, could just be a VW head unit software issue, but still.

Wireless mode is at least a bit better in that you can launch "App Connect" and it will bring up the AA screen. You still have to wait an annoyingly long time for the car to "boot" to a state where it's ready (unlike the Tesla, which has the opposite problem--usually my podcast starts playing as soon as I open the door and I miss 5-10 seconds of it while I'm climbing in).

Once AA is all set up and running, I have to say the voice response seems sluggish (not sure whether this is due to our phone, the signal, the head unit, or what). You have to wait for a bit after saying "Ok Google" for it to be ready to listen.

And the last issue we've noticed is that occasionally the system (again, not sure if it's the phone or head unit) gets into a mode where music appears to be playing (you can see time advance) but no audio (navigation audio continues to work, I think). The only fix we've had for this is to just shut everything down and try again, and the next time it will work fine.

Anyway, Tesla may have its warts, but I really have no idea why people are so enthralled with Android Auto. At least Tesla somewhat knows what they are doing when it comes to UI design. I certainly wouldn't trust any of the legacy automakers to come up with a compelling UI. For them, AA and CarPlay are absolutely the right solution. But I'll certainly take the Tesla UI over AA any day.
I think you're probably dealing with the worst of both worlds - Android and VW. Seems like wireless CarPlay is a lot more mature and more widely available that wireless AA. On top of that, VW seems to have a really weak spot when it comes to software. I recall reading about how they bungled the release of the ID.3 and all the software problems they had. I think they fired their developer leaders and started over. The takeaway is that VW is really weak at software.
I came from a Mazda CX-5 that I had installed A Pioneer receiver that had wireless AndroidAuto and Apple CarPlay. I had a Samsung Galaxy phone that worked with Wireless AA and I loved it. My podcast player was fully supported by AA and I could seamlessly go from car to phone and listen to my podcasts without much difficulty. I gave up trying to listen to podcasts in my ModelY using the provided services. I now just put the Tesla into Phone mode and just stream the podcast from my phone. Maybe someday Tesla will allow Android/Apple developers to integrate into the Tesla UI via an API, but I don't see that happening anytime soon.
I used TuneIn a lot for podcasts with the above issues.
I recently discovered that the Spotify app also provides podcasts playback and it does it way better: even after a reboot it pickups where I stopped. Have you tried it?

In Spotify, can you easily move between the Tesla App and the Phone App when listening to podcasts? If so, does it still work on the free version of Spotify?

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.