Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Possible Wifi Fix for Those That Can't Connect - Check Network Name Error

habanero69

I Dont Need Cialis. I Drive an EV.
Jul 29, 2016
410
226
KY
I've been dealing with a new Y since delivery on Sept 12th, where it will not connect to ANY wifi network other than my or my wife's iphone's hot spot. My 2 home networks, nope. My ATT portable LTE hotspot, nope. A local Starbux hotspot, nope. Zip, nada. Always failed with "network connection failed - check network name".

I am in the I.T. biz so I know a few things about networks so I knew my home router was doubtfully the issue. Especially since my Model S sitting right next to the Y was on the home network and had always had zero issues. I did fiddle a bit with using MAC address and static IP configurations on the router as some had suggested, but neither worked. I do have a lot of DLNA devices on my home network and I have heard some complain this MIGHT have something to do with it, but I personally doubted it. Again the model S worked fine.

Took the car to Tesla service for several fixes, the wifi being primarily the main issue. They gave me a M3 loaner and said come back next day. Tesla called the next day said my Y connected fine to their onsite networks. I said great, what about offsite like a starbux. They said those were unreliable and didn't serve as good tests. Funny, it's where a Tesla tech told us to go when we first called support with the connect issue when it wouldn't work on our home wifi; he suggested a local starbux. Anyway, they said they took offsite and were able to connect to a hotspot although it wasn't a starbux and they weren't saying where.

I had the loaner at home and of course it too would not connect to my home wifi. So now it's not my Y maybe, but why does my Model S sitting in the next garage stall work fine, and always has?

I began to play with the loaner car to see it I could get it on my home wifi. I WAS able to after doing some random experimenting, so let me state how I did it.

First, my home wifi SSID is NOT broadcast for security reasons and as an I.T. guy, I'd suggest you not broadcast yours either. So I opened the wifi config screen and entered in my SSID, the WPA2 personal security choice, and the password. Pressed enter, and within about 20 seconds I'd receive the error saying "unable to connect, check the network name". This is always what I got no matter which or where I was trying to connect. HERE COMES THE FIX. I simply turned off wifi to CLOSE the config window WITHOUT clearing the currently entered wifi config data that has just failed; I did clear the error that was raised by clicking OK. I then turned the wifi config back on, and the previously entered wifi config data was still filled in (that had just failed; SSID, security, pssword); THAT IS THE REQUIREMENT. Now I simply hit enter again without touching or altering the wifi config data, and bam, the connection immediately works. For some reason, closing/turning off the wifi with the failed config data entered, turning wifi back on and the config data still there entered undisturbed, then simply pushing enter, worked. Bug I assume, but it worked!

When I got my Y back from service, I went through the same process and got my car on my home wifi. Hope this helps someone else. Surely this is some sort of bug. Are you listening Tesla?
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top