TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Premium Connectivity not enabled

Discussion in 'Model 3: User Interface' started by skierrob, Dec 30, 2019.

  1. skierrob

    skierrob Member

    Joined:
    Dec 7, 2019
    Messages:
    54
    Location:
    Long Beach, CA
    Picked up my car yesterday (all wheel drive long range). Account says I have complimentary premium connectivity until December 30, 2020. But my vehicle shows standard connectivity only.

    Spoke with Tesla support on the phone this morning. They said one part of my account shows the premium connectivity but another does not and that they think I may not be eligible for the free trial when I am. They are escalating to a different team that should get back to me within 3 to 5 days allegedly. Hopefully they get it fixed soon. :(

    They did say they would email me my case information but I never received an email which worries me.

    Any advice on how else to get this fixed with Tesla's team?

    Robert
     
  2. jjrandorin

    jjrandorin Moderator, Model 3, Tesla Energy Forums

    Joined:
    Nov 28, 2018
    Messages:
    6,711
    Location:
    Riverside Co. CA
    have you tried contacting your delivery contact?
     
  3. skierrob

    skierrob Member

    Joined:
    Dec 7, 2019
    Messages:
    54
    Location:
    Long Beach, CA
    No but no one in the buena park store is answering their phones. Might need to drive there instead.
     
  4. AnonNJ

    AnonNJ Track mode, smack mode!

    Joined:
    May 4, 2016
    Messages:
    125
    Location:
    NJ
    I just lost premium features on 2019.40.50.5

    I'm all paid up. I think this may be a Tesla centralized issue or firmware related.
     
  5. skierrob

    skierrob Member

    Joined:
    Dec 7, 2019
    Messages:
    54
    Location:
    Long Beach, CA
    Interesting. If you go in your car does it say you are subscribed to standard connectivity instead of premium? Or did you just lose features?
     
  6. AnonNJ

    AnonNJ Track mode, smack mode!

    Joined:
    May 4, 2016
    Messages:
    125
    Location:
    NJ
    Just lost the features. Web browser is telling me to connect to wifi. Caraoke not working. No Sat view on the nav.

    I'm very much still "premium".
     
  7. skierrob

    skierrob Member

    Joined:
    Dec 7, 2019
    Messages:
    54
    Location:
    Long Beach, CA
    In my case, the car very clearly tells me I'm "standard" instead of "premium". :(
     
  8. henchman24

    henchman24 Member

    Joined:
    Dec 18, 2019
    Messages:
    50
    Location:
    Wyoming
    Same here... guessing the switch is causing some issues.
     
  9. AnonNJ

    AnonNJ Track mode, smack mode!

    Joined:
    May 4, 2016
    Messages:
    125
    Location:
    NJ
    This is what I'm assuming. I fired off a note to Tesla informing, but imagine this is a difficult transition and the issues are likely already known and in resolution.
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC