Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Problems with Messages/Texts

Bigriver

Member
Mar 2, 2018
410
344
Pittsburgh, PA
In my 2017 MX with the infotainment upgrade, on 2020.48.10.... having trouble with messaging.
  1. I cannot initiate a message with voice commands. When I say “send a message to John” it correctly dictates what I said, but then the request disappears without any action. I can, however, use voice commands to reply to a text. I just can’t initiate.
  2. A few messages have failed to come in. They are on my phone, my phone is connected to the car, but I was not notified as they came in, nor do they show up in the visual message bubbles now available on the main screen. But most messages do show up there correctly.
Of course I have tried rebooting, several times, and that has not helped. These are not problems on my model 3, also on 48.10.

Anyone else having the same or similar problems?
 

mswlogo

Well-Known Member
Aug 27, 2018
6,015
4,627
MA, NH
In my 2017 MX with the infotainment upgrade, on 2020.48.10.... having trouble with messaging.
  1. I cannot initiate a message with voice commands. When I say “send a message to John” it correctly dictates what I said, but then the request disappears without any action. I can, however, use voice commands to reply to a text. I just can’t initiate.
  2. A few messages have failed to come in. They are on my phone, my phone is connected to the car, but I was not notified as they came in, nor do they show up in the visual message bubbles now available on the main screen. But most messages do show up there correctly.
Of course I have tried rebooting, several times, and that has not helped. These are not problems on my model 3, also on 48.10.

Anyone else having the same or similar problems?

You didn’t state your phone type.

make sure sync messages is in enabled in blue tooth profile on the car.
 

Bigriver

Member
Mar 2, 2018
410
344
Pittsburgh, PA
You didn’t state your phone type.

make sure sync messages is in enabled in blue tooth profile on the car.
yes, sync messages is definitely enabled.

Confirmed to be a problem for 3 different iPhones we tried: iPhone 7, iPhone 11, iPhone 12pro.

Upon further debugging, it is only a problem for contacts for which I have only 1 phone number. If I have multiple numbers listed for a contact, then it asks me to choose which, and proceeds along ok. It also works if I say “send a message to David” and there are multiple David’s in my contact list. Then it starts the process of giving me options of which one, and it works.

As I mentioned, only a problem in my model X. Works perfectly in my model 3.

My current work-around is to put dummy second numbers for each of my key contacts that I regularly need to contact while driving.
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top