TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

Problems with navigation system just stopping with no apparent reason

Discussion in 'Model S: User Interface' started by FrozenCanuck, Jul 11, 2014.

  1. FrozenCanuck

    FrozenCanuck Member

    Joined:
    Feb 24, 2014
    Messages:
    147
    Location:
    Port Perry, Ontario
    Since Tuesday of this week I've been having weird nav problems. I'll give the car an address (saved favorite, or whatever...doesn't matter) and navigation will start. A few seconds later nav will just stop. The trace of the route disappears on the giant screen and the turn by turn disappears from the left of the steering wheel display area.

    My wife just called me to say the same thing is happening to her right now en route to her destination. It's really pissing me off but I can't seem to find any evidence of this problem happening to anyone else either at TMC or just via Google search. Am I alone with this? Anyone else seen this / resolved it?

    Ideas?
     
  2. jerry33

    jerry33 S85 - VIN:P05130 - 3/2/13

    Joined:
    Mar 8, 2012
    Messages:
    12,753
    Location:
    Texas
    Reboot the display by pressing and holding the scroll wheels. Then reboot the instrument panel by pressing and holding the top steering wheel buttons. That usually fixes odd errors. I've never heard of that particular problem, but it's always the first thing to try. (Note: usually you just reboot the 17" display, but because it's the Nav system, the instrument cluster display might possibly be involved.)
     
  3. FrozenCanuck

    FrozenCanuck Member

    Joined:
    Feb 24, 2014
    Messages:
    147
    Location:
    Port Perry, Ontario
    Thanks Jerry! I will try this as soon as my wife gets home with the car. The instrument cluster did lock up (froze) for about 2 minutes this week, then started working again on its own. So I suspect you are right to suggest rebooting both.
     
  4. Electricfan

    Electricfan Member

    Joined:
    Aug 24, 2013
    Messages:
    971
    Location:
    Houston
    My navigation line goes away - I have to reboot using the steering wheel buttons to get it back. Been doing this for a few months. But I haven't lost the one above the steering wheel yet. Just the 17in display nav line.
     

Share This Page