TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

qTes.la

Discussion in 'Model S: User Interface' started by JaredBanyard, Mar 31, 2014.

  1. JaredBanyard

    JaredBanyard Member

    Joined:
    Nov 16, 2013
    Messages:
    184
    Location:
    Bloomingdale, NJ
    Hey Everybody! So I'm doing some work on the website this weekend! I have already made some major speed and content improvements on my staging version of the site. But I have run into a couple issues.

    For those of you that haven't seen the site: QuickTesla.

    First, I made every page bookmarkable so you can just bookmark the one(s) you use the most. I did this by removing the frameset.

    Second, I remove the clock on the main page and just made it straight html. This should make sure it always loads fast.

    Third, I may need to figure out an SSL solution to continue using the geolocation of the browser. I'm hoping I can get cloudflare enabled on my webhosting account to do this, and get some performance improvements at the same time. I mainly want to do this so I can put Waze for Tesla Incidents and Supercharger Traffic in an iframe. They are https, which I can't embed in an http site.

    But, the main issue though is the radar. I hate the implementation right now, and I have a great one ready, but the cost is going to be significant. It is a dynamically created animated gif just based on your geolocation. But, a maximum of 5000 calls a day is $300/mo and 100,000 calls a day is $600/mo. Right now only have 500 calls a day allowed. I have a donate page ready but it feel scummy :( PM me if you would like to test out what I have done and have an idea how I could fund this.

    Jared
     
    • Like x 1
  2. fact200

    fact200 Member

    Joined:
    Sep 25, 2014
    Messages:
    107
    Location:
    San Francisco
    Is SSL required? Last I tried it, the https version of the site wasn't working with the tesla browsert.
     
  3. JaredBanyard

    JaredBanyard Member

    Joined:
    Nov 16, 2013
    Messages:
    184
    Location:
    Bloomingdale, NJ
    https was the only one working for me in chrome anyway. The tesla browser seems flaky with the site in general.

    You know what screw it, I'm going live with the new site, worst case we hit the monthly cap for the wunderground radar data and it doesnt work: qTesla. I'm also in the process of enabling cloudflare, so it's going to be a rocky 24 hours for the site.
     
  4. JaredBanyard

    JaredBanyard Member

    Joined:
    Nov 16, 2013
    Messages:
    184
    Location:
    Bloomingdale, NJ
    I re-enabled the iframe with no https for the waze site! lets try it again
     
  5. JaredBanyard

    JaredBanyard Member

    Joined:
    Nov 16, 2013
    Messages:
    184
    Location:
    Bloomingdale, NJ
    Wow okay so everything seems to be mostly working in the car.. the iframes are having some lag trying to resize when the browser is expanded.. but yeah. pretty legit. Hows it working for everybody else?
     
  6. JaredBanyard

    JaredBanyard Member

    Joined:
    Nov 16, 2013
    Messages:
    184
    Location:
    Bloomingdale, NJ
    Just bumped the radar quality too, but ill probably hit the daily limit pretty fast each day ;) lets see how long this lasts!
     
  7. JaredBanyard

    JaredBanyard Member

    Joined:
    Nov 16, 2013
    Messages:
    184
    Location:
    Bloomingdale, NJ
    Okay made some more improvements, let me know what you all think!
     
  8. SD Diver

    SD Diver Member

    Joined:
    Apr 5, 2016
    Messages:
    395
    Location:
    San Diego
    Jared,
    Thanks for the new posts! Being new to this site (& Tesla) this was the first I've heard about your web app. Playing with it on my phone - about to try it in my car. Thanks for the efforts!
     
  9. SD Diver

    SD Diver Member

    Joined:
    Apr 5, 2016
    Messages:
    395
    Location:
    San Diego
    Also - looks like San Diego is going to rough surf for a very long time!
     

    Attached Files:

  10. JaredBanyard

    JaredBanyard Member

    Joined:
    Nov 16, 2013
    Messages:
    184
    Location:
    Bloomingdale, NJ
    Hah .. yeah I pull those reports manually through the API .. I'm just showin what I got!
     
    • Like x 1
  11. JaredBanyard

    JaredBanyard Member

    Joined:
    Nov 16, 2013
    Messages:
    184
    Location:
    Bloomingdale, NJ
    Looks like the radar requests aren't too bad right now! I have 30 "overflow" drops built up with weather underground and we are only hitting about 250 requests/day. The only problem I have right now is trying to get the iframes for waze and plugshare to resize when you make the browser full or half screen when viewing it...
     
    • Like x 1
  12. NicB72

    NicB72 Supporting Member

    Joined:
    Jun 25, 2016
    Messages:
    98
    Location:
    Concord, MA
    Is this still alive. Idea is great. On the current version I don't get Waze to work and looks like you dropped news ?
    Great idea and I have my fingers crossed it is still being developed.

    Cheers
     
    • Like x 1
  13. JaredBanyard

    JaredBanyard Member

    Joined:
    Nov 16, 2013
    Messages:
    184
    Location:
    Bloomingdale, NJ
    Hey everybody. I'm doing a little work on the stock page right now if people want to test it out and make any other suggestions while I'm neck deep in code. Remember to open it in the car here: qTesla Stock .. you can try on your phones and desktop but its not guaranteed to work. You may have more luck at the https site: qTesla Stock
     
  14. jelloslug

    jelloslug Active Member

    Joined:
    Jul 21, 2015
    Messages:
    3,888
    Location:
    Greenville, SC
    @JaredBanyard
    After the new browser update, the weather and radar tabs have stopped asking for my location and are showing the weather for Santa Clara, CA when using the cars built in LTE connection. When connected via wi-fi, they seem to work properly.
     
  15. JaredBanyard

    JaredBanyard Member

    Joined:
    Nov 16, 2013
    Messages:
    184
    Location:
    Bloomingdale, NJ
    @jelloslug Hmm .. I guess I'm going to have to wait for the update myself. I can experiment with some different geolocation stuff.
     
  16. jelloslug

    jelloslug Active Member

    Joined:
    Jul 21, 2015
    Messages:
    3,888
    Location:
    Greenville, SC
    I can tell you that the pop up request for location information does come up for the Waze tab when on the LTE connection.
     
  17. JaredBanyard

    JaredBanyard Member

    Joined:
    Nov 16, 2013
    Messages:
    184
    Location:
    Bloomingdale, NJ
    Okay cool.. ill start messing around
     
    • Like x 1
  18. JaredBanyard

    JaredBanyard Member

    Joined:
    Nov 16, 2013
    Messages:
    184
    Location:
    Bloomingdale, NJ
  19. JaredBanyard

    JaredBanyard Member

    Joined:
    Nov 16, 2013
    Messages:
    184
    Location:
    Bloomingdale, NJ
    Just tested in my car and some things are working better. I look forward to hearing from some other people though!
     
  20. jelloslug

    jelloslug Active Member

    Joined:
    Jul 21, 2015
    Messages:
    3,888
    Location:
    Greenville, SC
    That one came back as 404
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC