TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC
Start a Discussionhttps://teslamotorsclub.com/tmc/tags/

Question about Auto Pilot

Discussion in 'Model X' started by Insight75, May 13, 2017.

  1. Insight75

    Insight75 Member

    Joined:
    May 7, 2017
    Messages:
    62
    Location:
    Mount Olive, New Jersey
    Just picked up a preowned Model X P100D last night and have a question about what I'm seeing on the autopilot screen. In all the videos I'm seeing, the display shows box trucks and cars on both sides of my car in the middle when driving on a highway for instance. In mine, I'm only seeing cars in front of me and trucks are showing like cars. Is there a setting I need or is my software not up to date?

    Thanks.
     
  2. Insight75

    Insight75 Member

    Joined:
    May 7, 2017
    Messages:
    62
    Location:
    Mount Olive, New Jersey
    To be clear, I do have enhanced auto pilot.....
     
  3. MXFan

    MXFan Member

    Joined:
    Mar 1, 2017
    Messages:
    109
    Location:
    Northern Virginia
    You apparently have an AP2 car which doesn't yet do everything you mentioned in the AP1 video you saw. A few more updates of the software and it will. Be patient.
     
    • Like x 1
  4. Yinn

    Yinn Member

    Joined:
    Nov 15, 2016
    Messages:
    669
    Location:
    Behind you
    This exactly. The videos you saw were AP1. It's able to identify things like a bicycle rider and multiple lanes of traffic. AP2 in general is still not up to par with AP1 yet.

    Congrats on the purchase!
     
    • Like x 1
  5. ecarfan

    ecarfan Well-Known Member

    Joined:
    Sep 21, 2013
    Messages:
    13,653
    Location:
    San Mateo, CA
    As I understand it, EAP is not quite up to parity with AP, specifically EAP does not yet show cars in adjacent lanes in the drivers display, it does not yet differentiate between cars and trucks and motorcycles in that display, and the auto sense wiper function is not yet operational. Other than that I think EAP does everything AP can currently do.

    I am sure that in a few weeks/months EAP will gain those missing features, and after that will progress beyond AP.

    There are other threads about this issue.
     
  6. Insight75

    Insight75 Member

    Joined:
    May 7, 2017
    Messages:
    62
    Location:
    Mount Olive, New Jersey
    Thank you both. Much appreciated.
     
  7. pilotSteve

    pilotSteve Member

    Joined:
    Jul 14, 2012
    Messages:
    953
    Location:
    Vancouver WA
    It's funny how little (and big) changes show up in the various SW updates. For instance, in my AP2/EAP S90D one of the early SW updates in February (not sure which version) showed one lane of traffic (like now) BUT it correctly depicted motorcycles with their correct icon as well as cars. Subsequent updates enhanced EAP but since then no other vehicle icons as you mention. Clearly they are implementing lots behind the scenes and we are looking forward to full AP1 plus functionality SOON!
     
  8. josher32

    josher32 Member

    Joined:
    Oct 29, 2015
    Messages:
    187
    Location:
    West Linn OR
    I've had my AP2 vehicle since Dec and before Autopilot update released. I am pretty certain motorcycles never were shown on AP2
     
  9. pilotSteve

    pilotSteve Member

    Joined:
    Jul 14, 2012
    Messages:
    953
    Location:
    Vancouver WA
    Oops, I went back and checked. This was January on 17.2.3 and the bug report I submitted to Tesla wa that when following a car (no AP engaged) there were car icons shown, but when I followed a motorcycle there was no icon showing. Tesla ack'd my report and said it would be added to the bug list.

    My guess was that motorcycle vs car detection was differentIating correctly but missing the case to display a cycle icon, hence the erroneous blank display.
     

Share This Page