TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

Reset airbag warning light?

Discussion in 'Roadster: Technical' started by glight2000, Aug 12, 2016.

  1. glight2000

    glight2000 Member

    Joined:
    Apr 3, 2016
    Messages:
    70
    Location:
    San Diego, CA
    After upgrading the audio system on the roadster, the airbag light has been on. The installers broke the clips on the airbag cover when removing dash parts. I hoped once the clips were replaced the light would go off. It did not. The airbag itself is still present (and I purchased extra clips just in case I need to remove the cover again).

    Anyone know how to reset the airbag light or will I need to go to TSC?
     
  2. wiztecy

    wiztecy Active Member

    Joined:
    Apr 29, 2012
    Messages:
    2,722
    Location:
    Santa Cruz, California, United States
    Those airbag clips will always break, they're ment to be replaced whenever the passenger AB cover is in any way removed. Were your seats removed? Check the connectors under the seat to ensure they're seated properly.

    I'd suspect the same Lotus Elise scan / reset tool would work on the Roadster. I'd see what the code is first before resetting.
    Airbag light - LotusTalk - The Lotus Cars Community

    Reference - Lotus AirBag Service Notes:
    http://vsic.lotuscars.com/system/files/documents/sn_wf_airbags_evora_0.pdf
     
  3. MLAUTO

    MLAUTO Member

    Joined:
    Mar 8, 2014
    Messages:
    314
    Location:
    SW Florida
    The OPCOM tool for the Opel (VX220) works on the Roadster. Its $20 on Ebay- a lot cheaper than a trip to the dealer. Even the Lotus dealer charges $75 to reset the light.
     
    • Informative x 2
  4. glight2000

    glight2000 Member

    Joined:
    Apr 3, 2016
    Messages:
    70
    Location:
    San Diego, CA
    My seats WERE removed. That's a good place to look. Thank you for the heads up!
     
  5. glight2000

    glight2000 Member

    Joined:
    Apr 3, 2016
    Messages:
    70
    Location:
    San Diego, CA
    I'm going to get one of these! Thank you MLAUTO.
     
  6. glight2000

    glight2000 Member

    Joined:
    Apr 3, 2016
    Messages:
    70
    Location:
    San Diego, CA
    I picked up one of those devices but couldn't get it to work. It may be because my laptop is Windows 10.
     
  7. MLAUTO

    MLAUTO Member

    Joined:
    Mar 8, 2014
    Messages:
    314
    Location:
    SW Florida
    Did the program run on your laptop? It took a little while to figure out the code supplied and to use a 2004 VX220 as the vehicle (if I remember correctly).
     
  8. glight2000

    glight2000 Member

    Joined:
    Apr 3, 2016
    Messages:
    70
    Location:
    San Diego, CA
    I'm heading to the stereo shop tomorrow (finally) to see if they can remedy the airbag warning light that was on after they upgraded the audio system.

    The Wiztecy Lotus manual is going to be very helpful for troubleshooting. Since the seats were removed, I'm going to stick with Wiztecy's suggestion of directing the installer to start with seat-removal related issues activating the light. Page 2 of the manual shows the components. My hunch is that it's either some connection to the seat belt tensioner or a connector under one of the seats shown on page 28. Anything else I should suggest to the stereo installer?

    I can't register the car until I get this fixed. My temporary registration has expired. :-(
     
  9. glight2000

    glight2000 Member

    Joined:
    Apr 3, 2016
    Messages:
    70
    Location:
    San Diego, CA
    The program did run. I'll try running it again right now. Thank you MLAUTO.
     
  10. glight2000

    glight2000 Member

    Joined:
    Apr 3, 2016
    Messages:
    70
    Location:
    San Diego, CA
    The problem is I purchased a Chinese clone of the device and I'm unable to get a USB connection. The provided drivers don't work with Windows 10 x64, documentation is terrible, and I can't find updated drivers on the net. I don't have a Windows 7 laptop. Uggh..
     
  11. MLAUTO

    MLAUTO Member

    Joined:
    Mar 8, 2014
    Messages:
    314
    Location:
    SW Florida
    Taking out the seats won't set the light-those wires are for the parking brake and buckle switch. The retractors will set it if unplugged, but I don't see why they would have unplugged them unless they messed with the factory subwoofer connector on the drivers side.
     
  12. glight2000

    glight2000 Member

    Joined:
    Apr 3, 2016
    Messages:
    70
    Location:
    San Diego, CA
    We replaced the factory sub.
     
  13. MLAUTO

    MLAUTO Member

    Joined:
    Mar 8, 2014
    Messages:
    314
    Location:
    SW Florida
    Then I would double check the connector on the drivers seat belt retractor. If it is plugged in they probably turned they key on with it disconnected and set a code.
     
    • Like x 1
  14. glight2000

    glight2000 Member

    Joined:
    Apr 3, 2016
    Messages:
    70
    Location:
    San Diego, CA
    Problem solved: it was a disconnected (or poorly connected) wire to the seat belt tensioner/retractor/thingy behind and up near the driver's shoulder.

    Many thanks once again to Wiztecy and MLAUTO for helping me point the installer to the correct location. No reset was required. It's a big relief to have that light off!
     
    • Informative x 1

Share This Page