TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC
Start a Discussionhttps://teslamotorsclub.com/tmc/tags/

RHD AP2.0 - not working?

Discussion in 'Model X' started by edb49, Feb 6, 2017.

Tags:
  1. edb49

    edb49 Member

    Joined:
    Sep 17, 2016
    Messages:
    66
    Location:
    UK
    Does anyone have a RHD X with AP2 features working? When I start the car I get a message "Driver assistance features unavailable - if this persists, contact Tesla service". (That may not be exactly verbatim.)

    I was on 17.3.15 but have just updated to 17.5.28 and problem is still there. I know at least one other RHD X has the same problem.
     
  2. muleferg

    muleferg Active Member

    Joined:
    Dec 15, 2013
    Messages:
    1,027
    Location:
    North Wilkesboro, NC
    "Driver assistance features unavailable
    Ignore this. It still works. Divided highway, hands on wheel. 50 mph. pull up 2 times on cruise control.
     
  3. edb49

    edb49 Member

    Joined:
    Sep 17, 2016
    Messages:
    66
    Location:
    UK
    Well even a single pull on cruise stalk says "Cruise unavailable"...
     
  4. muleferg

    muleferg Active Member

    Joined:
    Dec 15, 2013
    Messages:
    1,027
    Location:
    North Wilkesboro, NC
    I got that also this am. Rebooted, got out of the car. went in the YMCA, exercised for 40 min came back out and went for 8 mile drive on auto steer.
     
  5. edb49

    edb49 Member

    Joined:
    Sep 17, 2016
    Messages:
    66
    Location:
    UK
    I've upgraded firmware, so assume the car rebooted when it did that.

    Has anyone with a right hand drive X got AP2 working?
     
  6. outie

    outie Active Member

    Joined:
    May 22, 2016
    Messages:
    1,267
    Location:
    SoCal
    Do you have a right hand drive X?
     
  7. muleferg

    muleferg Active Member

    Joined:
    Dec 15, 2013
    Messages:
    1,027
    Location:
    North Wilkesboro, NC
    No RHD fo me. I'm sure that RHD LHD AP 2 have the same software.
     
  8. polymathic

    polymathic Member

    Joined:
    Oct 30, 2016
    Messages:
    202
    Location:
    Fairfax CA
    I have the same issue and the car has been dropped off for service as a result. Software updates didn't solve it, and nothing works. So it will need some internal calibration probably.
     
  9. Tomnook

    Tomnook Member

    Joined:
    Jan 31, 2017
    Messages:
    67
    Location:
    Nottingham, UK
    I have an X P100D with the same message and same updates. TACC has worked ok since purchase 2 weeks ago (albeit with the common erroneous warnings and braking etc.) Autosteer now works on Motorways only at 50mph.
     
  10. edb49

    edb49 Member

    Joined:
    Sep 17, 2016
    Messages:
    66
    Location:
    UK
    That's interesting - thanks. So seems it is something specific to my car, rather than right hand drive Xs in general. Will have to drop it off for service. :(
     
  11. Tomnook

    Tomnook Member

    Joined:
    Jan 31, 2017
    Messages:
    67
    Location:
    Nottingham, UK
    The spoiler doesn't function though so SC for me too!
     

Share This Page