TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Sentry Turning Off

Discussion in 'Model 3: User Interface' started by jfinephilly, Jan 6, 2020.

  1. jfinephilly

    jfinephilly Banned

    Joined:
    Jan 2, 2020
    Messages:
    321
    Location:
    Philly
    I am running on 2019.40.59.7, LR AWD. Sentry is set to always be on, even at home when parked in my driveway. However, it seems like it is turning itself off at home. I have to manually set it in the app. This didn’t happen before the software updates.

    Does anyone else have this issue?
     
    • Like x 1
  2. TLLMRRJ

    TLLMRRJ Active Member

    Joined:
    Dec 19, 2019
    Messages:
    1,555
    Location:
    Houston
    I have the same set up, and no, it's staying on.
     
  3. boriszima

    boriszima Member

    Joined:
    Jul 12, 2018
    Messages:
    651
    Location:
    Los Angeles
    Have you tried to reboot the car? Pressing two scroll wheels on steering wheel? Can’t say I have had this problem.
     
  4. Spacecadetwzrd

    Joined:
    Dec 18, 2019
    Messages:
    28
    Location:
    Here
    You turned it off to install the update. Turn it back on in the car and make sure the ignore check boxes are not selected, they will be .
     
    • Like x 1
  5. fseir

    fseir Member

    Joined:
    May 1, 2016
    Messages:
    663
    Location:
    Honolulu
    This sounds like an issue I had. I started a thread about it, awhile back:

    Sentry mode not triggering

    If you have the same issue, we seem to be in the minority, as I haven’t found anyone else describing this particular problem.

    What I discovered, was that the car was excluding my workplace, even though I had exclude work toggled off. But here’s the kicker:

    I had exclude home toggled on, and exclude work and favorites toggled off. But whenever I would turn sentry mode off and then back on, it would revert to all three being toggled on, so even though it looked like sentry was on (the red Hal light showed at the top of the screen), sentry wasn’t actually turned on. I tested this by turning off Bluetooth on my phone, and waving my hand in front of the cameras, and it wouldn’t trigger.

    Then it gets even weirder: I rebooted my car, and when I did this, and then turned sentry off and on, it now defaulted to a new configuration, where home and work were excluded, but favorites wasn’t. In fact, every time I rebooted, I would end up with a different configuration, and I had to reboot 5 or 6 times, until I got the exact combination I wanted, and then I re-tested it, and sentry was working again at my workplace.

    Very bizarre, and now I’m afraid to reboot my car, for fear of scrambling my exclusions again.

    To test to see if this is what you’re experiencing, go to your sentry mode settings and turn it off, and then back on again, and see if exclude home is checked. Uncheck it, then turn sentry off and on again, and if you have the same issue as me, exclude home will turn itself back on.

    The very inelegant solution, is to reboot over and over, until you get the exclusions you are looking for (it sounds like you want them all unchecked). It may take a few times, but I hope this helps you. Good luck!
     
  6. fseir

    fseir Member

    Joined:
    May 1, 2016
    Messages:
    663
    Location:
    Honolulu


    Here’s a quick video showing what happens when I turn sentry off and on. It reverts back to its “default” and manually overriding the exclusions is like a placebo, where the switch moves, but nothing actually happens (the state of sentry mode is always whatever the “default” is). The only way to adjust the default, is to reboot the car, and like a slot machine, hope your desired combination comes up. :eek:
     
  7. boaterva

    boaterva Supporting Member

    Joined:
    Apr 2, 2016
    Messages:
    7,539
    Location:
    Northern Virginia, USA
    I know it resets the exclusions on upgrade or Sentry off/on but this randomness is a new one. Have you tried a power off to see if does anything more than a reboot?

    That definitely sounds like the software is borked and needs a deeper reboot of power off.
     
    • Helpful x 1
  8. fseir

    fseir Member

    Joined:
    May 1, 2016
    Messages:
    663
    Location:
    Honolulu
    Hadn’t thought to try that. Since I got sentry back to the state that I wanted it in, I’ve been afraid to mess with it, and haven’t even manually rebooted since upgrading to 40.50.x. I know that eventually I’ll need to reboot for some reason or another, though, so if and when that happens, and it messes up my sentry mode again, I’ll try a complete power down and see what it does. If that fails, guess it will be a trip to the SC.

    If nothing else, maybe HW 3.0 will resolve this issue.
     
  9. jfinephilly

    jfinephilly Banned

    Joined:
    Jan 2, 2020
    Messages:
    321
    Location:
    Philly
    This worked. Thank you!
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC