Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Side cameras stopped working?

markrally

Member
Sep 8, 2020
21
18
Swansea
Hi all

I started getting a warning on the screen about 10-14 days ago along the lines of 'Autopilot cameras not working, but they may return on your next journey'. After reading some of the comments about it being a regular winter thing, I thought it was road spray or condensation that was causing the issue and didn't pay that much attention to it. The decent weather today, however, meant I had the opportunity to go around the car and clean off all the camera lenses. It seems the two side cameras aren't functioning at all. The front and rear cameras are okay, but trying to call up the two side cameras results in two blank screens and a 'loading' icon. Calling up stored video clips shows all four camera views from around a month ago, but only front and rear on today's journey.

Any thoughts? Is this something that I need to book a service appointment for?

Thanks
 

VanillaAir_UK

Well-Known Member
Jun 17, 2019
8,212
5,734
Surrey, UK
Yep, not the same thing as cameras blocked or blinded.

A full reboot may help but if no progress, one for a service appt. Hopefully it can be a remote and/or ranger fix.
 
  • Informative
Reactions: markrally

Electric Dream

Pilots the Millennium Milkfloat
Supporting Member
Jul 21, 2016
1,753
2,827
UK
It's a common issue with the latest batch of cars I'm afraid. A service appointment is the only way if a reboot doesn't fix it but you should get a ranger.
 
  • Like
Reactions: markrally

sw25481

Member
Oct 11, 2020
27
24
Epsom
Has anyone actually had this fixed? The car I picked up today has it and I have to drive it to a service center. I am wondering it it takes long? Do I need a lift back, am I going to be there long?
 

joanfa

Member
May 22, 2020
30
14
UK
I have had several issues with the cameras lately, which ended up by the SC changing both the pillar B cameras.

I started getting alerts of "blind or blocked cameras" constantly, not depending of weather, and after 2 visits to the SC they decided to change them both. I observed condensation in those cameras although Tesla said they thought that wasn't the issue.

I've been now driving for 12 days approx with the new cameras and I still see the alert every now and then, although less frequent and for much shorter periods of time (maybe just a few seconds, as opposed as minutes as before), so not sure if the actual issue is sorted and that;s just part of how the car works...but it's annoying anyway.
 
  • Informative
Reactions: DenkiJidousha

Durzel

Active Member
Jul 17, 2019
3,433
2,398
Bath, UK
It doesn't help that the message is pretty useless.

"Blocked or blinded" is a common occurance when its dark when you're on country lanes. Obviously the camera is neither blocked nor blinded, but it just can't really see anything.

Having said that, I've had "multiple cameras are blinded" and "left door pillar camera is blinded" for almost an entire trip recently, when it was just foggy, but not particularly dark.
 

Morhydro

Member
Mar 26, 2020
159
85
Scotland
It doesn't help that the message is pretty useless.

"Blocked or blinded" is a common occurance when its dark when you're on country lanes. Obviously the camera is neither blocked nor blinded, but it just can't really see anything.

Yes - this. I have written to TESLA. What is needed is a setting to 'reduce camera warnings'. Simply there is no fault but there is no interpretable image so the blocked or blinded message is displayed. So this is a false alarm and distracting for the driver. A simple setting would solve the problem on country roads, in snow, in fog etc.
 
  • Like
Reactions: DenkiJidousha

Basicbob

Member
Oct 14, 2020
77
6
London
Hi

I’ve had my car for 3 weeks and it’s already been to Tesla Park Royal and now Heathrow.

just noticed today the driver side camera isn’t working it’s just a black screen with a buffer symbol.

Any ideas on how to rectify this? I don’t want to take it to Tesla again!

thanks in advance
 

Alistairuk

Member
Jun 25, 2020
522
350
Scotland
Afraid I seem to now have this problem with a September delivered SR+

Looking at the reversing camera it appears to be the right camera (the one on the indicator not door pillar).

Did anyone have any luck with it resolving itself, ie is it worth waiting a few days to see if it fixes itself or should I just raise service appointment now? I tried restart earlier but still nothing except a little spinning circle over the video feed from that camera.
 

Twurzel

Member
Aug 1, 2020
50
12
Salisbury, UK
I have just had mine replaced, a service centre appointment was the only option. It took about an hour to replace. My camera went before Christmas but the first chance to replace it was the 15 January due to part availability problems (apparently a lot have been failing). All working now though, only gripe is that they only had the new black covered camera and I just missed the update (early September car) so I currently have one black and one silver camera. Ranger appointment booked for the 1 Feb to rectify the situation.
 

markrally

Member
Sep 8, 2020
21
18
Swansea
I booked a service centre appointment last week but remote investigation work is still going on, so the appointment has been put back to early Feb. The current lockdown situation isn't helping matters - I live around 100 miles away from the nearest service centre (Bristol) and so, while I doubt I'd be able to wait while the work was carried out, it seemed a courtesy car wasn't available.

It could possibly be fixed by a ranger appointment but that's not currently being offered...
 

Zakalwe

Member
Oct 16, 2020
446
432
UK
Hi

I’ve had my car for 3 weeks and it’s already been to Tesla Park Royal and now Heathrow.

just noticed today the driver side camera isn’t working it’s just a black screen with a buffer symbol.

Any ideas on how to rectify this? I don’t want to take it to Tesla again!

thanks in advance

My LR was the same. The camera will have to be replaced, though it can be done by a Mobile Ranger. Get an appointment booked via the app and ask for a Ranger visit.
 

Alistairuk

Member
Jun 25, 2020
522
350
Scotland
My LR was the same. The camera will have to be replaced, though it can be done by a Mobile Ranger. Get an appointment booked via the app and ask for a Ranger visit.

Ive booked an appointment at Edinburgh for Thursday (first available) and put in if possible can I have mobile service fix it as it’s a pita to go to Edinburgh for it, waiting to see what they say now.
 

init6

Member
Oct 16, 2020
514
284
Scotland
Ive booked an appointment at Edinburgh for Thursday (first available) and put in if possible can I have mobile service fix it as it’s a pita to go to Edinburgh for it, waiting to see what they say now.
Will watch with interest, one of my cameras has gone faulty and as you say Edinburgh isn't particularly handy.
 

DaveG_NJ

Member
Oct 7, 2020
298
815
NJ
There have been quite a few reports of this over the pass few months. I suspect a bad batch. My passenger side repeater was DOA when I took delivery. Made a service appointment but the camera was backordered, so I bought one on eBay. Took about 15 minutes to swap out and a reboot to get the replacement camera to work.
 
  • Informative
Reactions: Durzel

Wuddie

Member
Sep 18, 2020
100
69
Halesowen
Picked up my 2021 LRM3 19th November and had this problem around 10 mins after leaving the service Center, service appointment booked at SC on 23rd November, they had it a day to fix some other stuff and then told me that the camera was on back order and they would organise a mobile ranger to fit when it come in stock, I called SC middle of December to be told they were still waiting, called again last week and was told BREXIT !! Was no making it difficult to get the part quickly .. what I conclude is they don't have enough of the parts that work yet to cover the cars that are faulty and are just making up excuses for delays.. I'll keep chasing until it gets resolved but not holding my breath!
 

Corrimal

Member
Nov 3, 2020
15
6
UK
Mine was replaced last week at home after delivery on 12/12 where it immediately was identified via warnings - 5 minutes he was there. It was booked in just before Xmas with 14/01 visit. LHS camera replaced. Now the Autopilot works...but is scaring the life out of me.
 

Alistairuk

Member
Jun 25, 2020
522
350
Scotland
Will watch with interest, one of my cameras has gone faulty and as you say Edinburgh isn't particularly handy.

Tesla contacted me this morning - if you want to goto Edinburgh earliest is 7th February due to part availability - I asked about mobile service instead and am awaiting the mobile tech contacting me with a date - will let you know what they say :)
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top