Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Software crash on v9.0 (2019.8.5 3aaa23d)

Are you facing crash or battery drain issues with v9.0 (2019.8.5 3aaa23d)

  • Yes

  • No

  • Don't know but my battery is draining faster than normal


Results are only viewable after voting.

imthiazah

Member
Dec 14, 2017
54
10
San Jose
2019.8.5 is really annoying.

Mine AP2.0 is rebooting almost everyday.
Today, after I summoned the car into the garage, plugged the charger in like everyday routine - then walked away. 2 hours later, When I was driving another car into the garage, I heard the music. Looked into the X passenger door - omg the car was awake & unlocked. All door closed, no keyfob inside, no passive entry. Opened the door then closed made no any effect. Had to reboot the computer to make it normal again.

I had this exact same issue happen to my car. I had to manually power it off. Ever since that happened, I check my car via the app to see if it is awake. The way to check is to see if Media option shows in the app after you have walked away. This means the car is awake and you need to manually turn it off or reset the computer to avoid battery drain.
 
  • Like
Reactions: r0xx0r

khoat1

New Member
Nov 27, 2017
2
0
Laguna Niguel
Yes my MX MCU rebooted several times today. It has happened after getting the lastest 2019.8.x updates. Slacker is also having issues and after the reboots, navigation can be slow to work normally again. I have a service appointment next week for a different issue but will let them know about this issue.
 
Similar experience here. Spotify stutters frequently and this morning the vehicle appeared to be stuck in "powering up" mode with the main display remaining black. Freaked me out a little. I reset and after a few minutes the main screen came to life, phew .... I think this version (2019.8.5) is the most unstable version released so far. I also think there's a lot more processing going on with this release. My vehicle is a Dec. 2017 model, so I believe H/W 2.5, still the older MCU because I only have 3G.
 

CaliMS

Member
Oct 8, 2017
143
100
CA
I had this exact same issue happen to my car. I had to manually power it off. Ever since that happened, I check my car via the app to see if it is awake. The way to check is to see if Media option shows in the app after you have walked away. This means the car is awake and you need to manually turn it off or reset the computer to avoid battery drain.


I've had this 3x now as well. In addition to daily reboots while driving.... not good.

(I'm on 8.5, MS, AP2.5, MCU1)
 

imthiazah

Member
Dec 14, 2017
54
10
San Jose
I really hesitate to post because it will jinx my X :( Nonetheless, I have not experienced any of these issues since upgrading to 2019 5 on April 4. I have only driven for 10 hours and just over 350 miles so anecdotal info by all means. I have an August 2018 build X75D with 2.5 and MCU2

You probably dont need to worry as you have an MCU2. I think it is happening to people with MCU1 alone.
 

imthiazah

Member
Dec 14, 2017
54
10
San Jose
Similar experience here. Spotify stutters frequently and this morning the vehicle appeared to be stuck in "powering up" mode with the main display remaining black. Freaked me out a little. I reset and after a few minutes the main screen came to life, phew .... I think this version (2019.8.5) is the most unstable version released so far. I also think there's a lot more processing going on with this release. My vehicle is a Dec. 2017 model, so I believe H/W 2.5, still the older MCU because I only have 3G.

I have a Dec 2017 build X75D with MCU1 and get LTE. So not sure if that's the best way to differentiate MCU1 from 2..
 

ABC2D

Active Member
Dec 19, 2016
1,118
1,504
Home
I am on v9.0 (2019.8.5 3aaa23d)

1) software crashed while driving earlier today. The car continued driving and responding to acceleration, brakes etc but it was a scary moment, the software restarted automatically
2) battery consumed far more than needed. I have an approx 10 miles round trip to drop my son to the school and it consumed 16 miles even though the car took 252 Wh/mi over the past 15 miles.
3) after the software crash the system restarted while I was still driving and it displayed 101 miles and within a less than a mile drive dropped to 98 miles.

Can you please detail how you determined the "Software memory leak" that you put in the title?
 
  • Like
Reactions: Alketi
Have you also noticed audio skipping or distorted music when listening to slacker radio? I am having a lot of slowdown and the MCU feels unstable since 8.2. Wonder if it gets worse from here..

I have lost so much functionality since the 8.2 update. I have actually had it in the service center due to a repetitively faulty passenger side window since this, and they had to replace my whole MCU because the update would not take. My homelink was not working properly, audio 'skipping' from slacker and TuneIn on my podcasts. I've resorted to using my phone for audio through the bluetooth, but even that seems sketchy, sometimes it won't connect to my phone, sometimes it will connect to my phone when my kids walk into the garage with my keys to plug the car in. I have also had the MCU crash while driving, multiple times in my 1 hour morning commute just today in fact. I have also had it do a partial crash, where the background apps crashed, but my rear camera stayed active through the whole restart.
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top