Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register
  • Want to remove ads? Register an account and login to see fewer ads, and become a Supporting Member to remove almost all ads.
  • The final cut of TMC Podcast #29 is available now with topics time-stamped. We discussed the Tesla Cybertruck's expected 1 MW Ultra-Fast Charging capability, the Tesla Semi Delivery Event, the coming Model 3 refresh (project "Highland"), and more. You can watch it now on YouTube.

Software downloads bugged - update notifications disappear when on wifi

I've had a software update pending to 2021.24.4 since getting my Model 3 back from the service centre a week ago. It asks me to get on Wifi to download it. As soon as I get on wifi, all the relevant prompts to download it disappear and the car says I'm already up to date (it's the same behaviour in the app and the car).

I've tried letting the car go into a deep sleep overnight, power cycling via the power button the menu, and hard rebooting and soft rebooting via the steering wheel buttons & brae pedal. Nothing seems to fix it.

Video here:
What can I do? I don't have premium connectivity. Thanks!
 
Not sure but I think 24.4 got pulled due to a bug that exposed some debugging menus in dyno mode; probably have to wait until the next public 24.x version gets pushed to your car. Maybe 24.10.
That would be my guess too. For what it's worth 24.10 may have gotten pulled too. I'm currently on 24.4 (been meaning to play around with the debug menus a bit in comparison to Scan My Tesla) and have had a prompt to update to 24.10 for maybe a week. Yesterday I got prompted to update to 24.5, so thinking maybe they pulled 24.10 too. I'd assume people already on 24.10 are waiting for another incremental version, but people still on 24.4 they want to get moved off.
 
  • Informative
Reactions: thewishmaster
Same story here. Update download reached 100% and then stuck (2021.36.5.5).
The car left overlight on Wifi and sentry mode (to prevent sleep) and any signs of update disappear in the morning.
Nothing helps so far.
After chatting with Tesla support, I have fixed it by the following:
Park car near WiFi, Do soft reboot (2 buttons), Do Power off, Wait 5 min, Press brake to awake the car, and install prompt should appear again.
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top