TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC
Start a Discussionhttps://teslamotorsclub.com/tmc/tags/

Sometimes auto lane change doesn't work

Discussion in 'Model S: Driving Dynamics' started by RLC3, Jun 2, 2017.

  1. RLC3

    RLC3 Member

    Joined:
    May 11, 2017
    Messages:
    20
    Location:
    Portland
    Sometimes when I use the turn signal to initiate a lane change in AutoPilot in my AP2 Model S, the car completely ignores my request. Other times it works fine. We haven't found any obvious reason.

    Any ideas?
     
  2. Tam

    Tam Active Member

    Joined:
    Nov 25, 2012
    Messages:
    2,951
    Location:
    Visalia, CA
    Mine does not work on local streets but it does work for freeways.
     
    • Informative x 1
  3. rhumbliner

    rhumbliner Member

    Joined:
    Sep 24, 2015
    Messages:
    302
    Location:
    Las.Vegas Jackson.Hole Fish.Creek
    I've occasionally experienced this same behavior with AP1. No idea why.
     
  4. Haxster

    Haxster Member

    Joined:
    Apr 4, 2016
    Messages:
    606
    Location:
    Silicon Valley
    After the last two software updates (or shortly after), the "lane change" check box got unchecked. Once I re-enabled it in the configuration, all was well.
     
  5. BrettS

    BrettS Member

    Joined:
    Mar 28, 2017
    Messages:
    489
    Location:
    Orlando, FL
    The car definitely does some checking to make sure it's safe to change lanes... if the camera can't detect another lane in the direction you are signaling then it won't attempt to change lanes. Likewise, if the ultrasonic sensors on the side of the car detect an obstacle, or have recently detected an obstacle the car won't attempt to change lanes. I have discovered that I'm if im trying to move into a lane shortly after another car passed me in that lane there is a much longer delay before the car attempts to move into the lane.
     
    • Helpful x 1
  6. RLC3

    RLC3 Member

    Joined:
    May 11, 2017
    Messages:
    20
    Location:
    Portland
    It's possible the failed lane changes were due to the adjacent lane being poorly marked. I was on better roads the last couple of days, and did about 30 lane changes. All of them worked fine.

    Thanks.
     
    • Love x 1
  7. tpham07

    tpham07 Member

    Joined:
    Mar 21, 2017
    Messages:
    585
    Location:
    Baton Rouge
    My auto lane change will not work on what the car thinks is local roads (even state highways where the speed limit is 65). Interstates though, no problem.
     
  8. Bruinfan

    Bruinfan Member

    Joined:
    Sep 3, 2016
    Messages:
    66
    Location:
    Elk Grove, ca
    AP1
    my experience has been a correlation btwn drunk driving AP and lack of lane change.
    consistently i've seen this:
    small stretch of NB only I5 btwn florin exit and 50/80
    I5 btwn bakersfield and modesto
    I5 north of corning SC to the border.

    lanes are marked, but for some reason, it doesn't work well.
     
  9. Snowstorm

    Snowstorm Member

    Joined:
    Dec 8, 2016
    Messages:
    368
    Location:
    Ontario Canada
    I experienced that today, more than a few times. This is strange as I haven't seen this issue before. AP1.

    Lanes render as normal, I can see the next lane shown on the dash. As soon as I signal left, the left lane disappear and no lane changes. Turn signal off and left lane reappears. Was on a divided limited access highway with 100kmph speed limit (407 in Toronto Canada)

    It sometimes will work, but not all the time. It used to always work.
     

Share This Page