TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Spotify: My Library loading issues

Discussion in 'Model S: User Interface' started by Pagemakers, Apr 28, 2018.

  1. Pagemakers

    Pagemakers Member

    Joined:
    Dec 25, 2016
    Messages:
    55
    Location:
    Manchester UK
    Anybody with Spotify installed in their car having loading issues of “my library?

    For the past couple of days it never connects. A reboot fixes it only for a short time.

    Rest of Spotify working normally.

    2918.14.2

    I’m in the U.K. if that make any difference.
     
  2. milleron

    milleron Member

    Joined:
    Jun 16, 2017
    Messages:
    161
    Location:
    Columbus Ohio USA
    In the UK, you get Spotify instead of Slacker? Lucky bums. I guess Elon's allegiance to the Commonwealth is showing.
     
  3. Pagemakers

    Pagemakers Member

    Joined:
    Dec 25, 2016
    Messages:
    55
    Location:
    Manchester UK
    We do. Not heard of Slacker here.
     
  4. arubinst

    arubinst Member

    Joined:
    Apr 3, 2016
    Messages:
    272
    Location:
    Ecublens, Switzerland
    Europe gets Spotify.
     
  5. Mawesti

    Mawesti New Member

    Joined:
    May 4, 2018
    Messages:
    2
    Location:
    Brussels
    I have an issue that spotify but cannot load any of the playlists (featured etc..). Also, the songs show up but are greyed out. However the radio stations do run for a few minutues. Could this be down to a regional restriction? How do I change this?
     
  6. AustinP

    AustinP Member

    Joined:
    Apr 6, 2015
    Messages:
    583
    Location:
    Belgium
    Dumb question probably, but did you try a reboot ? There are two flavors of reboot afaik: 1) long press both wheel buttons until Mcu goes dark, and 2) same but with brake pedal pressed all the way during the reboot.

    Just for history, RoW (Rest of the Word outside US) initially had R.dio instead of Slacker. R.dio went bankrupt and this is when Tesla switched “us” to Spotify. Brilliantly quickly I might add. Which I’m very happy with indeed. But I have no Slacker experience so can’t say how they compare.
     
  7. Pagemakers

    Pagemakers Member

    Joined:
    Dec 25, 2016
    Messages:
    55
    Location:
    Manchester UK
    Yes rebooted.

    However for the past few days it’s worked so maybe just a glitch.
     
  8. Mawesti

    Mawesti New Member

    Joined:
    May 4, 2018
    Messages:
    2
    Location:
    Brussels
    Yes, I rebooted in every way. However, it has not resolved the issue. I can even log in with my own Spotify Premium account and the exact same thing happens.
     
  9. .jg.

    .jg. Member

    Joined:
    Feb 27, 2018
    Messages:
    390
    Location:
    Weston Super Mare, England
    I just tried connecting with Slacker (from the UK) and when I tried to play something, I received this message "We're sorry. Slacker Radio is only available in US and Canada". As Slacker isn't available here, I guess we will have to put up with Spotify :)

    As I understand it, there is a "Spotify Test" in the maintenance menus of Teslas in the USA, so perhaps you will get Spotify at some point.
     
  10. Asterix187

    Asterix187 Member

    Joined:
    Oct 7, 2017
    Messages:
    611
    Location:
    England
    I get this almost every day. Drives me nuts
     
  11. tomschouteden

    tomschouteden Member

    Joined:
    Apr 4, 2016
    Messages:
    27
    Location:
    Antwerpen, Belgium
    I'm experiencing the exact same problem. Spotify is working fine but My Library is not showing up so no way to access personal songs and playlists. Tried rebooting as well as logging in and out of Spotify to no avail. Has been consistently unavailable for over a week now.
     
  12. cynix

    cynix Member

    Joined:
    Jul 7, 2014
    Messages:
    815
    Location:
    Sydney, Australia
    I'm experiencing a different problem with Spotify. It would often skip back a couple of songs, for example it would play song A, then song B, then, after playing the first second or so of song C, it would play song A again. This will continue until I manually skip forward past song C. Tried rebooting, and logging out of my Spotify account and logging back in, but nothing helped.
     
  13. emmz0r

    emmz0r Member

    Joined:
    Jul 12, 2018
    Messages:
    844
    Location:
    Norway
    Same problem here. Any solution?
     
  14. Tom DB

    Tom DB Member

    Joined:
    Nov 13, 2018
    Messages:
    13
    Location:
    Belgium
    Same problem. Unable to login. I have a Spotify premium account. When I have the issue the Tesla account doesn't work either. I'm on 2018.46.2, Tesla X.

    Resetting the center console solves the issue. I have the issue daily, multiple times.

    Really annoying, knowing I have paid for this functionality.
     
  15. AustinP

    AustinP Member

    Joined:
    Apr 6, 2015
    Messages:
    583
    Location:
    Belgium
    When it happens to me, I switch the audio to FM or TuneIn. And then going back to Spotify usually does the trick.
     
  16. Pagemakers

    Pagemakers Member

    Joined:
    Dec 25, 2016
    Messages:
    55
    Location:
    Manchester UK
    I’m in contact with Tesla almost monthly over this and it’s still never permanently fixed.
     
  17. LondonMark

    LondonMark New Member

    Joined:
    Dec 17, 2018
    Messages:
    2
    Location:
    UK
    I also have the library loading issue with Spotify in my (very recent) Model S. I have tried rebooting but that didn't help at all. It does sometimes load my library but I would say the success rate is only one day in four. Sometimes switching to another source and back to Spotify does help but usually not.

    I was expecting some compromises as part of owning a Tesla (noise at speed and a giant steering wheel) but it is a shame some of the transformational tech is also so unreliable.

    My car is visiting the service centre later this week (to stop its dipped headlights from dazzling other drivers) and I have asked them to look at the library loading problem. I don't expect they will have a fix but I will post anything I do learn.
     
  18. Pagemakers

    Pagemakers Member

    Joined:
    Dec 25, 2016
    Messages:
    55
    Location:
    Manchester UK
    What a surprise. Mine won’t load this morning.
     
  19. LondonMark

    LondonMark New Member

    Joined:
    Dec 17, 2018
    Messages:
    2
    Location:
    UK
    During my service centre visit yesterday they told me the latest software release (2018.48.12.1) was making the issue much better... but mine still doesn't work.
     
  20. Pagemakers

    Pagemakers Member

    Joined:
    Dec 25, 2016
    Messages:
    55
    Location:
    Manchester UK
    I’m only on 46.2 and it’s crap. The browser is bust too and has been for months.
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC