TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Stuck in Time-based control

Discussion in 'Tesla Energy' started by doodledude, Jan 6, 2020.

  1. doodledude

    doodledude New Member

    Joined:
    Jan 6, 2020
    Messages:
    3
    Location:
    PA
    Hi,

    I have a newer installation and was exploring the settings earlier today. I selected Advanced and was playing with the time based control settings and then reverted back to set powered. I noticed strange flow directions and checked the gateway web portal and it is showing Time-based control as the current mode. I’ve tried toggling it several times but the gateway seems stuck. For now I shut off the powerwalls manually and called support. I was told it might take 1-3 days for a resolution but was curious if anyone had experienced this before and might know of a solution.
     
  2. JayClark

    JayClark Member

    Joined:
    Aug 6, 2019
    Messages:
    222
    Location:
    Arizona
    #2 JayClark, Jan 6, 2020
    Last edited: Jan 6, 2020
    It can take between 5-15 minutes for changes to take effect, some times longer if you've made a bunch of simultaneous changes in a row, as it seems the PW goes through and processes each change you've submitted sequentially. Also, with each individual change, there is a period of time that when the settings are being processed, where the flows bounce around in various directions before things settle out the way you'd expect. I.e. lots of toggling can queue up quite a few changes, and might take some time to flush out from my experience.

    Some older firmware versions (which yours might be if it's new) took up to a few hours for each change take effect. And in fact, support will call you, and most likely have you turn it all back on, change the mode to what you want, and then have you wait up to 2-4 hours (or even a full day) before they'll do anything else to support you.

    Also, in addition to the 5-15 minutes it takes to implement changes after you adjust settings (on the newest firmware versions), depending on your gateway connectivity, what the Tesla app is showing can be delayed by anywhere from a few minutes, to many minutes, as compared to what is actually occurring on the Gateways & Powerwall(s)... you have to login locally via your local gateway HTML site to insure you're seeing real-time state of the flows. This was confusing me for quite a while. By logging in to the local HTLM gateway site, and comparing to your app, you'll see the slightly delay - and if you see "not connected" popping up a lot on the HTML gateway view (in your browser) then you can be pretty sure your app is often a bit behind anytime the local gateway is losing connections.

    Seems many folks with Gateways connected via wifi find they are losing connections off and on with regular frequency, and when this is occurring making changes can be very confusing in terms of what the Tesla App is showing because the disconnects cause the Tesla app to show and freeze on states & flows that are out of sync until the gateway connection is reestablished, and updates resume to the app for the flows.
     
    • Informative x 1
  3. doodledude

    doodledude New Member

    Joined:
    Jan 6, 2020
    Messages:
    3
    Location:
    PA
    Thanks. I’ve been hoping it was just delayed but it’s been about 3.5 hours now. I do keep checking intermittently though.
     
  4. JayClark

    JayClark Member

    Joined:
    Aug 6, 2019
    Messages:
    222
    Location:
    Arizona
    Okay, if the PWs are still shutoff manually, then I'm not sure what the gateway will do with the settings. After a few hours, if you don't see the change, I'd make it the more time, then wait for a few hours. Also, definitely try logging in locally to the gateway web server to watch he flows and such there as they take effect.
     
  5. doodledude

    doodledude New Member

    Joined:
    Jan 6, 2020
    Messages:
    3
    Location:
    PA
    Unsure if Tesla support did something or if it just worked itself out, but everything is back to normal now. Thanks for the tips @JayClark
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC