Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
  • Want to remove ads? Register an account and login to see fewer ads, and become a Supporting Member to remove almost all ads.
  • The final cut of TMC Podcast #34 is available now with topics timestamped. We covered Tesla's rollercoaster prices, Toyota pushing junk science, Mike's new Model 3, Optimizing track mode for snow driving, FSD V11 apparently coming by the end of this week, and more. You can watch and check out the chat replay on YouTube.

Tesla 3 charging door won't open

Hopefully this will not be the issue for you but I had a very big problem with the charge port door and the car not charging. If you are able to open the door manually and charge than that's not a huge issue (points to an issue with the charge port door most likely or even the 12v battery). If when you open the door it won't charge that's more of a headache. In my case they replaced the charge port, 12v battery and a bunch of other stuff and I still had trouble. Eventually they had to take the car long term and strip it down to the find a loose wire deep in the middle of the wiring harness. I never had a problem once they found this but it was a very tough thing to diagnose and fix. 12v battery is often a culprit and simple fix though.
There is a clicking sound, but the cable remains stuck until I release it from the trunk.
Hey, I may have a solution for you, based on the opposite problem I just had yesterday with our car. When I hooked up the cable to our car, after a long trip, it started making ugly 'clicking' noises I've never heard before. Didn't think there was a problem until I saw a red triangle on the dash, which said the cable didn't latch, and wasn't charging. So I removed it, and this time consciously shoved it in there solidly, to make sure it was all the way in. No problem after that. So my suggestion for you is to also shove the cable in before pressing on the button, which might reduce the force required on the motor to unlatch it. Give it a try, and see if that works :).
  • Helpful
Reactions: EAV1 and Phlier
Problem went away in an interesting way. After writing my previous post I removed the cable by pulling harder. Every time since that I have been able to remove the cable by using slightly more force than I would normally use. Everything works fine otherwise, so nothing is broken I guess. I also have been doing what elptxjc suggested.

To be clear, when I used the solution in the trunk, removing the cable did not require that much force, so there is definitely some small problem still.
  • Informative
Reactions: Phlier
I had this issue yesterday. After various reboots and cable pulls without success, I scheduled a mobile service call for next week. After reading this thread I pulled the door open with my fingers. The door now seems to work normally. My question -- Based on others' experiences should I continue with the mobile service to fix an underlying issue or does prying the door open seem to fix a temporary glitch so I can cancel the service?
Strangely, I had this happen to me this morning(first time). I eventually opened it with a couple gentle whacks on the charge port door.
I honestly tried everything for the same type of problem, and this was the only thing that worked surprisingly. Just tapped it with my palm lightly a few times while using the cable’s wireless unlock button simultaneously. Don’t know if this fix will necessarily work for everyone, but definitely worth a try if you’re in a tough predicament with a need for immediate charging. Shout out to Sophias dad for the advice!


Active Member
Supporting Member
Jul 29, 2018
predicament with a need for immediate charging
The lid isn't actually ever locked down, if you can't get it open electrically just lift the lid with a fingernail, credit card, suction cup...

You should get a service order opened up. The whack-to-open only worked a dozen or two times before I had to pry it up every time, and then it started not closing as well, after another dozen or so times. They rescheduled my door-opener replacement twice due to lack of parts.
I have a 2018 M3. I had this happen to me twice in the last week which prompted me to find this thread. The first time I thought it may have been due to freezing weather. However, the second time the weather was not below freezing. I was able to open it both times (the first after waiting for the car to warm up a bit in the garage in case it was frozen) by getting my fingers under the door.

My question (and I feel dumb asking it) is how bad should I let it get before I schedule service? I'm afraid of a guy coming out and saying that there isn't anything wrong because he cannot reproduce it. Should I schedule it now or wait until it happens more frequently?

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.