Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
  • Want to remove ads? Register an account and login to see fewer ads, and become a Supporting Member to remove almost all ads.
  • We are looking for another podcast participant who can act as a lead co-host to join the TMC Podcast. If you are interested in participating please see this thread.

tesla app say 'update', but car has higher version

okay a bit of context here.

I have a 2018 M3 LR AWD, with FSD auto.

I'd gotten up the confidence to install an ECU gen 4 to allow CCS charging (including a FalconFour 'bundle of wires'). The upgrade was super nerve wracking for me, but worked as the videos and tutorials I found on here stated. The one issue I had was that I had deferred the 2022.44.25 update earlier this week to do this upgrade 4 days later (several times deferred, in fact). I attempted to do the update after the install, and found the system said something to the fact of 'you deferred too long, you need to reboot the infotainment system'. I did that seeveral times and attempted to make the app run the update after it connected to the car.
I'd also saw a video were someone used 'service mode' to 'reinstall', and the car did a reinstall up to 2022.44.30.5. Re-install worked, but the app still believes there's an update to push. I've uninstalled and re-installed the app, but the app is still showing an update.

Will this fix itself, or should I wait a few days. Car seems to work fine, charging works (and am gonna test the CCS with my adapter in the next few days), so I can live with the issue if it's temporary.
When you reinstall using Service Mode, it reinstalls the exact same software version you have on the car at that moment. It does not change the version.

Are you sure the app shows version 2022.44.25 on the home screen, where it shows you the update is ready to install? Because clicking into the release notes might show info for an older version if all it adds are bug fixes.

In my case, my car is on 2022.44.30.10 (FSD Beta when I tap on Release Notes it shows notes for 2022.44.25 (FSD Beta 10.69.25). Your 2022.44.30.5 is FSD Beta
I don't know if this comes into play but one thing to note is that it will only check for a new version once every 24 hours. So if you go to the software tab and it says up to date as of yesterday at 6pm and it's currently 5 pm, go to the software tab again an hour later and it will actually check the server for an update because now it is actually >24 hours since the "as of" date.

I got a new push to the 2022.44.30.10 update last night. I told the app to start the update, instead of from the dashboard, and the error in the app went away.

Appreciate the comments, thought I'd post an update incase I see this again in a few years...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.