Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register
  • Want to remove ads? Register an account and login to see fewer ads, and become a Supporting Member to remove almost all ads.
  • The final cut of TMC Podcast #29 is available now with topics time-stamped. We discussed the Tesla Cybertruck's expected 1 MW Ultra-Fast Charging capability, the Tesla Semi Delivery Event, the coming Model 3 refresh (project "Highland"), and more. You can watch it now on YouTube.

Tesla error code BMS_w150 and BMS_f150

gico

New Member
Jan 27, 2021
4
2
Rome
hi guys, I state that the car is currently working perfectly. However, I usually go to check the errors reported in the notification center although they are not active. I found 2 with the codes referred to in the subject of this post.

I immediately opened the ticket with Tesla to ask for information, hoping for the usual answer they give lately: it is a software problem that will be solved with the next update

instead no. They tell me to bring the car because after consulting with the parent company (I live in Italy) my car would be at risk ... I no longer remember the English term ... But it is something as the car would be have a road arrest

I bring it to them and the first thing they do is charge the battery to 100% and put it under their detectors and for 18 hours left at 98% charge

the diagnostics gave a negative result, i.e. at the moment they are groping in the dark

On the other hand, they invented as an attempt to change a part which, to change it, would involve putting the car on the bridge, disconnecting and lowering the main battery, replacing the piece they believe is the cause and reconnecting it



Needless to say, hearing this in front of a perfectly functioning car and without any sign of an anomaly, I immediately asked to take it back and while the piece arrives I meditate on it.

Since sooner or later this piece will arrive and since they are not absolutely sure that this is the cause it is just an attempt they told me they are doing and If it is not that, they will have to continue further.

Since at this very moment my car continues to go which is a beauty and indeed yesterday I tried the ludicrous + mode for the first time, I see no reason to subject my car to such stress

To paraphrase it would be as if a person who once had a cough (the last error report dates back to 10 days ago) immediately had a bronchoscopy done. Perhaps first it is better to go through a tac what do you say?

Here is the reason for my post: is there someone who has seen these error codes. And if so, what was the real cause?

I would like to avoid having the car disassembled



thanks let me know
 
I'd share your concerns with the Service Center. If they aren't asking for money, I would personally think Tesla just wants avoid problems and figure out what is going on. prevent a problem Let them know when you don't understand what they are trying to do. Ask them to explain.

You might listen to the Q4 talk from today.
Tesla goal is to work toward perfection in order to AVOID service calls.
Elon/Tesla has often stated SERVICE will not be a profit center. Very different from other auto makers.

The best service is not to need any service, right? Let us hope & help Tesla attain this goal.

good luck, enjoy your new ride, have fun
 

gico

New Member
Jan 27, 2021
4
2
Rome
Hi,
Thank you for you suggestion but I have already shared my concern with the Service and they have told me that they have sent the log to Tesla and Tesla has replyed them to “try” to change a component attached to the main battery but if in this way the problem persists they will have to continue to investigate
You have to know my car is quite new and I wouldn’t disassemble it part after part till they will find the solution .
So the reason of my post is to try to look for someone else he has had the same error in the past to let me know how it has been resolved
 
  • Helpful
Reactions: Brando
Hi,
Thank you for you suggestion but I have already shared my concern with the Service and they have told me that they have sent the log to Tesla and Tesla has replyed them to “try” to change a component attached to the main battery but if in this way the problem persists they will have to continue to investigate
You have to know my car is quite new and I wouldn’t disassemble it part after part till they will find the solution .
So the reason of my post is to try to look for someone else he has had the same error in the past to let me know how it has been resolved



I got the same issue f150 qnd w150 but my car is stopping charging frequently. And starting charging again by it self. Sone times 20 times in 12 hours . Some times charging is not starting again after being interrupted. Tms 2016 90D 150miles . Norway. Follow teslafromhell at snap and insta just started posting more will come ... stay tuned
 
Update ....


Got email from service center just now .

They say it software related and 2021.4 will fiks it .

"Etter besøket ditt til Tesla Oslo Nord i dag 05.02.21 rundt kl. 07:30 har vi nå fått inn resultat av fjerndiagnostisering av din bil som viser at dette er en firmware feil som vil bli fikset ved firmware versjon 2021.4."

This is on Norwegian.

But lets see if its a fact that it will solve the problem .

Yet to see.
 
Did you reboot after swapping out the AC? A setting a different tire configuration might cause it to rescan the accessories.
I measured all hv components and they were all in specs, i use tesla guide how to do it. proped all components.

Could it be possible, that software is jammed somehow?

i install software again at factory mode, and while it was installing, i hear main contactors trying to contact few times, so i think that is reason why "sw precharge too long"

this is like f_027 repeatedly, but not shown anywhere...

like to hear what you all are thinking of this!
 
Mine did that when I had the shorted AC and also when the PTC heater was shorted. Can you try changing the wheel configuration to something else (any other wheel option shown in the list) and let it reboot to see if the codes come back?
Must try tomorrow. Also guy from t-diag takes teamviewer contact.
Here is one picture from today, what is fc contactor?
 

Attachments

  • 56CBA015-399E-4FAB-AE43-E6DABA32C29D.jpeg
    56CBA015-399E-4FAB-AE43-E6DABA32C29D.jpeg
    587.2 KB · Views: 429
Yay!!! You might be able to fix it for $5buck. Although I bought a new PTC heater, I opened the old to see what was wrong. It turns out one the verticle transistor is shorted (see pics). It's about $5 on Mouser.
 

Attachments

  • CD69D1E0-FD4E-4032-8B59-4A99F294746B.jpeg
    CD69D1E0-FD4E-4032-8B59-4A99F294746B.jpeg
    457.5 KB · Views: 201
  • 54ECB55A-889B-4524-99E8-A3274BBDC194.jpeg
    54ECB55A-889B-4524-99E8-A3274BBDC194.jpeg
    318.8 KB · Views: 168
  • 2485D1A1-8388-4E6B-9769-F8A720C4FA8D.jpeg
    2485D1A1-8388-4E6B-9769-F8A720C4FA8D.jpeg
    575.2 KB · Views: 194
  • Like
Reactions: terofin
Ok! Can you tell me how to do disassembly, or where i can find instructions for that?
I am no expert at this, I was just removing things as I saw them.
1. Plastic cap covering the electronics was removed by gently prying on the 5 plastic clips.
2. CANBUS board (I think that's what it is) was removed by removing the 4 screws holding it down and unplugging the 2 temperature sensor plugs.
3. The heater control board was more difficult to remove, I don't know if I did it correctly. Removed the two nuts on the HV wires. Removed the screws holding down the board (there were 4 or 5, I don’t remember exactly). Unsolder the tabs powering the heaters (I think that's what they were). They are the biggest soldering points on the board. There are 9 of them in a line in front of the vertical transistors and two of them next to the large capacitors. You cannot miss them, they are huge. I had a vacuum unsoldering machine, but I think that melting them with a soldering iron and then soaking up the solder with coper mesh would probably work fine.
5. The vertical transistors (I think that they might be IGBTs) can be unsoldered the same way.

Checking the heaters (I am guessing that they are Peltier devices, but not sure) for shorts might be a good idea while you have things apart.
If you buy a new PTC heater assembly (the whole thing instead of repairing), the more recent and updated J version works fine (your original is probably the G version).
Good luck!
 
  • Like
Reactions: terofin

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top