TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

Tesla Motors website now in Italian?

Discussion in 'Tesla Motors' started by jrreno, Apr 27, 2014.

  1. jrreno

    jrreno Nothin' left to do but smile, smile, smile

    Joined:
    Jul 21, 2013
    Messages:
    691
    Location:
    Sarasota , Florida
    When I bring up TeslaMotors website in comes up in Italian?
    It started doing it for shortcuts I had and now it does it even if I type in TeslaMotors.com.
     
  2. EBill

    EBill Member

    Joined:
    Feb 27, 2014
    Messages:
    105
    Location:
    Hong Kong
    I had the same problem when logged into my account. I would start in English and then would all the pages would go to Italian. I notified the sales specialist that was handling my order. He said he would contact web support services. Problem disappeared within 48 hours.

    Suggest contacting your your sales support person or the webmaster for help.
     
  3. bonnie

    bonnie Oil is for sissies.

    Joined:
    Feb 6, 2011
    Messages:
    14,241
    Location:
    Columbia River Gorge
    moderator note: moving this thread to 'Tesla Motors', since this is an issue with teslamotors.com and not site feedback for teslamotorsclub.com.
     
  4. jrreno

    jrreno Nothin' left to do but smile, smile, smile

    Joined:
    Jul 21, 2013
    Messages:
    691
    Location:
    Sarasota , Florida
    I realized this only was happening on my iPad. I cleared cookies and I'm back to English.
     
  5. Doug_G

    Doug_G Lead Moderator

    Joined:
    Apr 2, 2010
    Messages:
    15,853
    Location:
    Ottawa, Canada
    It just went to German for me...
     
  6. MacroP

    MacroP Member

    Joined:
    Jan 12, 2013
    Messages:
    120
    Location:
    West Oz
    #6 MacroP, Apr 28, 2014
    Last edited: May 3, 2014
    Looks like I've turned Swedish myself. Clearing the cookies fixed it thanks.

    Logged into their forum and spam has taken over the General forum area.

    Edit - Looks like their site is playing up again. Now it keeps redirecting me to their Norwegian webpage. And their forum spam is as bad as ever.
     
  7. KenN

    KenN Member

    Joined:
    Feb 25, 2014
    Messages:
    398
    Location:
    North Vancouver, BC
    Question for all of you above: Are you using a non-MSIE browser?

    I've had this same problem crop up, and here is the sequence of events ...

    - do a google search for a topic, click on one of the hits without looking closely at the URL
    - the click takes me to a foreign language version of the Teslamotors.com site. You can tell because the URL appears as (http://www.teslamotors.com/xx_YY/etc/etc/etc), there xx is a two letter code for the language and YY is a two letter code for the country.
    - once I've browsed to the foreign language version of the site once, then I'm locked in and can't get out of the loop. Every time I try to navigate to the tesla site it redirects to that site. For a week I was going to an Italian site (it_CH). I deleted my full browsing history and that worked, but just today I inadvertently hit the Austrian german site (de_AT). I'm stuck again and trying to switch country does nothing but loop back to the Austrian site. I don't want to do a full clear of the browsing history because it purges a lot of username fields that I just spend 3 weeks rebuilding! Purging ONLY Tesla site urls doesn't seem to do the trick.

    But, if I use MS internet exploder it works normally. Maybe Tesla's web coders haven't fully back-tested against other browsers? I do almost all my surfing in Chrome. IE is a pain, won't use it except when I really can't avoid it!

    This also happened on my work computer using Firefox. It's still redirecting to the italian site. Grrr.

    Maybe someone who knows about chrome and other browsers could suggest where I could look "under the hood" to get rid of the re-direct?
     
  8. Larry93428

    Larry93428 Member

    Joined:
    Feb 26, 2014
    Messages:
    371
    Location:
    Cambria California, United States
    My laptop is stuck with Italian, has been for weeks.
    I e-mailed Tesla twice now (from the desktop) but no reply.
    Hope this gets straightened out soon.
     
  9. stopcrazypp

    stopcrazypp Well-Known Member

    Joined:
    Dec 8, 2007
    Messages:
    7,053
    #9 stopcrazypp, May 10, 2014
    Last edited: May 11, 2014
    I can't seem to reproduce this issue (the site correctly redirects me to the US page even if I visit a foreign page first in Google), but I think it may have to do with the sign-in (I don't have a Tesla account). Maybe people can try logging out of their Tesla account before visiting the Tesla home page.

    However, in Chrome, you can look "under the hood" of a specific page (for example, navigate to http://www.teslamotors.com before doing this) by going to Tools > Developer tools > Resources. Then under cookies you should see an entry for http://www.teslamotors.com, which will show all your cookies for this site (which you can right click and delete).

    I notice that the "buy_flow_locale" cookie is set to the foreign page I first visted (it_CH) but I was still able to reach the US page by visiting http://www.teslamotors.com. The other possibility is that the Tesla site figured out my area from my IP. Anyways, if I delete that cookie and refresh the page, it automatically resets it to "en_US".
     
  10. AlexT

    AlexT Member

    Joined:
    Mar 9, 2014
    Messages:
    299
    Location:
    Alphen aan den Rijn
    I've had a similar situation after browsing through some links on Tesla in different languages. Quickly solved by selecting the region (scroll down entirely, you'll see a flag). For reference, I do have an account and log onto the website.
     
  11. KenN

    KenN Member

    Joined:
    Feb 25, 2014
    Messages:
    398
    Location:
    North Vancouver, BC
    Tried many times. Browser just flashes the english site for a fraction of a second, then re-directs to the foreign language site.

    I might add that it only happens when I've logged in. If I log out then I can choose whatever country/language I want.

    - - - Updated - - -

    Thanks ... this seems to be the trick. I also found another cookie named "desired_locale" that was set to the Austrian site. I deleted both and now pointing correcly to english/canadian site.
     

Share This Page