Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Tesla wall connector gen3 overheating fix

pt19713

Active Member
Feb 5, 2020
1,062
1,393
Delaware
I just read that thread for the first time. I have the long cord, too. It would get warm but not “hot.” But aren’t people seeing this issue with the shorter cord too? I wonder if the new units they are sending us are different in any way (thicker cord?).

Also, I saw some voltage drop, too. Looking at my screenshots, I see 234V at 48A and 238-239V at 24A. But I figured that was partly due to the long wire run from my breaker box to the charger (about 60’) or that it was just normal. Touching the 60A breaker the electricians installed I can feel some warmth when the car is charging. But it is not “hot,” just warmer than the other breakers. I know essentially nothing about electrical equipment though. And like everyone else, mine worked fine at 48A until mid-July, then this issue started happening every time.

Tomorrow I’ll try 40A but I’m superstitiously afraid to jinx the 36A which is working well right now.
My issues are occurring with the 18' foot cord. I received it early June 2020, so it's from their 3rd batch, I believe.
The lowest I've seen my voltage drop at 48A has been 227V but it typically hovers around 235-237, depending on ambient temps.
 
Ill chime in now after following thread from start

I recently bought a maxed out Model X in May (love it,...waited 10 years to finally get electric car...pearl white with black 22 inch rims,...I call it "The Orca")...and purchased the gen 3 wall connector.

The HPWC ran great the first month until the down amps to 24A after 45 mins, then down to 6 A. followed by charging interrupted alert on the tesla app. The unit was hot to the touch but I figured maybe that could be normal, so I monitored the situation and only charged during the day so I could unplug.

I then noticed the 3 red light blinks indicating overheating. hmmm....it does feel warm....hardware issue I guess but for the down amps at 45 minutes each time??? maybe firmware.

Every charge would result in same issue so I contacted Tesla support. I figured since the unit originally functioned fine except for the warmth and the down-amps would occur after 45 mins that it was a firmware issue. They analysed the hardware, and checked the car logs and said they would send a new unit.

The sucker showed up less then a day later via Fedex. Not bad! Easy hookup and I sent back the original unit. Now it worked fine the first few charges so I figured instead of going offline so I wouldnt deal with any firmware issues , I would hook up to wifi and let the firmware upgrade,...that way I would find out if it was a firmware problem.

Once again, down amps to 24 A with the 3 red blinks while still charging. The firmware was the latest. I felt the face plate again....this sucker was hot! I couldnt understand it....tesla? space ships? best cars made ? stock rocking....whats up with the wall connector?

I called up support again,...always a nice person,...and we reviewed the issues. Bottom line, there is a defect causing the overheating of the unit, some kind of "pinhole". But the first replacement they sent me a unit that didn't have that fixed.

So they will send me a new unit that they say will have the hardware fix and we will give it a go again.


So, bottom line....its a hardware defect.

Rob from Long Island and very happy with the support
 
Great update Rob...just got my replacement unit today. Quite fiddly to remove the four old screws and put the new ones in, but did it. Charged for 2+ hours at 48A no problem, but on the old firmware version. Am thinking about taking it off line! Expecting it to get updated soon to new firmware and then have the overheating problem reappear. Note both units are the same PN. Clear to me they don't have this under control at all...too busy worrying about everything else going on so they just send out a new one and hope for the best.
 
I tried 40A tonight, after having multiple 36A multi-hour sessions with no problems. After about an hour at 40A, 3 red blinks and it cut power in half to 20A. Dammit.

Last time, holding down the button to broadcast the SSID seemed to reset the unit. So I did that, logged into the HPWC WiFi to see if it reported any alerts on the web interface (there were no alerts), then plugged back in and backed down amps (from inside the car) to 36A again.

It started charging and amps climbed up to 34A but no higher. Weird, right? I hadn’t seen this before. No blinks, just stopping the increase in amps at 34 instead of 36. I realize there probably no real difference but still it bugged me. I got in the car and raised to 40 then back to 36 to see if it could move but the amps didn’t budge in response.

So I unplugged with 11% more to charge. I’ll reset the breaker and give it an hour or two to cool off I guess. Then plug back in and see if it charges at 36A like it had been doing before. I hope I haven’t lost the 36A option.

Botton line, 40A is a no go for me. 36A seems to be my upper limit without the overheating warning.

EDIT - after resetting the breaker and giving it some time, I plugged in and it ramped up to 36A, the ceiling I set. Weird that it wouldn’t go higher than 34A before. I guess I’ll leave it at 36A until a fix is in place. I got a return label via e-mail, so I assume that means a replacement unit will be coming.
 
Last edited:
All,

I was having the "3-red-blink with reduce to 24A" issue, and called the support number (510-249-2490‬ Option 2), went thru some questions/diagnostics and Tesla sent out a new replacement. I did however have a host of backup - from infrared photos to amperage diagnostics - I think the support agent gave up wanting to hear my evidence after I offered a lot of detail to try to help them fix the issue :) . You will receive the return label email first; which I was instructed to ignore packing anything up until the replacement unit arrived, and just ship back in the same box.

Easy to replace, breaker off, 4 hex screws, pop off old, pop in new, power on, re-run commissioning (breaker amperage setting the most important!), and up and running. Note: the black base plate that attaches to the wall/house wiring does not need to be replaced - the white main charger unit that needs to be replaced pushes on to the already mounted back plate. So far so good about 3-weeks in and weather is way hotter than before!

Gen 3 Charger w/18 ft cord:

Old P/N: 1457768-01-F
Old S/N: B7S20090Y00638
Old Firmware: 0.8.58+

New P/N: 1457768-01-F
New S/N: B7S20146Y00078
New Firmware: 0.8.58+ (arrived with 0.8.54+and the unite upgraded next day and continued to operate at my full rating of 40A - on 50A breaker)

Tesla told me that some units responded well to the 0.8.58 software fix, and some like mine didn't (and I suspect maybe some folks didn't notice that their amperage had been reduced as long at it charged their car overnight).

It is unfortunate it happened, and frustrating, but the tech service folks at the 510-249-2490‬ (Option 2) number were helpful and responsive. Don't bother with the main Tesla number as it is simply the wrong starting point and don't know how to handle the call (learned out the hard way).

Hope this helps,
Tom
 
I’m waiting for those with the new wall connectors to let us know if it fixed the issue permanently and the supposed overheating doesn’t return.

I got a return label via email but no wall connector in the mail yet. I may call just to confirm my inquiry is still open and a replacement is on the way, but I’m sure that’s why I got a return label. In the meantime, as I said above, 40A doesn’t work for me. But 36A still seems to be working okay for now (note I’m on a 60A dedicated circuit). The support guy I spoke with last week said several customers aren’t able even to get 36A, so I guess there’s that to be thankful for.
 
Hard to imagine the cord overheating unless there was excessive current through it, something greater than the designed 48 Amps, or they have reduced the size of the conductors in the charging cord. I have a gen 2 charger on an 80 Amp circuit, with charger set for 64 Amp max rate. My 2019 Model X charges at the max of 48 Amps and can charge for hours and the cord will get warm, but not too hot to touch, certainly not blister the insulation. What length charge cord do you have? I have the longer, 20 foot, and any heating is distributed for the length of the cord. Is yours distributed, or are there hot spots on the cord?
 
Not sure what to say...the cord was definitely hot, not warm, but I didn't measure the temperature. There are now perhaps half a dozen places along the cord where it is deformed or blistered or wavy. I have the longer cord version of the GEN 3, 18' I think, and generally the deformations are closer to the unit as it was cooler the closer the cord was to the car. I was charging at 48 A for 4 hours.
 
Does anyone know if these are the same chargers they use at the tesla service center. I was at the cleveland SC center yesterday and they had a bunch of these charging cars outside the garage. My 2017 MX was charging at 24 miles per hour at the SC. I was thinking about getting one to put inside my garage, but it sounds like many people are having problems at home.
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top