TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here:

Three beeps...odometer to zero...then back to normal

Discussion in 'Model X: User Interface' started by BizJet, Aug 28, 2016.

  1. BizJet

    BizJet Member

    May 19, 2016
    Every couple of days, I experience a strange anomaly with my odometer. I hear three quick beeps, the odometer displays zero, and after 3-4 second it goes back to normal. It can happen anytime, but most often about 2 minutes after I pull out of my garage.

    It doesn't affect operation, so I'm not fretting about it. But I'm wondering if anyone else has seen this and/or can explain it.
  2. Blurry_Eyed

    Blurry_Eyed MS Sig #267, MX Sig # 761

    Dec 29, 2011
    Haven't ever experienced this particular issue in our X. Had it since January and are pushing 15,000 miles now. My explanation/guess would be there is either a hardware issue with your X or a firmware module may be corrupt. It is definitely not normal and should be checked out by your service center. Next time it happens, hold down the voice recognition button on the right side of your steering wheel controls and state 'bug report' and verbally give details about the issue with the time it happens. That should send some details to Tesla HQ and the service center can probably review detail the car sends with the bug report. Also let your local service center know the time that the next event happens with the exact time and they can also pull the logs to see if there is anything funny happening.

Share This Page