Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

Tons 'o' errors

bolosky

Member
May 5, 2009
701
591
During the pandemic I haven't had much use for driving the Roadster, so it's mostly been sitting in the garage. Back in August it started having what seemed like periodic data communication problems. The gauges on the instrument panel would sometimes just go to zero and various errors about missing or incorrect data would pop up.

Since I wasn't using the car and it still worked I pretty much ignored it. I figured I'd take it in to Carl Medlock to get it fixed eventually, but for the time being it didn't matter.

It generated a *lot* of errors. When I went into the garage to do something I'd often hear it do the beep indicating a new problem. If I looked in the car, I'd often have to clear as many as a dozen errors before I could get to the underlying VDS screen.

It stopped charging once, but I got it to charge again by disconnecting and reconnecting the power cable. Then a month later it stopped and wouldn't start again. I tried to move the car, but it wouldn't shift into reverse (or anywhere else), the shift buttons just flashed red like they do if you try to put it in park when you're moving. I noticed some of the errors on the VDS had SHFT as their component, so that may have been why.

This seemed bad, so I started texting Carl and we decided it was past time to send the car to him. It wouldn't go into tow mode so it wasn't even going to be easy to get it out of the garage onto the flatbed.

We suspected that the problem was with the CAN bus, since it all seemed to be related to data communication.

When I was in the process of getting a tow company to come out and pick up the car, Carl texted me and asked if I could unplug the VMS and plug it back in. I didn't know how, so he explained it to me and I did.

This completely fixed the problem. It wasn't that the CAN bus was grounded or a connector was loose, it was that something had gone wacky in the computer and it just needed to reboot. Professionally, I'm a computer scientist so it was kind of embarrassing that I didn't think of turning it off and back on again myself. :)

I pulled the logs. From when it started having problems in August to when I rebooted the computer yesterday it had a total of 58,495 errors. That's more than one every 5 minutes for the entire time. So I might have that record now. Woo!

Anyway, the bottom line is that if this happens to you, just power cycle the VMS before you pay to have your car towed.
 

Matteni

Member
Dec 8, 2019
127
138
St. Louis
Great report and glad Carl could help. Question - is the VMS accessed inside the car by the passenger footwell or is it through the front above the passenger footwell? I have read how to and what order to remove the plugs but have never looked for it or attempted.
 

Roadster

JdeMO Powered
Dec 10, 2016
1,510
1,204
SoCal
Passenger footwell. Black then blue... wait 10 sec... then blue then black.

How and where to pull plug / power to the VMS?

VMS reset has fixed many of my car's odd issues as well. I believe the charge door port trick is effectively the same thing.

Also... :eek:
...it had a total of 58,495 errors. That's more than one every 5 minutes for the entire time. So I might have that record now.
 
  • Helpful
Reactions: eHorses

lwinpet

New Member
Sep 13, 2018
3
1
gilroy
went to charge my tesla and the car was dead. the light on the charge door port did not turn on when i opened it. nothing works!

saw this post and located the vms on the passenger footwell. saw the blue and black connectors. however, one problem....the black connector seems to be damaged! the clip is missing or broken.

is there any other way to disconnect them without the clips?

any other way to reboot car?
 

slcasner

Active Member
Feb 20, 2011
1,167
789
Sunnyvale, CA
The clip isn't needed to disconnect the plug, its purpose is to keep the plug from disconnecting. I have found that it's tricky to disconnect those plugs because you have to hold the clip in the open position and exert a significant force to pull the plug loose. There's quite a bit of friction, so I expect the plug would stay in place even with a broken clip.
 
  • Informative
Reactions: IslandRoadster

lwinpet

New Member
Sep 13, 2018
3
1
gilroy
thanks for the advise!!...was able to reboot and the car works great now.

unfortunately, i tried the soft reboot with the charge door port before the vms and now the door broke. i heard something snap off...think the spring behind it fell and now the door does not stay open. oh well....don't think that will be an easy fix.
 

jfischer

Member
Feb 6, 2014
186
246
Houston
As a side note, you
“Might” introduce the GPS rollover issue if you have old firmware in the GPS. The error shows a date that is about 19 or so years earlier. Since the power for the GPS is taken from that VMS connector, rebooting it might require you to flash your GPS with the correct updated firmware.

the thread discussing this issue and the fix

Caution - Annual Service - Car power-down - GPS issue
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top