TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC
Start a Discussionhttps://teslamotorsclub.com/tmc/tags/

Touchscreen Unresponsive?

Discussion in 'Model X: User Interface' started by travwill, Feb 25, 2017.

  1. travwill

    travwill Active Member

    Joined:
    May 1, 2015
    Messages:
    1,199
    Location:
    Chicago, IL
    My touchscreen is unresponsive, gives the warning, about 90% of the time over the last couple months. Has made ownership extremely frustrating at times. I can't operate doors from it, can't do garage door, can't choose media easily, can' change AC to defrost windows at times, turn on defrosters, can't use autopark, enter navigation destinations, etc. I reboot it a lot and it sometimes it is able to be used say 20 seconds or so but then goes unresponsive again - I actually reboot both sometimes but makes no difference. After 3-6 reboots I give up in a day. Sometimes it also reboots itself. At times it works half a day (rare) but usually it says it is unresponsive (but you can see map moving still). I've entered a destination before only to have it go unresponsive after that and have it suck in there for 2-3 days even trying to direct me.

    With all that said, it seems to happen on cold starts I want to say but is unpredictable. The SC tried fix once and just said don't keep anything plugged into USB. They did it again and updated software a few days ago and it just started doing it again. They said the screen doesn't need to be replaced but we'll see. Have another appointment to take it in March 6th. I'm at the point where I really need a permanent fix as my patience is gone with this car doing this - had plenty of other physical issues.

    Question: Is anyone else having this constant issue lately, say past 2 months? It is frustrating as it controls almost all the entire car's best features.

    Appreciate anyone else's insight or similar experience if so.
     
  2. travwill

    travwill Active Member

    Joined:
    May 1, 2015
    Messages:
    1,199
    Location:
    Chicago, IL
    Surprised no one else on here had this issue but oh well.

    Wish me luck, car is in service and they have now decided to replace the MCU/touchscreen. Hope this goes well. I'd expect that to fix the unresponsive issue for good, just hoping no damage occurs and/or left with any rattles or creaks...
     
  3. dprisoner

    dprisoner Member

    Joined:
    Jul 1, 2016
    Messages:
    85
    Location:
    Silly-con Valley
    I must have missed this topic when you first posted it, but I have had frequent system requests to reboot the center console. I am assuming it's more a fault with the current firmware, as I don't recall having to reboot before. I've also had spontaneous rebootings while driving.
     
  4. travwill

    travwill Active Member

    Joined:
    May 1, 2015
    Messages:
    1,199
    Location:
    Chicago, IL
    Mine was always about 95% of the time so maybe more severe. Also we tried about 3 firmware versions and was always the same.

    Will report back though...
     
  5. travwill

    travwill Active Member

    Joined:
    May 1, 2015
    Messages:
    1,199
    Location:
    Chicago, IL
    So far so good, made it home from SC (full 5-6 miles) with no unresponsiveness. Real test is over next couple days. I'd think a whole new MCU will fix this problem.

    In the meantime, I think the only issue is relinking the app to the car, getting "Unknown Error" unless everyone is today...
     
  6. vandacca

    vandacca ReActive Member

    Joined:
    Oct 13, 2014
    Messages:
    3,180
    Location:
    Hamilton
    I'm having the same problem for the past couple of days. I can't seem to connect to the vehicle with the iPhone app. I tried logging out and logging back in, but it wouldn't accept my password until the 5th try. This may be a general issue.
     
  7. travwill

    travwill Active Member

    Joined:
    May 1, 2015
    Messages:
    1,199
    Location:
    Chicago, IL
    Everyone is having the app issue right now so don't worry. It was flaky yesterday and is down today. It should let you login, but may not retrieve your vehicle and certainly will error out after a bit.
     
    • Helpful x 1
  8. travwill

    travwill Active Member

    Joined:
    May 1, 2015
    Messages:
    1,199
    Location:
    Chicago, IL
    FYI, this was my solution from SC and working great now, can finally use the car!

    At the time of Service, continued diagnosis for touchscreen freezing. Created toolbox session and re-esculated session to Service Engineering for assistance. Service Engineering recommending to replaced MCU touchscreen assembly.

    ---------from invoice--------

    Corrections: Media Control Unit - Touch Screen

    Removed and replaced MCU touchscreen assembly. Installed firmware and verified proper operation.

    Parts Replaced or Added
    Part Quantity

    MCU NA PREMIUM - Model S and Model X 1 (1045006-00-C)
     
    • Informative x 1
  9. jaredscottm

    jaredscottm New Member

    Joined:
    Apr 12, 2017
    Messages:
    2
    Location:
    FL
    My Model X had the same issue. It popped up the day after I installed the update (last week or so). Almost always threw the error.

    My vehicle is still in service for more than this, but they supposedly replaced the entire MCU after confirming my problem.

    I believe the issue they still haven't fixed was my auto-present front doors won't work, even AFTER the MCU replacement.. I'm new to the forums, but had posted about my situation on /r/teslamotors on Reddit previously when it all first went down. Going on two weeks without my brand new vehicle :(

    Unresponsive touchscreen woes • r/teslamotors
     
  10. toxicpenguin

    toxicpenguin Member

    Joined:
    Jun 13, 2015
    Messages:
    75
    Location:
    Greenwich,CT


    I'll share my story with the driver side self presenting door. It worked fine for about a month and then just stopped working.
    Sent the car back to Tesla service center and they diagnosed the issue as a faulty body control module. When I got the car back, it worked for a week and same issue "self presented" (pun intended).
    The car went back in (they had it for a week) at which time they diagnosed the issue as a shorting antenna (supposedly the antenna in the door was shorting the entire BCM). They changed out the antenna and the BCM) and since then everything is working perfectly.
    Have your service center check the antenna position when you send the car in.

    Also remember to send BOTH keys. Changing the BCM needs both keys to be paired with the car again. It will save you a trip to the service center to get the second key validated.

    The strange thing was that just the self presenting function was busted. I could still open and close the door via the screen, as well as with the key. That's how they diagnosed it as the antennae. If you have similar symptoms that's probably your issue too.

    Cheers
     
    • Informative x 2
    • Helpful x 1
  11. jaredscottm

    jaredscottm New Member

    Joined:
    Apr 12, 2017
    Messages:
    2
    Location:
    FL
    I picked up my MX yesterday morning. They had both keys, they made sure I brought them originally. I can't recall specifically what the tech had told me, but it sounded very much like what you described as the solution for the auto-presenting doors. They tried to debug the antenna, it wasn't working, so then they replaced the BCM. I don't recall if they replaced the antenna as well, but we'll find out soon.

    So far my touchscreen has been responsive 100% of the time *knock on wood*. Auto present has functioned fine for the past two days as well.

    As I told service, I understand the spirit behind Tesla and the early-adopter mentality, but it's really hard to pay so much for a car and experience this kind of thing. It's also hard to trust the vehicle--but maybe the wound is still raw. The communication, once I made enough noise, has been 5-star, but I feel I had to show them I meant business and wouldn't be taken advantage of, just to receive the level of treatment everyone should be getting.

    Hopefully everything remains in working order!
     
    • Like x 1
  12. travwill

    travwill Active Member

    Joined:
    May 1, 2015
    Messages:
    1,199
    Location:
    Chicago, IL
    Nice, glad the MCU fixed things, it should. Rare that needs replaced. You acted appropriately as I wouldn't call people buying recently or now early adopters at all so expectations on a 100K+ product with profit margins much higher than other cars should be high.
     
  13. toxicpenguin

    toxicpenguin Member

    Joined:
    Jun 13, 2015
    Messages:
    75
    Location:
    Greenwich,CT

    I know exactly what you mean by not being able to trust the car.... since the auto presenting debacle, I almost always instinctively look back at the car as i am walking away to make sure the door is closing/closed behind me, and I'm always wary that the next time i walk up to the car, the door again won't present. But its been 3 weeks with no hitches, so slowly i am starting to move past it. I know this is a first world problem lol, but I guess I got spoiled by the MX!!
     
  14. travwill

    travwill Active Member

    Joined:
    May 1, 2015
    Messages:
    1,199
    Location:
    Chicago, IL
    Good thing is for the door closing, it slams pretty hard. Always listen for it ;-)
     
  15. PimBrokken

    PimBrokken New Member

    Joined:
    Oct 25, 2016
    Messages:
    4
    Location:
    Tilburg The Netherlands
    Since version 17.17.17 (20-5-2017) i also have the problem with the unresponsive touchscreen in my HW2 MX 2017. Just mailed to SC for a solution. Thanks for the info... I also mailed them the invoice from above.
     
  16. Gwgan

    Gwgan Almost a wagon

    Joined:
    Aug 11, 2013
    Messages:
    1,580
    Location:
    Maine
    Just started having the unresponsive touchscreen about 10 minutes into driving since upgrading to 17.18.50.
    I have Tesla log running, and sometimes use the Camper app. Who else have problems using similar apps?
     

Share This Page