Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

TPMS error message: system fault

3 weeks ago, I took my car (2016 MS P90D) to Tesla dealership (paid $200 CAD) for them to diagnose the TMPS module (in the car and sensors) base on the error message. The error message was "Tire Pressure Monitoring System fault"
The error message has been on for the last 2 months when I bought the car and swapped out the 21inch wheels that came with the car with 19 OEM wheels (from my previous model S).

Tesla's tech checked each wheel sensors (their machine and communicate with each individual sensors) and they can talk directly to the TMPS module in the car. However, they can't seem to force/clear the TMPS module to accept a new tires/wheels. The tech scratched his head on this and told me to try putting my winter wheels on to see what would happen.
Really? I paid $200 CAD for you guys and that's your "solution"? LMAO.
I wasn't happy with their $200 CAD "diagnostic" fee and shop on Amazon (based on this thread and few other TMPS threads) for new TMPS sensors just to eliminate.

I replaced the sensors with the Amazon ones (Amazon.com). It cost me $100 USD to pay a US tire shop to install them since none of the Canadian tire shop is willing to touch a Tesla. Then last week, I ended up buying a one year old used OEM sensors and installed them (another $100 USD for labor). And still my car doesn't seem to see them.

After $200 CAD diagnostic fee, $200 USD labor to mount TPMS and $150 USD for OEM used sensors, I'm still back to square one.

My last resort is to wait a few more months to put my winter tires on to see if it sees that. Then my extreme last resort is to buy another set of tires directly from Tesla (this is going to cost ~$2750 USD).
 
I went to service for a few things yesterday and a general "tpms system fault" was one of them. I had the problem during a trip and the error would stay for a few minutes and come back later. They ended up changing one of my sensors but said they couldn't "reprogram" them because the other ones were not OEM. Indeed, my summer wheels are replikas with sensors that that tire shop put in. When I picked the car up it had a tpms error but after driving a few minutes the error cleared.
When I bought those replika wheels the person told me they had "programmed" the sensors for my Tesla, but they did not have my car. I'm not sure what they did but it had worked. It'S possible that the sensors you are currently running were never "programmed" for your car, whatever that exactly entails, and I believe the Tesla tech cannot program those non-OEM ones. If that's your situation, you need to find a tire installer that can program whatever sensors you have in your wheels.
 
I went to service for a few things yesterday and a general "tpms system fault" was one of them. I had the problem during a trip and the error would stay for a few minutes and come back later. They ended up changing one of my sensors but said they couldn't "reprogram" them because the other ones were not OEM. Indeed, my summer wheels are replikas with sensors that that tire shop put in. When I picked the car up it had a tpms error but after driving a few minutes the error cleared.
When I bought those replika wheels the person told me they had "programmed" the sensors for my Tesla, but they did not have my car. I'm not sure what they did but it had worked. It'S possible that the sensors you are currently running were never "programmed" for your car, whatever that exactly entails, and I believe the Tesla tech cannot program those non-OEM ones. If that's your situation, you need to find a tire installer that can program whatever sensors you have in your wheels.

Well, I bought used (one year old) OEM Tesla sensors (part # 1074812-00- B) and them installed 2 days ago and my car still doesn't see it.
 
It's not the sensors...it's the tpms module...does anyone know where the module located?...bad how to change it out...any reprogramming?

Per Tesla's tech procedure/manual, you do have to do some sort of software update/firmware.
1663758681950.png


I have access to service manual (2012-2020 Model S) and found that there are two TPMS modules (Continental and Baolong?) and both are in different location of the vehicle. I have attached a pdf printout of the procedure to my post. I have no idea which TPMS module I have (2016 pre-refreshed Model S).
 

Attachments

  • Module - TPMS - Baolong (Remove and Replace).pdf
    350.9 KB · Views: 46
  • Module - TPMS - Continental (Remove and Replace).pdf
    233.1 KB · Views: 46
Per Tesla's tech procedure/manual, you do have to do some sort of software update/firmware.
View attachment 855067

I have access to service manual (2012-2020 Model S) and found that there are two TPMS modules (Continental and Baolong?) and both are in different location of the vehicle. I have attached a pdf printout of the procedure to my post. I have no idea which TPMS module I have (2016 pre-refreshed Model S).
If you have the TPMS pressures in your instrument cluster you have Continental, otherwise you have Baolong
 
  • Like
Reactions: siamnet

ShawnA

Active Member
Supporting Member
Nov 13, 2017
1,192
996
Edwardsburg, MI
Hi @siamnet ,

You are correct that your car has or should have the Continental System...

When the error message points to a "system" fault it is generally pointing to
the TPMS ECU. In this case it is part 1034601-00-C or 1034601-00-D.
They are relatively inexpensive even from Tesla...
It is located underneath the right rear passenger seat...
It may be accessed more easily by removing one of the "areo" panels
under the car...

Your Tesla Service center should have the programming tool to synchronize
the sensors to the ECU.
It is a fast and easy process...

A problem with this computer is that it is able to store 8 tire addresses...
Think winter and summer...
I do not know how they add and delete but trying this tire and that tire,
and another tire allows for the storage of a mess of junk addresses...

Another problem area is generic sensors...
The car was supplied with and reads 433 MHz sensors.
If you buy a generic sensor, be sure to buy one for 433 MHz and not one
for 315 MHz OR 433 MHz - The mixed possibility sensors have poor performance
and poor reliability in Tesla cars...

Please visit your service center and have them program the TPMS ECU...
It may be as simple as clearing or erasing the junk addresses currently
in the ECU.

I have had good luck buying and programming Sens.it 590883 sensors on Amazon or eBay.
$25 to $29 each...

Good Luck,

Shawn
 
Hi @siamnet ,

You are correct that your car has or should have the Continental System...

When the error message points to a "system" fault it is generally pointing to
the TPMS ECU. In this case it is part 1034601-00-C or 1034601-00-D.
They are relatively inexpensive even from Tesla...
It is located underneath the right rear passenger seat...
It may be accessed more easily by removing one of the "areo" panels
under the car...

Your Tesla Service center should have the programming tool to synchronize
the sensors to the ECU.
It is a fast and easy process...

A problem with this computer is that it is able to store 8 tire addresses...
Think winter and summer...
I do not know how they add and delete but trying this tire and that tire,
and another tire allows for the storage of a mess of junk addresses...

Another problem area is generic sensors...
The car was supplied with and reads 433 MHz sensors.
If you buy a generic sensor, be sure to buy one for 433 MHz and not one
for 315 MHz OR 433 MHz - The mixed possibility sensors have poor performance
and poor reliability in Tesla cars...

Please visit your service center and have them program the TPMS ECU...
It may be as simple as clearing or erasing the junk addresses currently
in the ECU.

I have had good luck buying and programming Sens.it 590883 sensors on Amazon or eBay.
$25 to $29 each...

Good Luck,

Shawn
Thank you. I replaced my summer tires's sensor with Amazon ones and didn't work. I replaced the Amazon ones with OEM tesla sensors and didn't work. I swapped out to my non-summer tire/wheel set. These came from previous owner of the vehicle and I have no idea what sensors (OEM vs replicas, etc.) are on these non-summer set. My car's TPMS is still showing an error.

Base on the remaining variable of what is left to change out as the culprit then it should be the TPMS ECU (as you stated). I don't understand why the Tesla tech didn't replace the ECU or clear the ECU, etc. instead of telling me to buy another set of OEM sensors for the tires during their initial attempt (waste of $200 diagnostic fee and still no solution).
 

ShawnA

Active Member
Supporting Member
Nov 13, 2017
1,192
996
Edwardsburg, MI
Hi @siamnet ,

It's a little more complicated...
The sensors when purchased from Amazon, eBay, Tire Rack, etc are "blanks."
Blank Sensor - Must be programmed before use according to specific vehicle protocol with TPMS scan tools or sens.it programming ...
After they are programmed for your 2016 Tesla Model S, the car ECU memory needs to be cleared or programmed.

There used to be a button "Program/Reset TPMS" in the Tesla Service Menu.
Unfortunately, between releases it was removed and never added back...

It is sad such a "simple" system is such a mystery to mechanics...

Good luck,

Shawn

PS - If you use Mobile Service they can help.
Beware to keep your extra sensors and tires as far away fro your "active work"
as possible. I have been amazed how far the TPMS signal can be read when you
don't want it to be read...
 
Hi @siamnet ,

It's a little more complicated...
The sensors when purchased from Amazon, eBay, Tire Rack, etc are "blanks."
Blank Sensor - Must be programmed before use according to specific vehicle protocol with TPMS scan tools or sens.it programming ...
After they are programmed for your 2016 Tesla Model S, the car ECU memory needs to be cleared or programmed.

There used to be a button "Program/Reset TPMS" in the Tesla Service Menu.
Unfortunately, between releases it was removed and never added back...

It is sad such a "simple" system is such a mystery to mechanics...

Good luck,

Shawn

PS - If you use Mobile Service they can help.
Beware to keep your extra sensors and tires as far away fro your "active work"
as possible. I have been amazed how far the TPMS signal can be read when you
don't want it to be read...

Mobile Service wasn't able to help. They were the first to troubleshoot when I had this problem. They came to my driveway and stated that the sensors were reading correct pressure and was able to communicate to their handheld unit. They told me to go to the service center to have the techs there to "reset"/clear my TPMS ECU.

I made an appointment with the service tech and paid $200 for them to do nothing. They claim that my TPMS ECU was "fine" and my sensors in the wheel were "fine" and told me to try putting on my winter set of wheels. That was their "solution" for me.
 
I had this fault two days ago when I had a new set of winter tires installed. At that time I switched the Tire setting under "Service-Wheels and Tires" to Winter from Summer/All Season. The fault error came up.
I tried the usual Shut Down and Reboot routines, and reset the TPMS sensors without success.
Today I set the Tire setting back to Summer/All Season and got the new tire setup found message. The TPMS system came back online and I then was able to set the Tires setting back to Winter and it works.
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top