TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker and becoming a Supporting Member. For more info: Support TMC

Traction Control UX Bug

Discussion in 'Model S: User Interface' started by SabrToothSqrl, Apr 13, 2017.

  1. SabrToothSqrl

    SabrToothSqrl Active Member

    Joined:
    Dec 5, 2014
    Messages:
    2,497
    Location:
    PA
    I found a bug :p

    Press 'Controls', then driving. Then turn T/C OFF (more fun this way)

    Then, don't press 'disable'. press 'controls'.

    The T/C slider says off, but it's not actually disabled, you just can't see the popup anymore.

    so... it's mostly a UI bug

    someone get on that.
     
  2. tga

    tga Supporting Member

    Joined:
    Apr 8, 2014
    Messages:
    3,002
    Location:
    New Hampshire
    It looks like the controls dialog pops up over the T/C confirmation dialog. If you click the close button on the controls dialog, you'll see the T/C dialog re-appear.

    The bigger issue is YOU CAN'T DISABLE TRACTION CONTROL ANYMORE!?!?!

    For some reason (I don't really know why), I tried to disable traction control this morning. I get the confirmation dialog, and select the disable button, but the slider resets itself to "ON" a second or two later.

    This is a huge bug - I got stuck in a snowbank last winter (with Hakka R2's), and the only way I could get out is by shutting off traction control. If this is a new "feature" of 8.1, it's unacceptable.
     
  3. SabrToothSqrl

    SabrToothSqrl Active Member

    Joined:
    Dec 5, 2014
    Messages:
    2,497
    Location:
    PA
    I can still disable mine. I believe on AWD cars you cannot. You get 'slip start' instead.
     
  4. Captainsin

    Captainsin Member

    Joined:
    Feb 15, 2017
    Messages:
    26
    Location:
    Arizona
    I also cannot disable Traction Control. Have the same thing happen as tga. I called the service center and they had no answer. I wonder if its RWD P85 AP1 related?!?
     
  5. SabrToothSqrl

    SabrToothSqrl Active Member

    Joined:
    Dec 5, 2014
    Messages:
    2,497
    Location:
    PA
    Well, that's no fun. The whole point of a P85 is to turn off T/C and have white smoke pouring from the tires!
     
  6. tga

    tga Supporting Member

    Joined:
    Apr 8, 2014
    Messages:
    3,002
    Location:
    New Hampshire
    After contacting [email protected], the local service center pushed down the latest firmware, 8.1(17.18.50). It fixed the "can't disable traction control" bug I noted, but not the UI bug noted in the OP by @SabrToothSqrl.
     
  7. gabeincal

    gabeincal Enjoying Napa life the electric way

    Joined:
    Jul 5, 2016
    Messages:
    615
    Location:
    Napa, CA, USA
    So I had slip start for the past 2 years or so on my S75 but yesterday I noticed that it is back to traction control. I tried to disable, gives me a UI note that it will be disabled, but then it enables it again automatically in about a second or 2. Anyone else had their slip start taken away for a non-working traction control button?

    IMG_3527.jpeg IMG_3529.jpeg
     

Share This Page

  • About Us

    Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.
  • Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


    SUPPORT TMC