TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

Trip display problem in 7.1

Discussion in 'Model S: User Interface' started by gregincal, Jan 27, 2016.

  1. gregincal

    gregincal Active Member

    Joined:
    Oct 26, 2012
    Messages:
    2,136
    Location:
    Santa Cruz, CA
    Since upgrading to 7.1 a couple days ago my trip display has gone totally wonky. I unplug the car and drive into work in the morning and very quickly the current trip and since last charge displays start showing different distances. The even stranger thing is that they can jump up and down by up to a mile, and I've even seen the distance change by half a mile suddenly when stopped at a light. Has anybody else seen this?

    Here is a screen shot after unplugging and driving into work:

    IMG_1012.jpg
     
  2. sdick3

    sdick3 Member

    Joined:
    Apr 26, 2015
    Messages:
    9
    Location:
    Auckland, New Zealand
    I left home this morning after reading this. And noticed the same thing. There were .2 - .4 km inconsistencies up to 20km from home. Then the range lined up but the wh/km never got to be the same.

    My theory is that it is just rounding errors and mismatched sampling times. These numbers are not constantly updating (microseconds) so some process must sample the current state, calculate the numbers and display them. If they are not the same thread they could get out of sync. But why it would be separate I don't know.

    Then when you manually calculate the wh/km it does not match either because we have only 1 decimal place to work with.
    I also noticed when i reached exactly 25km the Energy App did not show the same number either. With more accuracy it could be displayed correctly but really does it matter?
    They should align over a longer distance which is where it matters.
     
  3. gregincal

    gregincal Active Member

    Joined:
    Oct 26, 2012
    Messages:
    2,136
    Location:
    Santa Cruz, CA
    In my case they don't ever align, and the individual numbers can both increase or decrease at a given time or change while stopped.
     
  4. AWDtsla

    AWDtsla Active Member

    Joined:
    Mar 3, 2013
    Messages:
    2,130
    Location:
    NE
    It has never produced accurate numbers for me even pre 7.1. Not being self-consistent is just the tip of the iceberg.
     
  5. Wulf

    Wulf Member

    Joined:
    Apr 18, 2015
    Messages:
    5
    Location:
    San Francisco, CA
    I've had this issue as well. I didn't occur with 7.0, I only started noticing it with 7.1. It's super-annoying.
     
  6. kseitzberg

    kseitzberg Member

    Joined:
    Dec 21, 2012
    Messages:
    86
    Location:
    Denmark
    It is a known issue - i noticed the same a few days ago, and have logged data since. Today after a long drive my display went totally insane. It didnt update for 6 km - neither the distance - nor the energy consumption. However the average consumption dropped from 192 wh/km to 191 during the same period - without any change in the numbers on the display. I called the service number, and got transferred to the service desk, and had the pleasure of talking to a very service minded technician. I was told right away, that this is a known issue. Just an hour before i shot a video of the energy app jumping forward and back in displaying the consumption, and guess that the tech rep could use the video. I also told (and send data from my TeslaMS server) that I expierience the 6 km without data, and could tell the exact times as these were logged in TeslaMS. According to TeslaMS - and the API I could see that somewhere in the car there were communication - however not on the main display. Range logged by TeslaMS clearly shows that the vehicle is sending the data, so the issue must be within the 2 main CPU's for the system.
    They are investigating further, but as for now they do not have a timeframe for a solution.
     

Share This Page