TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

"Unable to Play" and other problems

Discussion in 'Model S: User Interface' started by wayner, Jul 5, 2016.

  1. wayner

    wayner Active Member

    Joined:
    Oct 29, 2014
    Messages:
    1,586
    Location:
    Toronto
    Since yesterday evening I am having issues with my car. I appear to have a valid LTE connection as my Google Maps are updating. But when I go to play music via Slacker or Tunein it downloads the Track Name and the Album Art but then it says "Unable to Play" right under the line that shows the track download progress and timeline.

    The voice command button doesn't seem to do anything either. And the browser doesn't seem to want to update.

    I tried to switch to Wifi using my iPhone as a hotspot but that doesn't change anything.

    I have rebooted three times by holding down both scroll keys. But that hasn't helped.

    Are there any other types of reboots that I could try, like a harder reboot?
     
  2. zro ltr

    zro ltr Member

    Joined:
    Jul 16, 2014
    Messages:
    67
    Location:
    United States
    Any luck with this yet? I'm having the same "unable to play" problem, also since Monday.
     
  3. wayner

    wayner Active Member

    Joined:
    Oct 29, 2014
    Messages:
    1,586
    Location:
    Toronto
    I am glad to hear that I am not alone - my problem also started on Monday. I have rebooted many times, and I went to the service center yesterday. The service guy couldn't figure it out either and they are scheduling an appointment.

    Are you able to browse the web? I am not.

    But my maps and traffic do update so I must be getting a valid LTE/3G connection. Using wifi doesn't appear to help either.

    I wonder if something changed at Tesla on the back end for Slacker and web?
     
  4. Pluto

    Pluto Member

    Joined:
    Nov 17, 2015
    Messages:
    71
    Location:
    US
    Something to try for further troubleshooting, are you able to change the name of the car (from the T button)? Or access car information from the mobile app? And when you search for something on the map, does it actually find results or ask you to put in address information?

    Also, tips and tricks (including at least one other reboot option) can be found here: Tesla Model S Hidden Features, Tips, Tricks & Tidbits
     
  5. zro ltr

    zro ltr Member

    Joined:
    Jul 16, 2014
    Messages:
    67
    Location:
    United States
    #5 zro ltr, Jul 7, 2016
    Last edited: Jul 7, 2016
    I'm able to change the car's name, browse the web, search in nav, and access the car from the app both on WiFi and 3G. On Slacker, it seems to buffer about 5% of the song, then say "unable to play" under the progress bar. I just made a Tunein account so I'm about to try it.

    Edit: I couldn't log in (which I think is normal), but Tunein works fine. My problem seems to be entirely Slacker.
     
  6. wayner

    wayner Active Member

    Joined:
    Oct 29, 2014
    Messages:
    1,586
    Location:
    Toronto
    I am able to change the name and I am able to log in via the web app and the Remote S app, at least when I am home and on Wifi. Tunein hasn't worked but I have never set up an account - I tried creating an account on a PC and signing in but that but it still doesn't let me log in, but perhaps it takes a while after you create an account.
     
  7. Pluto

    Pluto Member

    Joined:
    Nov 17, 2015
    Messages:
    71
    Location:
    US
    Because Slacker loads the song part of the way and then fails, but TuneIn works, it sounds like your car may not be able to keep a persistent connection going. With TuneIn, it's streaming live audio anyways so it's perfectly fine if the connection drops because it can resume the audio at the same point later. With Slacker, it's always seemed to skip a song if it loses connection (especially when switching from Wifi at home to 3G on the go).

    @wayner Could you try playing from TuneIn a few more times, or keeping the TuneIn stream playing for a while (even though it may still be loading)? You don't need to log in to use it at all.

    With your web browser, I've always experienced a bug where canceling loading a web page seemed to replace the entire page with an error instead of just stopping the download, which is probably what's happening for you (it downloads the page some of the way, but any failed downloads would show an error message afterwards).

    So the problem sounds like persistent Internet connections are being dropped. I don't know what would cause this though.
     
    • Helpful x 1
  8. wayner

    wayner Active Member

    Joined:
    Oct 29, 2014
    Messages:
    1,586
    Location:
    Toronto
    To clarify - it isn't clear to me that Slacker downloads any of the actual song, it downloads the metadata, including the album art and then it says unable to play.

    With TuneIn I get the same unable to play error. And the web browser is still not functional - I don't get an error I just get a blank screen when I try to go to any web page.
     
  9. wayner

    wayner Active Member

    Joined:
    Oct 29, 2014
    Messages:
    1,586
    Location:
    Toronto
    I have a service appointment scheduled for Thursday to fix this problem but it appears that the issue went away after a software upgrade that went through over the weekend. I haven't driven he car too much since then but for two weeks, and after dozens of reboots, I couldn't play music nor use the web browser and that all now looks good.
     

Share This Page