TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

Unable to unlock from app(s)

Discussion in 'Model S: User Interface' started by redi, Feb 23, 2016.

  1. redi

    redi 2013 P85+ with HumanPilot Technology

    Joined:
    Aug 31, 2013
    Messages:
    520
    Location:
    DFW, TX
    Maybe there is an obvious answer I am overlooking: While every other function of the remote app works, I am unable to unlock the car from the Tesla app (or Remote S).

    I am on the last 6.2 release and plan on staying there for the foreseeable future.

    Other functions work fine (horn, lights flash, etc).

    I have rebooted both displays in the car and phone.

    This has been an issue for a while and I am curious if anyone has the problem or has solved it.

    ServiceNA has no idea.
     
  2. BertL

    BertL Active Member

    Joined:
    Aug 19, 2015
    Messages:
    1,600
    Location:
    Carlsbad, CA
    Not going to debate here your decision to stay on 6.2 -- as there is plenty of that in other threads, but as an X-software and technical support kinda guy, the reality likely is as you get further behind in firmware releases, more odd problems may creep up where interfaces to things like the Tesla App (& Remote S or other apps that use the evolving and officially undocumented API) are involved. We know Tesla changed things to introduce Homelink, Summon, etc in both MS firmware, the Tesla App itself, and likely the API. To what degree that involves the door lock logic, or they touched other parts of the API or code that may have broken something interacting with old releases, only Tesla engineers into the bowels of it would perhaps know. I suspect the issue is Tesla does not perform regression testing to ensure everything continues to operate with (much) older firmware releases. Frankly, I wouldn't expect them to, with their standard of pushing new firmware releases out to the fleet, and new Tesla App levels to the App Stores. Sure, customers can continually decline installing a new firmware release in their MS or not updating from the App Store, but that doesn't mean Tesla will or must ensure everything continues to operate with the growing number of code combinations that have ever existed.

    All that being said, posting here to find another 6.2 owner was probably a good move. The other thing I'd suggest, is post which App (iPhone or Android) and what release of the Tesla App you are using -- there have been several, and you need to find an owner matching both sides of the equation to really come to a conclusion if it's just you or the specific combination causing issues. Good luck.
     
    • Informative x 1
  3. redi

    redi 2013 P85+ with HumanPilot Technology

    Joined:
    Aug 31, 2013
    Messages:
    520
    Location:
    DFW, TX
    #3 redi, Feb 23, 2016
    Last edited: Feb 23, 2016
    Thanks. All that being said, I don't believe it unlock has ever worked for me since the feature was released, regardless of version, iOS version, or app version.

    I would also generally agree that Tesla's regression testing might be limited, but I could not imagine they could skip regression testing software across releases particularly since they are dealing with a 5000lb missle and all the inherent liability and regulatory concerns around the globe.

    I did find some reference to what may be some (firmware-independent?) OTA fix. Unfortunately no one so far in "service" has been aware of this and I will likely just put it on the list for the next service center visit as it is not worth the trek and trouble for this issue alone.

    Can't unlock with iPhone app | Tesla Motors
     
  4. ITSELE

    ITSELE Member

    Joined:
    Jan 25, 2013
    Messages:
    68
    Location:
    Goodyear, AZ
    I am having the same problem now with the latest 7.1 firmware update. 2015 Model S P85D and cannot unlock car from app. Rebooted car display and dash, rebooted phone, deleted and reinstalled tesla app, turned remote access off and on in car, turned off and on always connected option. Tried from my wife's phone. Car on strong wifi or cellular. Cannot unlock car, everything else works on iPhone app I'm bringing car in for service next week for Ludicrous upgrade and will add it to the list. I read above linked thread and it looks like Tesla needs to fix it and no amount of rebooting, reinstalling will help. Of note, I had to have my display replaced at the last visit so maybe that had something to do with it?
     
  5. redi

    redi 2013 P85+ with HumanPilot Technology

    Joined:
    Aug 31, 2013
    Messages:
    520
    Location:
    DFW, TX
    Please have them tell you the details of the fix, it may be handy to keep the fumbling to the minimum for my debugging. My symptoms are exactly the same, and my display has been replaced twice over the lifetime, and out at least one more time for the LTE upgrade.
     
  6. ITSELE

    ITSELE Member

    Joined:
    Jan 25, 2013
    Messages:
    68
    Location:
    Goodyear, AZ
    I won't mess with the settings now until I bring it to Tesla Service next week. I also had the LTE upgrade along with the display replacement so our problems are the same. I'll be sure to post here when I have an answer.
     
  7. redi

    redi 2013 P85+ with HumanPilot Technology

    Joined:
    Aug 31, 2013
    Messages:
    520
    Location:
    DFW, TX
    Any update on this problem? Mine still will not unlock from any app.

    I'm scheduled to check it on my annual next month.
     
  8. faughtz

    faughtz Model S P85DL

    Joined:
    Jan 4, 2015
    Messages:
    88
    Location:
    Los Angeles
    I cannot remotely unlock my car either. I did not try it for over a year and after a center display replacement (mine was damaged during the LTE update) is when I noticed this. Lights and horn work. I also can't remotely start the car- can you?
     
  9. redi

    redi 2013 P85+ with HumanPilot Technology

    Joined:
    Aug 31, 2013
    Messages:
    520
    Location:
    DFW, TX
    Common theme seems to be LTE upgrade and some sort of damage in the process of getting the center display pulled out and reinstalled. I have had the center display replaced (iirc) twice.
     
  10. faughtz

    faughtz Model S P85DL

    Joined:
    Jan 4, 2015
    Messages:
    88
    Location:
    Los Angeles
    Can you start your car remotely?

    I'm wondering if there is something uniquely related to security with the unlock and start functions.
     
  11. redi

    redi 2013 P85+ with HumanPilot Technology

    Joined:
    Aug 31, 2013
    Messages:
    520
    Location:
    DFW, TX
    #11 redi, Sep 29, 2016
    Last edited: Sep 29, 2016
    I do appear to be able to start the car remotely. Just not get into it.

    Of course it is impossible to tell if the car is "started" when it is locked up tight and display off. But if the door is open it says the car is started and has the little 2 minute countdown timer going.

    And even more curiously, I can lock the car from the app if it is open.
     
  12. faughtz

    faughtz Model S P85DL

    Joined:
    Jan 4, 2015
    Messages:
    88
    Location:
    Los Angeles
    I can remotely lock.
    I've seen the timer also. But if the car is unlocked, and I place the key far away, do a remote start, and step on the brake during the 2 min countdown, I can't drive. I had the SC look at this and the inability to remotely unlock and they said they had never seen it before. They questioned some of my mods, dash cam, CAN device, rear appliqué, and of course I can't prove those devices are not interfering. But I doubt it.
     
  13. redi

    redi 2013 P85+ with HumanPilot Technology

    Joined:
    Aug 31, 2013
    Messages:
    520
    Location:
    DFW, TX
    I have no mods. They've had the MCU out several times and also (iirc) replace some of the upper panel top cover as it was buggered up during the MCU replacement.

    I seem to recall app unlock working in the distant past. But I don't use it much and consider it a failsafe for a lost or dead key.
     
  14. faughtz

    faughtz Model S P85DL

    Joined:
    Jan 4, 2015
    Messages:
    88
    Location:
    Los Angeles

    I always considered it a backup, never tried it. Had the car more than 18 months and tried it, only to have it not function.
     
  15. bob_p

    bob_p Member

    Joined:
    Apr 5, 2012
    Messages:
    939
    I'm finding it much more difficult for the mobile app to even access the car - most of the time, it cannot connect, after multiple tires - and I have the "sleep mode" disabled during the day.
     
  16. redi

    redi 2013 P85+ with HumanPilot Technology

    Joined:
    Aug 31, 2013
    Messages:
    520
    Location:
    DFW, TX
    Mine was fixed yesterday by a Ranger and a an update with a laptop in about 10 minutes. Had not been working for quite a while. When I see the service invoice I'll update with any details.
     
  17. faughtz

    faughtz Model S P85DL

    Joined:
    Jan 4, 2015
    Messages:
    88
    Location:
    Los Angeles
    Please, I have the same issue.
     

Share This Page