Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register

UniFi WiFi connection issues, any ideas?

DJP31

Active Member
Aug 30, 2015
1,657
1,065
UK
This is puzzling both me and my IT guy. My old Model S which only supported 2.4ghz connected to my office UniFi wifi without a problem.

My new MS won't connect, giving the error as per attached pic. The only difference is the new car supports 5ghz. We have checked the channel is between 1-11, there's no splash page, the passwords are the same as before. The UniFi has two AP's running as a mesh.

IT guy has set up two separate SSID's with different names, one on 2.4ghz the other 5ghz. The car rarely finds either of them, and is inconsistent about finding our usual wifi. It will find others, and happily connects at home or if I use my phone as a hotspot.

It's hardly the end of the world but is very frustrating, especially when nothing in the network has changed.

I'm not a techie but try my best, go easy on the answers please o_O



InkedInkedIMG_2638_LI.jpg
 

Krokkodillo

Member
Dec 11, 2016
56
16
UK
Its a bit odd, having two separate ssid should work fine with backwards compatibility. Maybe try to merge 2.4 and 5ghz into one ssid?
 

DJP31

Active Member
Aug 30, 2015
1,657
1,065
UK
Its a bit odd, having two separate ssid should work fine with backwards compatibility. Maybe try to merge 2.4 and 5ghz into one ssid?

Apparently the UniFi kit does that automatically and something called band steering. It wouldn't connect then either, which was where the advice to establish two SSID's came from.
 

VanillaAir_UK

Supporting Member
Jun 17, 2019
7,705
5,164
Surrey, UK
You didn't say whether your IT guy had deactivated the appropriate circuit using a contactor to prevent the electrons flowing then 10000ms later, reenergise the circuit to 230v -6%/+10% using said contactor :D
 
  • Funny
Reactions: DJP31

Krokkodillo

Member
Dec 11, 2016
56
16
UK
It looks like UniFi is using custom popup to connect to your WiFi, try to connect to it from a laptop to see if you get a custom popup in a browser (obviously forget the WiFi beforehand).
 

rotor2k

Member
Sep 16, 2019
488
255
London
Isn’t that error very clearly reporting that the wifi connection has a captive portal? (Like when you connect to a public wifi network and they force you to accept the terms and conditions before you can do anything). It’s called Hotspot in UniFi parlance - that needs to be off. I have UniFi at home and it works fine, single SSID, my M3 always connects on 5GHz (weakly, but happily). Band steering is notoriously finicky and you should get your guy to turn it off - it causes more problems than it is worth. He should also configure a single ssid as this allows wifi clients to choose the best channel for the conditions (5GHz is great when you are very near the access point, 2.4GHz for everything else). He should he setting the 2.4GHz channel transmission power to medium or low, and 5GHz to Auto or High. Tell him to turn off the fancy “Advanced - only enable this if you know what you are doing” section, it is a lot more trouble than it is worth. I know it is tempting to turn on everything that says “fast” and “advanced”, but wifi is an extremely fickle thing, each client presents unique challenges, and the more you deviate from plain vanilla, the more issues you run into.

A few more things for him to check (the DTIM Period tweak makes a big difference for modern devices, also note all the things that are switched off are switched off for a reason):

upload_2020-9-18_11-10-22.jpeg
upload_2020-9-18_11-10-22.jpeg
 
  • Informative
Reactions: arcus

DJP31

Active Member
Aug 30, 2015
1,657
1,065
UK
It looks like UniFi is using custom popup to connect to your WiFi, try to connect to it from a laptop to see if you get a custom popup in a browser (obviously forget the WiFi beforehand).

Thanks for this, no pops up other than the usual p/w request. Other devices have successfully connected to the new SSID's so it's definitely the car.
 

Jason71

Active Member
May 8, 2019
2,651
2,423
Shropshire
If you get really desperate you can always get another router to use as a buffer. I have a cheap portable one I take with me on holidays connect it to the hotel wifi then create my own network in the room that everything can connect to.
I know it shouldn't be needed but it you really need the car to connect for some reason its a viable workaround.
Samsung Galaxy S phones have this capability as well since the S7. Last time I checked they were the only phones which do have wifi sharing
 

hmy7k

Member
Nov 7, 2019
94
61
Shropshire
My MP3 connects to mu Unifi network fine, I have two separate SSID's too.

Have you got the guest portal set up, it may be asking the car to login to access this?
 

LongRanger

Active Member
Jan 11, 2020
1,317
1,198
Wales
If UniFi is using mobile broadband (via its own SIM card) to provide data, I had this issue recently through my router where I had swapped SIMs to another network, manually set the APN profile - then when I swapped back it was still trying to use EE’s APN instead of Vodafone.

If you aren’t using mobile broadband then obviously ignore the above, if you are then double-check APN settings for Mobile/WAN.
 

DJP31

Active Member
Aug 30, 2015
1,657
1,065
UK
@Jason71 I’m defo not desperate as the car connects at home quite happily, it’s more the fact that it won’t connect when the old car did, and nothing has changed apart from that.

Thanks to others for contributions, they’ve all been looked at. A right old mystery o_O
 

nexusone

Member
Mar 23, 2018
107
83
California
Enabling/disabling of bands is also on a per AP basis, not an SSID basis. Unifi such a mixed bag in so many ways. Make sure the the SSID is bound to all the APs, and that each AP is properly configured for each SSID. Here at home I also have multiple SSIDs. It works fine. Make sure it is NOT configured as a guest (this is a defined network type in unifi). Make sure it is doing standard password/key authentication and not asking for a username or using a captive portal.

Lastly: your IT guy sucks. Keep him away from anything important to you. This is really basic networking.
 
  • Funny
Reactions: Den tuverneir

DJP31

Active Member
Aug 30, 2015
1,657
1,065
UK
Enabling/disabling of bands is also on a per AP basis, not an SSID basis. Unifi such a mixed bag in so many ways. Make sure the the SSID is bound to all the APs, and that each AP is properly configured for each SSID. Here at home I also have multiple SSIDs. It works fine. Make sure it is NOT configured as a guest (this is a defined network type in unifi). Make sure it is doing standard password/key authentication and not asking for a username or using a captive portal.

Lastly: your IT guy sucks. Keep him away from anything important to you. This is really basic networking.

Thanks for your input. He's been brilliant for 20 years so I'll ignore the last piece of advice. :)
 
  • Like
Reactions: CPhoenix

DSolie

Pew Pew
Jul 2, 2020
298
641
Olympia, WA
Have your IT guy create a new wireless network, with a stupid easy PW and all guest controls turned off. Make sure there is no guest/splash screen to accept terms to sign-in to your wireless network. Troubleshoot from there.

Our UI network at work and mine at home have ZERO issues connecting to our UI network. CKG2+, USG and multiple UAP-AC-Pro's in the deployment.

ut4YUdV.png
 

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top