Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.

Unknown characters in Google Map address causing Tesla to crash infinitely (WARNING: don't try this)

WARNING: This may put your car in infinite crash->reboot cycle and requires a factory reset. Proceed at your own risk.

If Tesla can not display certain characters (perhaps due to font not available) it will crash. This happens in Google Map navigation as well as contact names in the Phonebook. This was reported widely when owners in Taiwan tried to go to a famous eatery and MCU went into endless reboot cycle. You can still drive as MCU is separate from the drive unit, but you won't be able to use navigation text search until a factory reset to clear the navigation history. I suspect last weekend Tesla HQ was flooded with 'MCU crash' notifications from half of owners in Taiwan who tried to replicate this bug (and didn't realize the problem persists after the reboot). :confused:

(moderator note: removed link)

Don't try unless you're prepared to factory reset your car and clear user profiles/bluetooth pairing/navigation history etc.

The question is, apart from factory reset or waiting for an OTA fix, is there any other way to remove the navigation history so that it will not crash every time the history is opened?
  • Informative
Reactions: KenC
(moderator note: OP I removed the link, since you state it has the capability of causing a boot loop on a tesla, I didnt see a need for it to be here. Others can theoretically find it somewhere else.)
The problem character is Unicode U+29D5A and any names with this will cause the problem. I suspect there are more problem characters that haven't been found yet.