Welcome to Tesla Motors Club
Discuss Tesla's Model S, Model 3, Model X, Model Y, Cybertruck, Roadster and More.
Register
  • TMC Podcast #11 will stream live Saturday at 1PM PDT. We will be joined by special guest JT Stukes, a former engineer at Tesla. You can watch it live and participate in the chat on YouTube. We will addressing viewer comments and questions. For more information, follow the TMC Podcast #11 thread.

Upgrade (to HW3.0) fate of AP.2.0 owners who purchased FSD?

I was upgraded today from AP2.0 to AP3.0 with MCU1. The biggest surprise is dashcam recording now works. I thought MCU2 was needed for that. I am making a 3200 mile drive next week. We'll see how it goes. I am an original owner with FSD purchased when it came available 10/2016. Build 11/2016. Delivery 12/2016. I received an invitation to be updated and didn't need to separately schedule for the upgrade.
 
I was upgraded today from AP2.0 to AP3.0 with MCU1. The biggest surprise is dashcam recording now works. I thought MCU2 was needed for that. I am making a 3200 mile drive next week. We'll see how it goes. I am an original owner with FSD purchased when it came available 10/2016. Build 11/2016. Delivery 12/2016.
Great to hear! I'm scheduled for this as well. Are the dashcam videos black and white or color?
 
Just got mine back today also (mcu1 as well). Other than dash cam and the toggle for traffic signal (beta) I honestly can’t tell the diff. Anything I’m missing ?
Those are pretty big items. ap2.0 didn't have dashcam at all and the stop lights and signs works great. Seems like the next big step to feature complete. I would assume navigate on non-highway roads is next.
 
Just checked them out. The front and both side cameras were color. I thought all ap2.0 side cameras were black and white. No rear camera recording though.
That’s good news. Amazing that so many forum posts stated the cameras on our 2.0 cars were black and white and did so with seeming authority. It appears that dash cam activation is the only visible improvement for us so far (at least In Canada). Wonder if we will ever see the autopilot visualizations (stop signs etc.) without spending more to upgrade the media computer?
 
Just checked them out. The front and both side cameras were color. I thought all ap2.0 side cameras were black and white. No rear camera recording though.

That’s good news. Amazing that so many forum posts stated the cameras on our 2.0 cars were black and white and did so with seeming authority. It appears that dash cam activation is the only visible improvement for us so far (at least In Canada). Wonder if we will ever see the autopilot visualizations (stop signs etc.) without spending more to upgrade the media computer?
They are not black and white.
Did you see the videos posted: Honolulu SC just completed my MCU2 Upgrade

3ikJBSP.jpg
 
That’s good news. Amazing that so many forum posts stated the cameras on our 2.0 cars were black and white and did so with seeming authority. It appears that dash cam activation is the only visible improvement for us so far (at least In Canada). Wonder if we will ever see the autopilot visualizations (stop signs etc.) without spending more to upgrade the media computer?
The stop sign and stop light visualizations work as well. The feature works quite well. The only visualization I think is missing is the traffic cones. Not a big deal.
 
The stop sign and stop light visualizations work as well. The feature works quite well. The only visualization I think is missing is the traffic cones. Not a big deal.
Visualizations work with MCU1 and HW 3.0? I always could see cars, trucks etc.. Stop lights, signs and cones I’ve been told can’t be seen without an upgrade of the media computer... at least that is what is being reported in Canada.
 
Visualizations work with MCU1 and HW 3.0? I always could see cars, trucks etc.. Stop lights, signs and cones I’ve been told can’t be seen without an upgrade of the media computer... at least that is what is being reported in Canada.
If the stop light and sign functionality has been released in Canada, then the signs and lights will work. Works for me in the US.
 
Let me add a small amount of data to the mix.

I am scheduled for the upgrade and I am also going to upgrade the computer. Note: this has NOT been done yet.

However, on 2 separate occasions, my Instrument Cluster screen (smaller screen) has shown a red traffic light indicator when I have gone through a yellow/red light. On one occasion the car warned me and on the other the red dot (only a red dot, not the entire traffic signal icon) remained on the dash until I turned off the car (this may be evidence that MCU1 can't handle all the data, I'm not sure).

Anyway, I thought it was interesting that my car is not only seeing, but also occasionally showing traffic light visulation without HW 3.0 nor MCU2.

Mine is a 12/2016 Order - 2/2017 Delivery.
 
FWIW, just got my 2017 AP2 and MCU1 upgraded to AP3 and MCU2 (I had bought FSD and AP back in 2017). The invoice clearly states that screen is not swapped (NOREPLACE) with a new one and only MCU is. They did fix the yellow border around the screen which was not that noticeable but it was there. I had to literally hound the service center as they kept cancelling my appointment for the upgrades

Got the full visualizations, theater mode (Netflix etc), dashcam, sentry etc and all the other goodies. Screen is very responsive. I am in Northern Virginia btw.

Also to add, the older MCU2 regularly showed traffic lights when on AP if I was about to jump a red light and it would alert me to take over
 

ABC2D

Active Member
Dec 19, 2016
1,147
1,589
Home
Let me add a small amount of data to the mix.

I am scheduled for the upgrade and I am also going to upgrade the computer. Note: this has NOT been done yet.

However, on 2 separate occasions, my Instrument Cluster screen (smaller screen) has shown a red traffic light indicator when I have gone through a yellow/red light. On one occasion the car warned me and on the other the red dot (only a red dot, not the entire traffic signal icon) remained on the dash until I turned off the car (this may be evidence that MCU1 can't handle all the data, I'm not sure).

Anyway, I thought it was interesting that my car is not only seeing, but also occasionally showing traffic light visulation without HW 3.0 nor MCU2.

Mine is a 12/2016 Order - 2/2017 Delivery.
That's not traffic visualization you're describing, if I understood correctly, but stop signs and red light detection while auto-steering is engaged - no HW3 or MCU2 is required for that, works on MCU1/HW2
 
Let me add a small amount of data to the mix.

I am scheduled for the upgrade and I am also going to upgrade the computer. Note: this has NOT been done yet.

However, on 2 separate occasions, my Instrument Cluster screen (smaller screen) has shown a red traffic light indicator when I have gone through a yellow/red light. On one occasion the car warned me and on the other the red dot (only a red dot, not the entire traffic signal icon) remained on the dash until I turned off the car (this may be evidence that MCU1 can't handle all the data, I'm not sure).

Anyway, I thought it was interesting that my car is not only seeing, but also occasionally showing traffic light visulation without HW 3.0 nor MCU2.

Mine is a 12/2016 Order - 2/2017 Delivery.
I guess it's a Canadian thing. I've never seen stop lights, signs or cones. I do see cars, trucks, motorcycles, bicycles and pedestrians. July 2017 delivery of MX with enhanced AP but paid for FSD when on sale last year. 3.0 chip next week.
 

Yinn

Active Member
Nov 15, 2016
2,100
1,926
Behind you
I guess it's a Canadian thing. I've never seen stop lights, signs or cones. I do see cars, trucks, motorcycles, bicycles and pedestrians. July 2017 delivery of MX with enhanced AP but paid for FSD when on sale last year. 3.0 chip next week.

Not a Canadian thing. I’ve seen it as well, and posted about it about a year ago. it’s insanely difficult to reproduce but meant to indicate that you’ve run a red light. Seen on a 2016 w/EAP.

Now that I’ve upgraded, I can also state it’s completely different than the traffic light visualization of MCU2 which also sees traffic lights. MCU2 puts them on the display according to approximate location of the light and status. The former is a static location meant to only to indicate, does not have an effect on autopilot but seems to be preparation for safety features as it beeped at me (even though it was an incorrect reassign)
 
  • Like
Reactions: Forty Creek
Now that I’ve upgraded, I can also state it’s completely different than the traffic light visualization of MCU2 which also sees traffic lights. MCU2 puts them on the display according to approximate location of the light and status. The former is a static location meant to only to indicate, does not have an effect on autopilot but seems to be preparation for safety features as it beeped at me (even though it was an incorrect reassign)
The functionality you mention is available on hw3 with mcu1.it is not an MCU2 requirement
 

Products we're discussing on TMC...

About Us

Formed in 2006, Tesla Motors Club (TMC) was the first independent online Tesla community. Today it remains the largest and most dynamic community of Tesla enthusiasts. Learn more.

Do you value your experience at TMC? Consider becoming a Supporting Member of Tesla Motors Club. As a thank you for your contribution, you'll get nearly no ads in the Community and Groups sections. Additional perks are available depending on the level of contribution. Please visit the Account Upgrades page for more details.


SUPPORT TMC
Top