TMC is an independent, primarily volunteer organization that relies on ad revenue to cover its operating costs. Please consider whitelisting TMC on your ad blocker or making a Paypal contribution here: paypal.me/SupportTMC

Upper Cubby Re-Attachment

Discussion in 'Model S' started by MJPatience, Apr 30, 2014.

  1. MJPatience

    MJPatience New Member

    Joined:
    Apr 30, 2014
    Messages:
    2
    Location:
    Canada
    Was taking a peek around the car and detached the "upper cubby" (The cubby just below the screen) and have been unable to re-attach it. Anyone been in the same situation. It has 4 clips but the back 2 clips are a real annoyance to try and get in, and to be honest I'm not even sure that I'm doing it right.

    Anyone have tips on the best way to re-attach it?
     
  2. steve841

    steve841 Active Member

    Joined:
    Jan 17, 2010
    Messages:
    1,397
    Location:
    Ft. Lauderdale, FL
    The SC changed out my MCU and left the cubby hanging. It was a pain to pop back in place. But don't push from the bottom, put your hand inside the cubby and push up. I seem to recall it attached at the front then rear (relative to car) with a lot of pressure and no good place for leverage.
     
  3. 4SUPER9

    4SUPER9 Active Member

    Joined:
    Jun 6, 2013
    Messages:
    1,324
    Location:
    California
    I had the same problem with my cubby. I simply could not get it back on. I asked the same question on this forum, and everyone stated that I needed to take the side panels off to re-install. I gave up and drove to my local SC. They re-installed exactly that way. Even though they knew it was entirely my fault, they fixed it, not even bothering to write up a ticket.
     
  4. MJPatience

    MJPatience New Member

    Joined:
    Apr 30, 2014
    Messages:
    2
    Location:
    Canada
    Thanks everyone! Looks like I'll just take it back to the shop.
     

Share This Page